Bug 315493 - Rekonq crashes when loading a page
Summary: Rekonq crashes when loading a page
Status: RESOLVED DUPLICATE of bug 312990
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1
Platform: Fedora RPMs Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-20 05:39 UTC by Brallan Aguilar
Modified: 2013-02-20 15:32 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brallan Aguilar 2013-02-20 05:39:16 UTC
Application: rekonq (2.1)
KDE Platform Version: 4.9.5
Qt Version: 4.8.4
Operating System: Linux 3.7.8-202.fc18.i686 i686
Distribution (Platform): Fedora RPMs

-- Information about the crash:
- What I was doing when the application crashed: My connection was interrumpted while loading a web page. When I close rekonq, the error appeared.

-- Backtrace:
Application: rekonq (rekonq), signal: Segmentation fault
Using host libthread_db library "/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0xb76fd9c0 (LWP 3262))]

Thread 5 (Thread 0xb6547b40 (LWP 3263)):
#0  0xb7736424 in __kernel_vsyscall ()
#1  0x4b8ae18c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:171
#2  0x45c70a89 in WTF::TCMalloc_PageHeap::scavengerThread (this=this@entry=0x463e5fe0 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:2495
#3  0x45c70b80 in WTF::TCMalloc_PageHeap::runScavengerThread (context=0x463e5fe0 <WTF::pageheap_memory>) at wtf/FastMalloc.cpp:1618
#4  0x4b8aaaff in start_thread (arg=0xb6547b40) at pthread_create.c:308
#5  0x4b7e109e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:132

Thread 4 (Thread 0xb5c1eb40 (LWP 3264)):
#0  0x4b8cadad in __GI_clock_gettime (clock_id=1, tp=0xb5c1dfa8) at ../sysdeps/unix/clock_gettime.c:115
#1  0x4166ecc6 in do_gettime (frac=0xb5c1dfa0, sec=0xb5c1df98) at tools/qelapsedtimer_unix.cpp:123
#2  qt_gettime () at tools/qelapsedtimer_unix.cpp:140
#3  0x4175860f in QTimerInfoList::updateCurrentTime (this=0xb5c1e028) at kernel/qeventdispatcher_unix.cpp:354
#4  0xb5302074 in ?? ()

Thread 3 (Thread 0xaf176b40 (LWP 3317)):
#0  0xb7736424 in __kernel_vsyscall ()
#1  0x4b8ae18c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:171
#2  0xafef778f in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#3  0xafabc695 in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#4  0xafef7a4c in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#5  0xafef80f6 in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#6  0x4b8aaaff in start_thread (arg=0xaf176b40) at pthread_create.c:308
#7  0x4b7e109e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:132

Thread 2 (Thread 0xae975b40 (LWP 3318)):
#0  0xb7736424 in __kernel_vsyscall ()
#1  0x4b8ae18c in pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/i386/i486/pthread_cond_wait.S:171
#2  0xafef778f in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#3  0xafabc695 in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#4  0xafef7a4c in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#5  0xafef80f6 in ?? () from /usr/lib/flash-plugin/libflashplayer.so
#6  0x4b8aaaff in start_thread (arg=0xae975b40) at pthread_create.c:308
#7  0x4b7e109e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:132

Thread 1 (Thread 0xb76fd9c0 (LWP 3262)):
[KCrash Handler]
#7  data (this=0x610062) at /usr/include/QtCore/qsharedpointer_impl.h:587
#8  Application::eventFilter (this=0xbff7e868, watched=0x8675c58, event=0xbff7e13c) at /usr/src/debug/rekonq-2.1/src/application.cpp:465
#9  0x4172520e in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8672d20, receiver=0x8675c58, event=0xbff7e13c) at kernel/qcoreapplication.cpp:1056
#10 0x41ef203e in QApplicationPrivate::notify_helper (this=0x8672d20, receiver=0x8675c58, e=0xbff7e13c) at kernel/qapplication.cpp:4558
#11 0x41ef6bd5 in QApplication::notify (this=0x8672d20, receiver=0x8675c58, e=0xbff7e13c) at kernel/qapplication.cpp:4423
#12 0x42d7ba82 in KApplication::notify (this=0xbff7e868, receiver=0x8675c58, event=0xbff7e13c) at /usr/src/debug/kdelibs-4.9.5/kdeui/kernel/kapplication.cpp:311
#13 0x4172508e in QCoreApplication::notifyInternal (this=0xbff7e868, receiver=0x8675c58, event=0xbff7e13c) at kernel/qcoreapplication.cpp:946
#14 0x41ef663c in sendSpontaneousEvent (event=<optimized out>, receiver=<optimized out>) at ../../src/corelib/kernel/qcoreapplication.h:234
#15 QApplication::setActiveWindow (act=0x8675a20) at kernel/qapplication.cpp:2641
#16 0x41f7bb92 in QApplication::x11ProcessEvent (this=0xbff7e868, event=0xbff7e49c) at kernel/qapplication_x11.cpp:3639
#17 0x41fa4a85 in x11EventSourceDispatch (s=0x8673318, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:148
#18 0x4ba3a15b in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#19 0x4ba3a500 in g_main_context_iterate.isra.22 () from /lib/libglib-2.0.so.0
#20 0x4ba3a5e2 in g_main_context_iteration () from /lib/libglib-2.0.so.0
#21 0x41757ad2 in QEventDispatcherGlib::processEvents (this=0x86420e8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#22 0x41fa470b in QGuiEventDispatcherGlib::processEvents (this=0x86420e8, flags=...) at kernel/qguieventdispatcher_glib.cpp:207
#23 0x41723b2d in QEventLoop::processEvents (this=this@entry=0xbff7e798, flags=...) at kernel/qeventloop.cpp:149
#24 0x41723e29 in QEventLoop::exec (this=0xbff7e798, flags=...) at kernel/qeventloop.cpp:204
#25 0x4172936b in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1218
#26 0x41eefee5 in QApplication::exec () at kernel/qapplication.cpp:3823
#27 0x411292f5 in kdemain (argc=1, argv=0xbff7e954) at /usr/src/debug/rekonq-2.1/src/main.cpp:235
#28 0x0804872c in main (argc=1, argv=0xbff7e954) at /usr/src/debug/rekonq-2.1/i686-redhat-linux-gnu/src/rekonq_dummy.cpp:3

This bug may be a duplicate of or related to bug 312990.

Possible duplicates by query: bug 314761, bug 314015, bug 313898, bug 312990.

Reported using DrKonqi
Comment 1 Andrea Diamantini 2013-02-20 15:32:29 UTC

*** This bug has been marked as a duplicate of bug 312990 ***