Bug 315033 - Crashes on pressing Send To... button
Summary: Crashes on pressing Send To... button
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Runtime (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-13 03:58 UTC by Avihay
Modified: 2018-02-04 11:17 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Avihay 2013-02-13 03:58:03 UTC
Application: ksnapshot (0.8.2)
KDE Platform Version: 4.10.00
Qt Version: 4.8.2
Operating System: Linux 3.2.0-37-generic i686
Distribution: Ubuntu 12.04.2 LTS

-- Information about the crash:
- What I was doing when the application crashed:
I pressed the Send To... button. Ksnapshot froze for a bit, like usual, and then crashed.
I do not have a Facebook account associated with the program who's offending plug-in crashed Ksnapshot, or any other program for that matter.

-- Backtrace:
Application: KSnapshot (ksnapshot), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb7786740 (LWP 25310))]

Thread 2 (Thread 0xb6594b40 (LWP 25316)):
#0  0x004f0412 in read () at ../sysdeps/unix/syscall-template.S:83
#1  0x04d556ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0x04d16bd2 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0x04d17042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0x04d17201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0x029e4db7 in QEventDispatcherGlib::processEvents (this=0xb5c00468, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x029b067d in QEventLoop::processEvents (this=0xb6594240, flags=...) at kernel/qeventloop.cpp:149
#7  0x029b0919 in QEventLoop::exec (this=0xb6594240, flags=...) at kernel/qeventloop.cpp:204
#8  0x028999ec in QThread::exec (this=0x976a8e8) at thread/qthread.cpp:501
#9  0x0298dccd in QInotifyFileSystemWatcherEngine::run (this=0x976a8e8) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x0289ce80 in QThreadPrivate::start (arg=0x976a8e8) at thread/qthread_unix.cpp:307
#11 0x00a0ed4c in start_thread (arg=0xb6594b40) at pthread_create.c:308
#12 0x00500d3e in clone () at ../sysdeps/unix/sysv/linux/i386/clone.S:130

Thread 1 (Thread 0xb7786740 (LWP 25310)):
[KCrash Handler]
#7  QString::operator= (this=0x14, other=...) at tools/qstring.cpp:1411
#8  0x01987be1 in KIPI::Plugin::setUiBaseName (this=0x97b2e90, name=0x196549f "kipiplugin_facebookui.rc") at ../../libkipi/plugin.cpp:309
#9  0x01949d1b in KIPIFacebookPlugin::Plugin_Facebook::Plugin_Facebook (this=0x97b2e90, parent=0x96149b8) at /build/buildd/digikam-3.0.0~rc/extra/kipi-plugins/facebook/plugin_facebook.cpp:72
#10 0x0194aa4a in KPluginFactory::createInstance<KIPIFacebookPlugin::Plugin_Facebook, QObject> (parentWidget=0x0, parent=0x96149b8, args=...) at /usr/include/kpluginfactory.h:477
#11 0x008566ae in KPluginFactory::create (this=0x97b1fc0, iface=0x9cf860 "KIPI::Plugin", parentWidget=0x0, parent=0x96149b8, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
#12 0x009c67d9 in KIPI::PluginLoader::Info::plugin() const () from /usr/lib/libkipi.so.8
#13 0x0805c7a8 in _start ()

Reported using DrKonqi
Comment 1 caulier.gilles 2013-02-13 06:04:54 UTC

*** This bug has been marked as a duplicate of bug 307775 ***
Comment 2 caulier.gilles 2018-02-04 11:17:40 UTC
Problem fixed in 6.0.0 where all tools are now in digiKam core