Bug 314902 - Files: cannot add all the files to a tag
Summary: Files: cannot add all the files to a tag
Status: RESOLVED FIXED
Alias: None
Product: Active
Classification: Unclassified
Component: Applications (show other bugs)
Version: Master
Platform: Other Linux
: NOR major (vote)
Target Milestone: PA 4
Assignee: active
URL:
Keywords:
Depends on: 314553
Blocks:
  Show dependency treegraph
 
Reported: 2013-02-11 14:31 UTC by Wromey
Modified: 2013-04-01 19:55 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Wromey 2013-02-11 14:31:26 UTC
PA3 updated 09.02.2013.
I have 100 pictures on my wetab, which I want to tag. So I search for Wien, wich is part of the file name and get corretly 3 pages. I select the pictures on the first page and drag them to "new tag". The naming window pops up, and I give in the tag-name "Wien". The tag is created. I switch to page 2, select the pichtures and drag them to the Wien-tag. They are tagged. I switch to page 3, select and drag. When after a while i deselect the tag, all pictures are shown, when I select it only the pictures of the first two pages are shown.

Reproducible: Always

Steps to Reproduce:
1. Load 100 pictures on your tablet and select some which fill three pages
2. Try to tag the selected pictures
3. Deselect and select the tag
Actual Results:  
Only the picture of the first two pages are tagged

Expected Results:  
All pictures should have been tagged
Comment 1 Thomas Pfeiffer 2013-03-26 21:46:59 UTC
This problem seems to be more complex than thought at first.
Actually, it's a combination of two bugs. When tagging the first page of resources, the second page is actually already inadvertently tagged as well due to Bug 314553 .
Afterwards, though, it is not possible to tag any more files until a restart of Files. This happens not only when tagging a full page at once, but I cannot exactly tell when it happens. When tagging a whole page of resources, it always happens.
Try tagging a set of files and then another one and it's likely that tagging will have stopped working.
Comment 2 Thomas Pfeiffer 2013-03-28 14:45:48 UTC
This is related to Bug 314553 so we'll retest if fixing that one will fix this one as well.
Comment 3 Thomas Pfeiffer 2013-03-29 22:14:45 UTC
Even though Bug 314553 is fixed, this bug still remains.
Actually, after tagging any file with any tag, tagging reproducibly stops working until I restart Files.
Comment 4 Marco Martin 2013-03-31 15:08:40 UTC
Git commit 1e1ec016117c4e1dbf79f348cb51feb05e36ae13 by Marco Martin.
Committed on 31/03/2013 at 17:07.
Pushed by mart into branch 'integration'.

make metadataSource global

M  +0    -7    applications/filebrowser/package/contents/ui/Browser.qml
M  +6    -0    applications/filebrowser/package/contents/ui/main.qml

http://commits.kde.org/plasma-mobile/1e1ec016117c4e1dbf79f348cb51feb05e36ae13
Comment 5 Thomas Pfeiffer 2013-04-01 19:55:28 UTC
Yep, that fixed it! :)