Bug 314876 - Syncing IMAP blocks folder properties dialog
Summary: Syncing IMAP blocks folder properties dialog
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: folders (show other bugs)
Version: 4.10.0
Platform: Ubuntu Packages Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-02-11 08:30 UTC by Martin van Es
Modified: 2014-06-09 08:56 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin van Es 2013-02-11 08:30:00 UTC
While (re)syncing IMAP contents (e.g. after expunging the local cache) folder properties popup can be selected but is blocked (does not appear) until the sync is finished.

Reproducible: Always

Steps to Reproduce:
1. Stop akonadi,
2. Clear local IMAP cache (.local/share/akonadi)
3. Restart akonadi
4. Start Kmail2
5. Watch IMAP folders being synced
6. Right-click folder, select folder properties
Actual Results:  
No folder properties pop-up until sync finishes

Expected Results:  
Expect either disabled folder properties while syncing, or a pop-up (i.e. independant threads for user interface and sync).

This is somewhere between bug and wishlist. The behaviour is somewhat unexpected and confusing.
Comment 1 Laurent Montel 2013-02-15 06:56:33 UTC
There is a progress for it now in 4.11.
So we are inform that we will sync it.
Comment 2 David Faure 2014-06-07 09:07:22 UTC

*** This bug has been marked as a duplicate of bug 325756 ***
Comment 3 David Faure 2014-06-09 08:56:00 UTC
Git commit dc97df054b2eaae2556eae56d6b01f38c00b3a2a by David Faure.
Committed on 07/06/2014 at 08:47.
Pushed by dfaure into branch 'KDE/4.13'.

Speed up opening the folder properties dialog in kmail.

An IMAP mail check schedules a large number of tasks.
Tasks that the user is waiting for, such as ItemFetch (reading one mail)
or SyncCollectionAttributes (as called by the folder properties dialog)
should have priority over that.

There might be more types of tasks that the user could potentially be waiting for.
Maybe we could even blacklist instead of whitelist, i.e. put folder-sync tasks
in a low-prio queue, while the default queue would be above it. Not sure.
Related: bug 325756
REVIEW: 118602

M  +2    -1    akonadi/resourcescheduler.cpp
M  +5    -3    akonadi/resourcescheduler_p.h

http://commits.kde.org/kdepimlibs/dc97df054b2eaae2556eae56d6b01f38c00b3a2a