Bug 314800 - Plantage en cours de jeux
Summary: Plantage en cours de jeux
Status: RESOLVED DUPLICATE of bug 290706
Alias: None
Product: phonon-backend-gstreamer
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: 4.6.2
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Harald Sitter
URL:
Keywords:
: 317454 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-09 23:22 UTC by Jacques VALLOIS
Modified: 2013-04-13 11:23 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jacques VALLOIS 2013-02-09 23:22:59 UTC
Application: kbattleship (2.0)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-23-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed: Playing. Window enlarged. This aplication was used in Gnome.

- Custom settings of the application: Sound enabled. Low difficulty.

-- Backtrace:
Application: Bataille navale (kbattleship), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f9502eaa780 (LWP 6274))]

Thread 7 (Thread 0x7f94eb4b3700 (LWP 6277)):
#0  0x00007f94ff8f6303 in __GI___poll (fds=<optimized out>, nfds=<optimized out>, timeout=<optimized out>) at ../sysdeps/unix/sysv/linux/poll.c:87
#1  0x00007f94fc483d84 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94fc4841e2 in g_main_loop_run () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f94f34744a6 in ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007f94fc4a7645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ff5f8e9a in start_thread (arg=0x7f94eb4b3700) at pthread_create.c:308
#6  0x00007f94ff901cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 6 (Thread 0x7f94cbffe700 (LWP 6299)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f94fc4c109f in g_cond_wait () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94e10f2003 in gst_task_func (task=0x18917b0) at gsttask.c:312
#3  0x00007f94fc4a7e62 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f94fc4a7645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ff5f8e9a in start_thread (arg=0x7f94cbffe700) at pthread_create.c:308
#6  0x00007f94ff901cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 5 (Thread 0x7f94d61dc700 (LWP 6342)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f94fc4c109f in g_cond_wait () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94e10f2003 in gst_task_func (task=0x7f94c00f9430) at gsttask.c:312
#3  0x00007f94fc4a7e62 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f94fc4a7645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ff5f8e9a in start_thread (arg=0x7f94d61dc700) at pthread_create.c:308
#6  0x00007f94ff901cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f94c97f9700 (LWP 6537)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f94fc4c109f in g_cond_wait () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94e10f2003 in gst_task_func (task=0x7f94c032cd40) at gsttask.c:312
#3  0x00007f94fc4a7e62 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f94fc4a7645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ff5f8e9a in start_thread (arg=0x7f94c97f9700) at pthread_create.c:308
#6  0x00007f94ff901cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f94c9ffa700 (LWP 6615)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f94fc4c109f in g_cond_wait () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94e10f2003 in gst_task_func (task=0x7f94b02c9310) at gsttask.c:312
#3  0x00007f94fc4a7e62 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f94fc4a7645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ff5f8e9a in start_thread (arg=0x7f94c9ffa700) at pthread_create.c:308
#6  0x00007f94ff901cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f94c8ff8700 (LWP 6617)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f94fc4c109f in g_cond_wait () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f94e10f2003 in gst_task_func (task=0x7f94c032c940) at gsttask.c:312
#3  0x00007f94fc4a7e62 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f94fc4a7645 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f94ff5f8e9a in start_thread (arg=0x7f94c8ff8700) at pthread_create.c:308
#6  0x00007f94ff901cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f9502eaa780 (LWP 6274)):
[KCrash Handler]
#6  0x00007f94ff844425 in __GI_raise (sig=<optimized out>) at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#7  0x00007f94ff847b8b in __GI_abort () at abort.c:91
#8  0x00007f94fa4395fd in pa_mutex_free () from /usr/lib/x86_64-linux-gnu/pulseaudio/libpulsecommon-2.1.so
#9  0x00007f94fd989e7a in pa_threaded_mainloop_free () from /usr/lib/x86_64-linux-gnu/libpulse.so.0
#10 0x00007f94d6447881 in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstpulse.so
#11 0x00007f94d6447a38 in ?? () from /usr/lib/x86_64-linux-gnu/gstreamer-0.10/libgstpulse.so
#12 0x00007f94e10b0d2c in gst_element_change_state (element=element@entry=0x32fcb40, transition=transition@entry=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2761
#13 0x00007f94e10b1678 in gst_element_set_state_func (element=0x32fcb40, state=GST_STATE_NULL) at gstelement.c:2717
#14 0x00007f94e109e857 in gst_bin_element_set_state (next=GST_STATE_NULL, current=GST_STATE_READY, start_time=0, base_time=0, element=0x32fcb40, bin=0x18ac170) at gstbin.c:2209
#15 gst_bin_change_state_func (element=0x18ac170, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2518
#16 0x00007f94e10b0d2c in gst_element_change_state (element=element@entry=0x18ac170, transition=transition@entry=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2761
#17 0x00007f94e10b1678 in gst_element_set_state_func (element=0x18ac170, state=GST_STATE_NULL) at gstelement.c:2717
#18 0x00007f94e109e857 in gst_bin_element_set_state (next=GST_STATE_NULL, current=GST_STATE_READY, start_time=0, base_time=0, element=0x18ac170, bin=0x18ac2e0) at gstbin.c:2209
#19 gst_bin_change_state_func (element=0x18ac2e0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2518
#20 0x00007f94e10b0d2c in gst_element_change_state (element=element@entry=0x18ac2e0, transition=transition@entry=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2761
#21 0x00007f94e10b1678 in gst_element_set_state_func (element=0x18ac2e0, state=GST_STATE_NULL) at gstelement.c:2717
#22 0x00007f94e109e857 in gst_bin_element_set_state (next=GST_STATE_NULL, current=GST_STATE_READY, start_time=0, base_time=0, element=0x18ac2e0, bin=0x18ac5c0) at gstbin.c:2209
#23 gst_bin_change_state_func (element=0x18ac5c0, transition=GST_STATE_CHANGE_READY_TO_NULL) at gstbin.c:2518
#24 0x00007f94e10b0d2c in gst_element_change_state (element=element@entry=0x18ac5c0, transition=transition@entry=GST_STATE_CHANGE_READY_TO_NULL) at gstelement.c:2761
#25 0x00007f94e10b1678 in gst_element_set_state_func (element=0x18ac5c0, state=GST_STATE_NULL) at gstelement.c:2717
#26 0x00007f94d4d35d2e in activate_chain (activate=0, chain=0x7f94c0005f20) at gstplaysink.c:971
#27 activate_chain (chain=0x7f94c0005f20, activate=0) at gstplaysink.c:957
#28 0x00007f94d4d36052 in gst_play_sink_change_state (element=0x196ab70, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstplaysink.c:3587
#29 0x00007f94e10b0d2c in gst_element_change_state (element=element@entry=0x196ab70, transition=transition@entry=GST_STATE_CHANGE_PAUSED_TO_READY) at gstelement.c:2761
#30 0x00007f94e10b1678 in gst_element_set_state_func (element=0x196ab70, state=GST_STATE_READY) at gstelement.c:2717
#31 0x00007f94e109e857 in gst_bin_element_set_state (next=GST_STATE_READY, current=GST_STATE_PAUSED, start_time=0, base_time=0, element=0x196ab70, bin=0x3528940) at gstbin.c:2209
#32 gst_bin_change_state_func (element=0x3528940, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstbin.c:2518
#33 0x00007f94e10cf4c3 in gst_pipeline_change_state (element=0x3528940, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstpipeline.c:482
#34 0x00007f94d4d2f57b in gst_play_bin_change_state (element=0x3528940, transition=GST_STATE_CHANGE_PAUSED_TO_READY) at gstplaybin2.c:3936
#35 0x00007f94e10b0d2c in gst_element_change_state (element=element@entry=0x3528940, transition=transition@entry=GST_STATE_CHANGE_PAUSED_TO_READY) at gstelement.c:2761
#36 0x00007f94e10b1678 in gst_element_set_state_func (element=0x3528940, state=GST_STATE_READY) at gstelement.c:2717
#37 0x00007f94e1de3d76 in Phonon::Gstreamer::Pipeline::setState (this=0x3523250, state=GST_STATE_READY) at ../../gstreamer/pipeline.cpp:242
#38 0x00007f94e1ddc464 in Phonon::Gstreamer::MediaObject::requestState (this=this@entry=0x3520760, state=state@entry=Phonon::StoppedState) at ../../gstreamer/mediaobject.cpp:845
#39 0x00007f94e1ddc714 in Phonon::Gstreamer::MediaObject::stop (this=0x3520760) at ../../gstreamer/mediaobject.cpp:451
#40 0x00007f9501ecf3f4 in Phonon::MediaObject::setCurrentSource (this=0x1c12d10, newSource=...) at ../../phonon/mediaobject.cpp:248
#41 0x000000000041216d in AudioPlayer::play (this=0x1a8b690, player=<optimized out>, info=...) at ../../../knavalbattle/src/audioplayer.cpp:42
#42 0x0000000000416ca2 in Controller::finalizeShot (this=0x2577530, player=Sea::PLAYER_B, c=..., info=...) at ../../../knavalbattle/src/controller.cpp:164
#43 0x000000000041c7e2 in hit (shot=0x39e21e0, this=0x390be20) at ../../../knavalbattle/src/playerentity.cpp:99
#44 PlayerEntity::hit (this=this@entry=0x390be20, shot=shot@entry=0x39e21e0) at ../../../knavalbattle/src/playerentity.cpp:95
#45 0x000000000041681d in Controller::shoot (this=0x2577530, player=1, c=...) at ../../../knavalbattle/src/controller.cpp:152
#46 0x00007f950005d43e in QObject::event (this=0x2577530, e=<optimized out>) at kernel/qobject.cpp:1195
#47 0x00007f9500c7fe9c in QApplicationPrivate::notify_helper (this=this@entry=0x1786d50, receiver=receiver@entry=0x2577530, e=e@entry=0x3a35490) at kernel/qapplication.cpp:4562
#48 0x00007f9500c8430a in QApplication::notify (this=0x7fffe98ab150, receiver=0x2577530, e=0x3a35490) at kernel/qapplication.cpp:4423
#49 0x00007f950232e1d6 in KApplication::notify (this=0x7fffe98ab150, receiver=0x2577530, event=0x3a35490) at ../../kdeui/kernel/kapplication.cpp:311
#50 0x00007f950004856e in QCoreApplication::notifyInternal (this=0x7fffe98ab150, receiver=receiver@entry=0x2577530, event=event@entry=0x3a35490) at kernel/qcoreapplication.cpp:915
#51 0x00007f950004c3f1 in sendEvent (event=0x3a35490, receiver=0x2577530) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#52 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1755ff0) at kernel/qcoreapplication.cpp:1539
#53 0x00007f9500076a63 in sendPostedEvents () at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:236
#54 postEventSourceDispatch (s=0x1780b50) at kernel/qeventdispatcher_glib.cpp:279
#55 0x00007f94fc483ab5 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#56 0x00007f94fc483de8 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#57 0x00007f94fc483ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#58 0x00007f9500076bf6 in QEventDispatcherGlib::processEvents (this=0x17574b0, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#59 0x00007f9500d24c1e in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#60 0x00007f95000472bf in QEventLoop::processEvents (this=this@entry=0x7fffe98aaff0, flags=...) at kernel/qeventloop.cpp:149
#61 0x00007f9500047548 in QEventLoop::exec (this=0x7fffe98aaff0, flags=...) at kernel/qeventloop.cpp:204
#62 0x00007f950004c708 in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#63 0x000000000040f5f0 in main (argc=3, argv=0x7fffe98ab288) at ../../../knavalbattle/src/main.cpp:77

Reported using DrKonqi
Comment 1 Christoph Feck 2013-03-27 20:30:13 UTC
*** Bug 317454 has been marked as a duplicate of this bug. ***
Comment 2 Myriam Schweingruber 2013-04-13 11:23:36 UTC

*** This bug has been marked as a duplicate of bug 290706 ***