Bug 314594 - Add option to remove entries from service-menu
Summary: Add option to remove entries from service-menu
Status: RESOLVED FIXED
Alias: None
Product: dolphin
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.2
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
: 430316 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-02-07 11:23 UTC by ThomasvonderElbe
Modified: 2020-12-28 20:28 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 21.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ThomasvonderElbe 2013-02-07 11:23:19 UTC
I would like to have the possiblity to remove these entries from the service-menu:

- Open in new window
- Open in new tab
- Add to places

Because these actions are already much easier to perform with middle-click, drag-and-drop, ... . So from my perspective they are useless and just clutter the menu.

Easiest would maybe be, to add them to the list of services: settings -> configure Dolphin -> services. Or to give them a .desktop file, which can be edited then. 

Reproducible: Always
Comment 1 Janet 2013-05-12 14:11:32 UTC
I agree for "open in new tab" and "add to places" but how do you open a folder in a new dolphin window without the context menu?

But yes, I think it is a good idea to add these entries to the configurable services.
Comment 2 Frank Reininghaus 2013-05-12 17:21:37 UTC
Thanks for the idea. I see that this might make sense for some users, but considering that this would require some non-trivial code changes and that there has not been much demand for this feature so far, I'm not sure if it should be implemented (provided that anyone volunteers to do it).
Comment 3 David Chmelik 2020-11-09 00:44:10 UTC
I wish it could be added.  I went through the entire extra add-on services (even if there are 1000+, taking one-half to one hour... I read fast) and installed a bunch.  Some ended up in Spanish, but I don't read that, and others are broken or break (permanently hide) the system ones!  There needs to be better quality/version control here for the add-on ones also...

Actually I don't want the option to remove system ones from the configuration list, but only add-on ones.  Any/all should be allowed to be removed from the user menu (after configuration.)
Comment 4 Nate Graham 2020-12-15 16:18:05 UTC
There's an open merge request that would implement this feature: https://invent.kde.org/system/dolphin/-/merge_requests/103
Comment 5 Nate Graham 2020-12-15 16:18:12 UTC
*** Bug 430316 has been marked as a duplicate of this bug. ***
Comment 6 Elvis Angelaccio 2020-12-28 20:19:01 UTC
Git commit a512176b4bdbf0f0471a9b9089f4a936c14e2732 by Elvis Angelaccio, on behalf of Duong Do Minh Chau.
Committed on 28/12/2020 at 20:18.
Pushed by elvisangelaccio into branch 'master'.

Add options to hide some context menu entries

This commit add options to hide the following context menu entries:
- Add to Places
- Copy Location
- Duplicate Here
- Open in New Tab and Open in New Tabs
- Open in New Window
- Sort By
- View Mode

The Services settings page is renamed to Context Menu

ShowCopyMoveMenu option is moved from GeneralSettings to ContextMenuSettings

M  +15   -11   src/CMakeLists.txt
M  +51   -36   src/dolphincontextmenu.cpp
R  +77   -18   src/settings/contextmenu/contextmenusettingspage.cpp [from: src/settings/services/servicessettingspage.cpp - 071% similarity]
R  +6    -6    src/settings/contextmenu/contextmenusettingspage.h [from: src/settings/services/servicessettingspage.h - 081% similarity]
R  +0    -0    src/settings/contextmenu/servicemenu.knsrc [from: src/settings/services/servicemenu.knsrc - 100% similarity]
R  +0    -0    src/settings/contextmenu/servicemenuinstaller/CMakeLists.txt [from: src/settings/services/servicemenuinstaller/CMakeLists.txt - 100% similarity]
R  +0    -0    src/settings/contextmenu/servicemenuinstaller/Messages.sh [from: src/settings/services/servicemenuinstaller/Messages.sh - 100% similarity]
R  +0    -0    src/settings/contextmenu/servicemenuinstaller/servicemenuinstaller.cpp [from: src/settings/services/servicemenuinstaller/servicemenuinstaller.cpp - 100% similarity]
R  +0    -0    src/settings/contextmenu/test/service_menu_deinstallation_test.rb [from: src/settings/services/test/service_menu_deinstallation_test.rb - 100% similarity]
R  +0    -0    src/settings/contextmenu/test/service_menu_installation_test.rb [from: src/settings/services/test/service_menu_installation_test.rb - 100% similarity]
R  +0    -0    src/settings/contextmenu/test/test_helper.rb [from: src/settings/services/test/test_helper.rb - 100% similarity]
R  +0    -0    src/settings/contextmenu/test/test_run.rb [from: src/settings/services/test/test_run.rb - 100% similarity]
A  +42   -0    src/settings/dolphin_contextmenusettings.kcfg
A  +4    -0    src/settings/dolphin_contextmenusettings.kcfgc
M  +0    -4    src/settings/dolphin_generalsettings.kcfg
M  +8    -8    src/settings/dolphinsettingsdialog.cpp
A  +47   -0    src/settings/kcm/kcmdolphincontextmenu.cpp     [License: GPL(v2.0+)]
A  +62   -0    src/settings/kcm/kcmdolphincontextmenu.desktop
A  +32   -0    src/settings/kcm/kcmdolphincontextmenu.h     [License: GPL(v2.0+)]
D  +0    -46   src/settings/kcm/kcmdolphinservices.cpp
D  +0    -204  src/settings/kcm/kcmdolphinservices.desktop
D  +0    -32   src/settings/kcm/kcmdolphinservices.h
M  +1    -1    src/tests/CMakeLists.txt

https://invent.kde.org/system/dolphin/commit/a512176b4bdbf0f0471a9b9089f4a936c14e2732