Bug 314033 - Crashed when attempting to vie images in folders
Summary: Crashed when attempting to vie images in folders
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Image (show other bugs)
Version: 2.9.0
Platform: Microsoft Windows Microsoft Windows
: NOR grave (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-28 15:57 UTC by Tom Coxon
Modified: 2017-07-20 09:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Coxon 2013-01-28 15:57:32 UTC
DigitKam 2.9.0 (as installed with latest windows installer from your web site) starts up fine & when I was testing it on a few (approx 50 photos) it worked fine. When I gave it the whole photos folder to go at, it crashes randomly whenever I go to a folder to view the photos.

Reproducible: Always

Steps to Reproduce:
1. Open DigiKam
2. Wait until the I/O has calmed down
3. Click on a folder
Actual Results:  
As it starts to display image thumbnails the KDE crash reporter comes up (although DigiKam seems to keep working in the back ground). Unfortunately the crash reporter then claims to have nothing worth forwarding & refuses to report the fault.
The fault seems to be an attempted memory violation.
Comment 1 Tom Coxon 2013-01-28 16:32:03 UTC
I've just tried to see if I can glean any more info.
DigitKam seems fine when it's displaying a folder with jpg's, but when it gets a folder that includes PEF or DNG (from a Pentax camera) it crashes & not always via the KDE crash reporter.
on my second go at this, KDE did catch it and reported 
Executable: digikam.exe PID: 2736 Signal: EXCEPTION_ACCESS_VIOLATION (0xc0000005)
Comment 2 Tom Coxon 2013-01-28 16:36:54 UTC
It also seems to have a problem with folders containing CR2 (Canon) files, but it's OK with TIFF's
KDE reported this
Executable: digikam.exe PID: 5624 Signal: EXCEPTION_ACCESS_VIOLATION (0xc0000005)
Comment 3 Tom Coxon 2013-01-28 16:41:25 UTC
Just tried it again and as soon as it got to the PEF file it crashed
Executable: digikam.exe PID: 4852 Signal: EXCEPTION_ACCESS_VIOLATION (0xc0000005)
I'm not sure if is is related, but I noticed that on a few jpg files it also displayed the "place holder" icon instead of the thumbnail of the image.
Comment 4 Tom Coxon 2013-01-28 16:45:25 UTC
and KDE gave this info for the back trace
Application: digiKam (digikam.exe), signal: EXCEPTION_ACCESS_VIOLATION
[unknown]!KiFastSystemCallRet() [[unknown] @ -1] at 0x7c90e514
[unknown]!WaitForSingleObject() [[unknown] @ -1] at 0x7c802542
[unknown]!QWaitCondition::wait() [[unknown] @ -1] at 0x6702855b
[unknown]![unknown]() [[unknown] @ -1] at 0x60002
[unknown]![unknown]() [[unknown] @ -1] at 0x6eb79f8
[unknown]![unknown]() [[unknown] @ -1] at 0x7d08048
Comment 5 Tom Coxon 2013-01-28 18:10:09 UTC
Having renamed the database & rebuilt it from scratch I got an abort with slightly different info
Executable: digikam.exe PID: 4712 Signal: Unknown (0xe06d7363)
Comment 6 Ananta Palani 2013-06-10 12:39:04 UTC
(In reply to comment #5)
> Having renamed the database & rebuilt it from scratch I got an abort with
> slightly different info
> Executable: digikam.exe PID: 4712 Signal: Unknown (0xe06d7363)

Could you try the just release 3.1.0 and let me know if you still have problems?

   http://download.kde.org/stable/digikam/digiKam-installer-3.1.0-win32.exe
Comment 7 Tom Coxon 2013-06-10 18:05:41 UTC
Hi Ananta,

I just installed the 3.1.0 windows (32 bit) version & repeated the steps 
which caused the crash in 2.9.0 & it works well.

Just as I thought that it was completely fixed, it crashed on displaying 
a PEF (it was busy doing some I/O at the time). I restarted it, 
displayed the same image & it worked just fine.

So it looks like there's probably a timing bug left somewhere which 
doesn't show very often.

There are a few TIF's that it doesn't want to preview, but there are 
others that it's just fine with. But it doesn't crash with either.

So it looks like it's fixed for practical purposes, but I'll exercise it 
some more over the net few days & let you know if I get any problems 
which can be reproduced.

Kind regards,

Tom Coxon

On 10/06/2013 13:39, Ananta Palani wrote:
> https://bugs.kde.org/show_bug.cgi?id=314033
>
> Ananta Palani <anantapalani@gmail.com> changed:
>
>             What    |Removed                     |Added
> ----------------------------------------------------------------------------
>                   CC|                            |anantapalani@gmail.com
>
> --- Comment #6 from Ananta Palani <anantapalani@gmail.com> ---
> (In reply to comment #5)
>> Having renamed the database & rebuilt it from scratch I got an abort with
>> slightly different info
>> Executable: digikam.exe PID: 4712 Signal: Unknown (0xe06d7363)
> Could you try the just release 3.1.0 and let me know if you still have
> problems?
>
>     http://download.kde.org/stable/digikam/digiKam-installer-3.1.0-win32.exe
>
Comment 8 caulier.gilles 2013-06-10 19:52:04 UTC
Thanks Tom for the feedback.

Ananta plan also to release 3.2.0 for windows in near future...

I close this file now. Reopen if necessary

Gilles Caulier