Bug 314010 - kmail composer regression: Cursor jumps to end of line after every keypress
Summary: kmail composer regression: Cursor jumps to end of line after every keypress
Status: RESOLVED UNMAINTAINED
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 4.10
Platform: Gentoo Packages Linux
: NOR major with 35 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: regression, usability
: 321219 321786 329732 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-28 02:11 UTC by Marc Schiffbauer
Modified: 2017-01-08 06:26 UTC (History)
14 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
strace during To edit (617.26 KB, application/octet-stream)
2014-03-07 02:00 UTC, Kevin Clevenger
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marc Schiffbauer 2013-01-28 02:11:44 UTC
When editing an email address in the To: field of the composer the cursor always jumos to the end of line which makes it very hard to enter/change an email address

Reproducible: Always

Steps to Reproduce:
1. create new mail
2. enter some text in the To: Lineedit
3. move cursor in the middle of the text
4. press backspace
Actual Results:  
cursor jumps to end of lineedit

Expected Results:  
cursor shouls never be moved automatically

This seems to be a regression introduced in the 4.10 RCs somewhere
Comment 1 Laurent Montel 2013-01-29 12:34:39 UTC
Need to test last version
I fixed it (I hope)
Comment 2 Marc Schiffbauer 2013-01-29 23:19:52 UTC
Hi Laurent,

thanks for looking into it!

Sorry, but for me its not fixed :-/
I just have built and tested current 4.10 branch.

.... resetting to unconfirmed
Comment 3 Laurent Montel 2013-01-30 07:28:18 UTC
Ok I fixed an other bug.
I will investigate it.
Comment 4 Marc Schiffbauer 2013-02-26 15:34:28 UTC
Hi Laurent,

any news on this?

In current kmail its almost impossible to edit the recipient of an email manually.

Can you reproduce this?

Thanks
-Marc
Comment 5 Laurent Montel 2013-02-26 15:54:25 UTC
no I can't.

Do you use ldap for autocompletion ?
Perhaps you have specific config ? 
etc.
Comment 6 Marc Schiffbauer 2013-02-26 16:16:08 UTC
No,  I have:

* default vcard adressbook
* CardDAV Resource
* Google Contacts Resource

But I think I found out how to reproduce:

right click on the addressfield and set Textcompletion to "drop down" (or similar, german locale here)

If I set this to something other it works fine here too

-Marc
Comment 7 Silver Salonen 2013-03-23 12:35:12 UTC
Happens also in KMail 4.10.1 on openSUSE 12.3.
Comment 8 Søren Holm 2013-06-14 06:53:53 UTC
It's still present in 4.10.4
Comment 9 Laurent Montel 2013-06-17 07:47:08 UTC
*** Bug 321219 has been marked as a duplicate of this bug. ***
Comment 10 David Faure 2013-06-24 19:22:37 UTC
I had this bug many times too in the past. Today I decided OK, time to fix it.... and obviously I can't reproduce it anymore...  KDE/4.10 branch.
Comment 11 Allen Winter 2013-06-24 19:58:30 UTC
same here. working today for me in master.
<twilight zone music>
Comment 12 Marc Schiffbauer 2013-06-25 14:39:58 UTC
For me this is still reproducable using todays KDE/4.10 branch
Comment 13 Silver Salonen 2013-07-02 08:01:52 UTC
Still happens in KMail 4.10.90 (4.11 beta2) on openSUSE 12.3.
Comment 14 Laurent Montel 2013-07-03 05:53:48 UTC
*** Bug 321786 has been marked as a duplicate of this bug. ***
Comment 15 Marc Schiffbauer 2013-07-16 00:04:24 UTC
For me this is fixed in current 4.11 branch
Comment 16 Allen Winter 2013-07-25 20:37:09 UTC
Here's one situation where I can reliably reproduce.

I get an email from a mailing list.
I reply to all.
I see 3 addresslineedits (why 3?, that's a different question)
  mailinglist@mail.kdab.com
  senderfirst.senderlast@whereever.com
  mailinglist@kdab.com

If I try to edit mailinglist@mail.kdab.com by clicking after any character and then pressing the backspace key, the cursor immediately goes to the end-of-line after removing the previous character.  ditto for each addresseelineedit.
Comment 17 Søren Holm 2013-07-25 21:45:00 UTC
It's still a problem in 4.11 rc1
Comment 18 Laurent Montel 2013-07-26 05:53:59 UTC
(In reply to comment #16)
> Here's one situation where I can reliably reproduce.
> 
> I get an email from a mailing list.
> I reply to all.
> I see 3 addresslineedits (why 3?, that's a different question)
>   mailinglist@mail.kdab.com
>   senderfirst.senderlast@whereever.com
>   mailinglist@kdab.com
> 
> If I try to edit mailinglist@mail.kdab.com by clicking after any character
> and then pressing the backspace key, the cursor immediately goes to the
> end-of-line after removing the previous character.  ditto for each
> addresseelineedit.

please try to debug if you can reproduce.
I fixed my ldap kdab but not success to reproduce it.
Don't know why create this bug
Comment 19 Marc Schiffbauer 2013-07-26 09:08:00 UTC
I dont think its related to ldap....
Comment 20 Laurent Montel 2013-07-26 09:42:05 UTC
So it's related to what ?:)
I can't reproduce it.
I hope that allen will debug it
Comment 21 Thomas Fjellstrom 2013-08-20 14:53:44 UTC
I'm seeing this issue in kmail 4.10.5 in debian sid.
Comment 22 Laurent Montel 2013-08-20 16:19:35 UTC
Ok but I don't have this bug and people which has this bug doesn't debug it...
Comment 23 Marc Schiffbauer 2013-08-20 21:35:31 UTC
Update from my side: Seems to be fixed for me in 4.11, atm I cannot reproduce it anymore and I could 100% with latest 4.10
Comment 24 Silver Salonen 2013-08-21 15:21:49 UTC
It just happened to me with KMail 4.11.00 on openSUSE 12.3.
Comment 25 Benjamin M 2014-01-01 03:07:08 UTC
I confirm this bug on up-to-date 4.12.0 on openSUSE 13.1. I'd humbly suggest it's time to change this to "confirmed". :-) This has been open for almost a year.
Comment 26 Søren Holm 2014-01-01 13:57:41 UTC
Hmmm ... It's gone for me now on kmail 4.12
Comment 27 Sami Boukortt 2014-01-01 16:02:52 UTC
Not for me.
Comment 28 quazgar 2014-01-06 21:03:43 UTC
(In reply to comment #23)
> Update from my side: Seems to be fixed for me in 4.11, atm I cannot
> reproduce it anymore and I could 100% with latest 4.10
A specific 4.11 release or a revision between releases?  I can reproduce it in 4.11.2 on Gentoo.
Comment 29 quazgar 2014-01-06 21:26:12 UTC
Actually this bug only appears for one user on this machine, another user does not show the symptoms.
Comment 30 Laurent Montel 2014-01-09 06:32:16 UTC
*** Bug 329732 has been marked as a duplicate of this bug. ***
Comment 31 Kevin Clevenger 2014-03-07 01:58:14 UTC
This still happens for me on kdepim 4.12 (F20). I do have an LDAP address book configured, but it happens with all addresses - recent addresses, local address book, manually typed names, etc. I'm attaching an strace (kmail2-2.trace) that was captured when only editing the To field.
Comment 32 Kevin Clevenger 2014-03-07 02:00:59 UTC
Created attachment 85458 [details]
strace during To edit
Comment 33 quazgar 2014-03-07 17:20:29 UTC
One additional observation:
This behaviour does not happen when deleting until the next word boundary for me, i.e. when I press Ctrl-delete.
Comment 34 swisscarbon 2014-10-27 14:25:16 UTC
Seems to be gone in at least 4.14.1, many thanks to who ever took care of it.
Comment 35 Denis Kurz 2016-09-24 18:07:33 UTC
This bug has only been reported for versions before 4.14, which have been unsupported for at least two years now. Can anyone tell if this bug still present?

If noone confirms this bug for a Framework-based version of kmail2 (version 5.0 or later, as part of KDE Applications 15.12 or later), it gets closed in about three months.
Comment 36 Denis Kurz 2017-01-07 21:35:31 UTC
Just as announced in my last comment, I close this bug. If you encounter it again in a recent version (at least 5.0 aka 15.08), please open a new one unless it already exists. Thank you for all your input.