Bug 313991 - Crash on start
Summary: Crash on start
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ColorManagement (show other bugs)
Version: 3.0.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-27 18:54 UTC by andy.boettger
Modified: 2013-01-28 11:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andy.boettger 2013-01-27 18:54:51 UTC
Application: digikam (3.0.0-rc)
KDE Platform Version: 4.9.98
Qt Version: 4.8.3
Operating System: Linux 3.7.0-7-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f769f609a00 (LWP 13528))]

Thread 3 (Thread 0x7f767967c700 (LWP 13529)):
#0  pthread_cond_wait@@GLIBC_2.3.2 () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007f7699dff04b in wait (time=18446744073709551615, this=0xece650) at thread/qwaitcondition_unix.cpp:86
#2  QWaitCondition::wait (this=<optimized out>, mutex=0xf0d0e8, time=18446744073709551615) at thread/qwaitcondition_unix.cpp:158
#3  0x00000000005cb6e8 in Digikam::ScanController::run (this=0xf0ded0) at /build/buildd/digikam-3.0.0~rc/core/digikam/database/scancontroller.cpp:698
#4  0x00007f7699dfeaec in QThreadPrivate::start (arg=0xf0ded0) at thread/qthread_unix.cpp:338
#5  0x00007f76941e6e9a in start_thread (arg=0x7f767967c700) at pthread_create.c:308
#6  0x00007f7699027cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#7  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f7678e7b700 (LWP 13530)):
#0  0x00007f76941ea05d in __pthread_mutex_unlock_usercnt (mutex=<optimized out>, decr=<optimized out>) at pthread_mutex_unlock.c:52
#1  __pthread_mutex_unlock (mutex=0x7f766c000a60) at pthread_mutex_unlock.c:290
#2  0x00007f7691c4ae51 in g_mutex_unlock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f7691c0dc9e in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007f7691c0dea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007f7699f29c16 in QEventDispatcherGlib::processEvents (this=0x7f766c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007f7699efa2bf in QEventLoop::processEvents (this=this@entry=0x7f7678e7ab50, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007f7699efa548 in QEventLoop::exec (this=0x7f7678e7ab50, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007f7699dfbb10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007f7699eda9af in QInotifyFileSystemWatcherEngine::run (this=0xf10cb0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007f7699dfeaec in QThreadPrivate::start (arg=0xf10cb0) at thread/qthread_unix.cpp:338
#11 0x00007f76941e6e9a in start_thread (arg=0x7f7678e7b700) at pthread_create.c:308
#12 0x00007f7699027cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f769f609a00 (LWP 13528)):
[KCrash Handler]
#6  0x0000000000000000 in ?? ()
#7  0x00007f76946667f1 in cmsReadICCTextEx () from /usr/lib/x86_64-linux-gnu/liblcms.so.1
#8  0x00007f76946675f6 in cmsTakeProductDesc () from /usr/lib/x86_64-linux-gnu/liblcms.so.1
#9  0x00007f769cd71a15 in Digikam::IccProfile::description (this=0xedd0c0) at /build/buildd/digikam-3.0.0~rc/core/libs/dimg/filters/icc/iccprofile.cpp:387
#10 0x00007f769cd7e3c3 in Digikam::IccSettings::loadAllProfilesProperties (this=0xf7c400) at /build/buildd/digikam-3.0.0~rc/core/libs/dimg/filters/icc/iccsettings.cpp:585
#11 0x0000000000590042 in Digikam::DigikamApp::DigikamApp (this=0xf43ec0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /build/buildd/digikam-3.0.0~rc/core/digikam/main/digikamapp.cpp:228
#12 0x000000000048f611 in main (argc=1, argv=0x7fffbf7c2ee8) at /build/buildd/digikam-3.0.0~rc/core/digikam/main/main.cpp:188

Reported using DrKonqi
Comment 1 caulier.gilles 2013-01-27 20:24:28 UTC
It crash in LCMS library, not digiKam...

Gilles Caulier
Comment 2 Andreas 2013-01-28 09:07:42 UTC
Same here, on my desktop and my notebook since the update yesterday
Comment 3 andy.boettger 2013-01-28 09:56:15 UTC
Workaround: First I uninstalled digikam. Then the beta repository deactivated. Then I installed digikam again.
Comment 4 andy.boettger 2013-01-28 10:02:33 UTC
(In reply to comment #1)
> It crash in LCMS library, not digiKam...
> 
> Gilles Caulier

Which version? I have liblcms1 and liblcms2-2 installed.

/usr/lib/x86_64-linux-gnu/liblcms.so.1
/usr/lib/x86_64-linux-gnu/liblcms.so.1.0.19

/usr/lib/x86_64-linux-gnu/liblcms2.so.2
/usr/lib/x86_64-linux-gnu/liblcms2.so.2.0.2

With these versions digikam 2.8.0 running without problems.
Comment 5 andy.boettger 2013-01-28 10:29:02 UTC
I enabled the Kubuntu beta repository again. After upgrading digikam crashes again. Then I replaced the four packets with an older version:

kipi-plugins (4:2.8.0-0ubuntu1)
kipi-plugins-common (4:2.8.0-0ubuntu1)
digikam (4:2.8.0-0ubuntu1)
digikam-data (4:2.8.0-0ubuntu1)

Digikam works.
Comment 6 Andreas 2013-01-28 10:57:42 UTC
I tested the same and have the same results. For the moment i locked the four packages.