Bug 313918 - no OSD is shown when adjusting the screen brightness on a Lenovo T410s
Summary: no OSD is shown when adjusting the screen brightness on a Lenovo T410s
Status: RESOLVED UNMAINTAINED
Alias: None
Product: solid
Classification: Unclassified
Component: powermanagement (show other bugs)
Version: 4.9.98 RC3
Platform: Ubuntu Packages Linux
: NOR minor with 50 votes (vote)
Target Milestone: ---
Assignee: Dario Freddi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-26 09:41 UTC by Craig Magina
Modified: 2018-09-04 15:42 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments
kded4 debug output (34.77 KB, application/octet-stream)
2013-03-06 00:14 UTC, Craig Magina
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Craig Magina 2013-01-26 09:41:10 UTC
On my Lenovo T410s, if I use the keyboard keys to adjust my screen brightness, the OSD popup never appears, however the screen does adjust its brightness.

Reproducible: Always

Steps to Reproduce:
1. Adjust the screen brightness via the hardware keys
2.
3.
Actual Results:  
The screen brightness changes, but there is no OSD showing the change.

Expected Results:  
An OSD is displayed when changing the screen brightness setting via the keyboard keys.

If I change the screen brightness via the power applet, the OSD is displayed properly.
Comment 1 Alex Fiestas 2013-03-03 17:56:12 UTC
That is probably because your laptop is changing the screen hardware-wise :/ can you test with a newer kernel perhaps? does it help?

Also, can you try with a GNOME livecd using same kernel?

Thanks !
Comment 2 Craig Magina 2013-03-04 18:06:51 UTC
This reproduces in Kubuntu raring, which is a 3.8 kernel, so a newer kernel does not change it. Ubuntu 12.10 and 13.04 (Unity) both show a display brightness level OSD when I use the keyboard buttons. This is definitely an issue with KDE and the way it handles this for my specific hardware as another laptop I had worked without issue. How does KDE detect the screen brightness changes currently?
Comment 3 Alex Fiestas 2013-03-05 21:27:06 UTC
Can you execute:
kdebugdialog

Enable everything with "kded" or "powerdevil" on it

Then kill kded4 and execute it in a terminal so you can provide the output?
Comment 4 Craig Magina 2013-03-06 00:14:57 UTC
Created attachment 77787 [details]
kded4 debug output

I did as you instructed and while it was running changed the display brightness both to the max and to the min among other random changes. The X errors towards the end of the log occurred when the brightness popup showed itself for a second, but quickly vanished.
Comment 5 Alex Fiestas 2013-03-06 09:36:27 UTC
Oh... can you try by changing your plasma theme, or deactivating composite ?

What gpu driver are you using?
Comment 6 Craig Magina 2013-03-06 23:18:54 UTC
I did the previous test on a Kubuntu 13.04 live-cd. My laptop uses an intel gpu, but it also has an nvidia chip I can activate to see if it reproduces. The theme is the KDE default Oxygen and Air. The display pop-up used to work some time back, but I can't remember exactly when it stopped functioning.
Comment 7 Alex Fiestas 2013-03-07 00:07:29 UTC
As you pointed out this seems to be something related with X and drawing, let's see if we can figure it out.

Did you test disabling the composite?
Changing the widget style to Plastik or any other?
Comment 8 Craig Magina 2013-03-11 15:32:51 UTC
I tried all of what you suggested and no change. I have fired up xev to see if the key presses were getting handled by X and if X was registering them as the correct key, it is. I see X86BrightnessUp (or whatever the key is labeled and it matched what I saw on Ubuntu Unity where it does display the brightness bar correctly). I do not believe this is a bug with X, but more likely an interface changed and KDE wasn't updated to work with this change. I believe this as Ubuntu's Unity interface works perfectly and its using the same kernel and X as KDE.

If you could direct me at the code responsible for handling these hardware events, I would be willing to get my hands dirty trying to fix it.
Comment 9 Alex Fiestas 2013-03-12 11:52:39 UTC
you can start by kde-workspace/powerdevil/daemon/powerdevilcore.cpp look for "Increase Screen Brightness"

The technology that draws to the screen is completely different from Unity to KDE, though the underlying technologies are the same.

Try the following:
Desktop effects -> Advanced -> Qt Graphics system -> Native

Then either restart KDED or logout/login.
Comment 10 Craig Magina 2013-03-16 19:11:56 UTC
Due to a mishap with my laptop, I am unable to continue to debug this until, hopefully, I can get it fixed.
Comment 11 Dario Freddi 2013-04-20 18:32:13 UTC
Git commit 245493d67eed84f56b62bceae56aa83c58891f64 by Dario Freddi.
Committed on 20/04/2013 at 20:12.
Pushed by dafre into branch 'master'.

Merge branch 'brightness-changed-signals'

Now brightness changes are always detected and streamed when hardware changes.
The cache itself is hardware based.
Related: bug 295982

M  +46   -10   powerdevil/daemon/backends/upower/powerdevilupowerbackend.cpp

http://commits.kde.org/kde-workspace/245493d67eed84f56b62bceae56aa83c58891f64
Comment 12 Brandon Watkins 2013-09-23 22:17:43 UTC
Does anyone know if this fix is in kde 4.11? I've tried kde 4.11 and 4.11.1 and see this issue. A clevo/system 76 laptop. Brightness keys change brightness but I get OSD, and KDE's battery applet does not reflect that brightness was changed (brightness progress bar still shows old brightness).
Comment 13 Wiktor 2013-09-24 06:33:45 UTC
(In reply to comment #12)
> Does anyone know if this fix is in kde 4.11? I've tried kde 4.11 and 4.11.1
> and see this issue. A clevo/system 76 laptop. Brightness keys change
> brightness but I get OSD, and KDE's battery applet does not reflect that
> brightness was changed (brightness progress bar still shows old brightness).

In my case nothing have changed. I still get OSD in random situations.

Lenovo G780
Comment 14 Jim Jones 2013-09-27 15:13:48 UTC
this bug isn't fixed, same here on gentoo with 4.11.1 on lenovo x220 and x230
Comment 15 Christoph Feck 2013-10-12 17:34:41 UTC
Reopening based on recent comments.
Comment 16 Laurent 2014-01-26 16:02:36 UTC
Same here.

I just commented to this bug: https://bugs.kde.org/show_bug.cgi?id=321310
...which seems to refer to the same problem.

TL;DR: KDE / xev do NOT notice Fn + BrightnessUp/Down key presses. There is no OSD / slider update. However, if I use the slider to change the brightness, everything works fine. Boot params: 'acpi_osi='

System: Lenovo T440p + Arch Linux. Current kernel: 3.12.8-1 mainline 64bit.

Regards
Comment 17 Laurent 2014-01-26 16:29:22 UTC
Hi all,
Fixed it for me on Lenovo T440p
https://bugs.kde.org/show_bug.cgi?id=323516#c24
Regards
Comment 18 Bart 2014-01-26 18:06:25 UTC
Kernel parameters are just a workaround. This is still a KDE bug. On my T440s, xev DOES see XF86MonBrightnessUp and XF86MonBrightnessDown events and the brightness DOES change, but still, I get no OSD.
Comment 19 Alex Fiestas 2014-01-26 18:15:22 UTC
Have you tried going to configure global shortcuts and configure them with your laptop keys? 
(In reply to comment #18)
> Kernel parameters are just a workaround. This is still a KDE bug. On my
> T440s, xev DOES see XF86MonBrightnessUp and XF86MonBrightnessDown events and
> the brightness DOES change, but still, I get no OSD.
Comment 20 Bart 2014-01-26 18:30:06 UTC
I have the default setting, which is indeed change brightness with XF86MonBrightness{Up,Down}. If I change it to something else, like Shift+F5, everything works, including OSD. If I leave it at Fn+F5 (XF86MonBrightnessDown), everything works, *except* OSD.
Comment 21 Jonathan Riddell 2015-03-11 19:17:17 UTC
This bug is reported on libsolid which is the kdelibs4 version of the solid library.  It is now in maintenance mode.  If you think it should still be fixed in the KDE Frameworks 5 version of solid please move it to or report a bug on frameworks-solid or Powerdevil.
Comment 22 Andrew Crouthamel 2018-09-04 15:42:40 UTC
Hello! Sorry to be the bearer of bad news, but this project has been unmaintained for many years so I am closing this bug. Please try again with the latest version and submit a new bug to frameworks-solid if your issue persists. Thank you!