Bug 313841 - No keyboard shortcut for "Find" action
Summary: No keyboard shortcut for "Find" action
Status: RESOLVED FIXED
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: 2.9.8
Platform: Ubuntu Linux
: NOR wishlist with 50 votes (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
: 382009 382709 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-24 18:41 UTC by Oleg Atamanenko
Modified: 2019-03-14 03:25 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Atamanenko 2013-01-24 18:41:09 UTC
There is no default shortcut to run "Find".

Also, in "Configure shortcuts" dialog box there is no possibility to assign custom shortcut for "Find".

It would be nice, if you implement this functionality.

Thank you!

Reproducible: Always
Comment 1 Anders Kreinøe 2015-07-29 07:21:11 UTC
I also have this problem. I have bound copy to meta-c and paste to meta-v in konsole, and it is not reflected in yakuake. Tested on opensuse 13.1 with an updated yakuake:

yakuake --version
Qt: 4.8.5
KDE Udviklingsplatform: 4.11.5
Yakuake: 2.9.9
Comment 2 arcanis 2015-12-04 18:55:28 UTC
same here, using latest git build for frameworks
Comment 3 Eike Hein 2017-07-25 21:53:31 UTC
*** Bug 382009 has been marked as a duplicate of this bug. ***
Comment 4 Eike Hein 2017-07-25 21:53:34 UTC
*** Bug 382709 has been marked as a duplicate of this bug. ***
Comment 5 Alexander Mentyu 2017-08-16 13:34:49 UTC
Confirming this bug on Yakuake 3.0.4+ . Think 'Ctrl+Alt+F' key combination would fit.
Comment 6 zhulik 2018-01-30 22:16:12 UTC
I'm a Qt developer with 5 years experience and I've just spent two hours trying to find where is "Find" action defined is sources. But I did't find neither in yakuake source nor in konsole. I give up. If somebody helps me to find it I will make a pull request with fix.
Comment 7 zhulik 2018-01-30 23:08:38 UTC
Seems like it's not possible to add a shortcut to run "Find" because the terminal widget in yakuake works via KParts plugin system. I thinks it's needed to change konsolepart itself and hell knows what else in KDE=(. Maybe it can be done via some monkey patching through Qt reflections, but I don't have a time to investigate it.
Comment 8 Kurt Hindenburg 2019-03-14 03:25:37 UTC
Git commit 6ba044c145a68b0356fde5cf210d9db812eba310 by Kurt Hindenburg, on behalf of Nicolas Fella.
Committed on 14/03/2019 at 03:25.
Pushed by hindenburg into branch 'master'.

Define shortcuts for Find actions also for konsolepart

Summary:
The find action in Yakuake (and other konsolepart users) is missing
a shortcut. This is because the shortcut is only defined for Konsole
and not for the part.

Test Plan: Press Ctrl + Shift + F in Yakuake, search bar opens

Reviewers: #konsole, hindenburg, hein

Reviewed By: #konsole, hindenburg

Subscribers: konsole-devel

Tags: #konsole

Differential Revision: https://phabricator.kde.org/D19451

M  +10   -13   src/SessionController.cpp

https://commits.kde.org/konsole/6ba044c145a68b0356fde5cf210d9db812eba310