Bug 313740 - Drag and drop saved bookmarks
Summary: Drag and drop saved bookmarks
Status: RESOLVED DUPLICATE of bug 287038
Alias: None
Product: keditbookmarks
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-23 09:17 UTC by Franjo
Modified: 2013-01-23 10:16 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Franjo 2013-01-23 09:17:10 UTC
Application: keditbookmarks (4.8.5 (4.8.5))
KDE Platform Version: 4.8.5 (4.8.5)
Qt Version: 4.8.1
Operating System: Linux 3.2.0-36-generic-pae i686
Distribution: Ubuntu 12.04.1 LTS

-- Information about the crash:
- What I was doing when the application crashed:
1. Marked bookmarks in bookmark directory named WIZ
2. Drag and drop to directoy WIZ_1

-- Backtrace:
Application: Bookmark Editor (keditbookmarks), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xb4de3740 (LWP 13211))]

Thread 3 (Thread 0xb266eb40 (LWP 13212)):
#0  0xb77c9424 in __kernel_vsyscall ()
#1  0xb76a35f0 in poll () from /lib/i386-linux-gnu/libc.so.6
#2  0xb542ba7b in g_poll () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb541e0ae in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb541e56b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb3522134 in ?? () from /usr/lib/i386-linux-gnu/gio/modules/libdconfsettings.so
#6  0xb54416b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb54ead4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb76b1d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0xb1cffb40 (LWP 13213)):
#0  0xb545d0fc in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#1  0xb545d3c8 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb541db85 in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb541e042 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb541e56b in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb341f1ba in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb54416b3 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb54ead4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb76b1d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xb4de3740 (LWP 13211)):
[KCrash Handler]
#7  0xb72811f8 in QDomNode::QDomNode (this=0xbfeb8dec, n=...) at dom/qdom.cpp:2038
#8  0xb7283533 in QDomElement::QDomElement (this=0xbfeb8dec, x=...) at dom/qdom.cpp:4738
#9  0xb75bbd7d in KBookmark (this=0xbfeb8dec) at /usr/include/kbookmark.h:34
#10 TreeItem::bookmark (this=0x0) at ../../../keditbookmarks/kbookmarkmodel/treeitem.cpp:87
#11 0xb75b9991 in KBookmarkModel::bookmarkForIndex (this=0x9035c28, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:396
#12 0xb75b9a1e in KBookmarkModel::parent (this=0x9035c28, index=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:263
#13 0xb64ad5f4 in parent (this=0xbfeb8fe0) at ../../include/QtCore/../../src/corelib/kernel/qabstractitemmodel.h:393
#14 can_create_mapping (source_parent=..., this=0x90aacd0) at itemviews/qsortfilterproxymodel.cpp:401
#15 QSortFilterProxyModelPrivate::can_create_mapping (this=0x90aacd0, source_parent=...) at itemviews/qsortfilterproxymodel.cpp:398
#16 0xb64b09af in QSortFilterProxyModelPrivate::_q_sourceRowsAboutToBeInserted (this=0x90aacd0, source_parent=..., start=3, end=3) at itemviews/qsortfilterproxymodel.cpp:1273
#17 0xb6a136b1 in QMetaObject::activate (sender=0x9035c28, m=0xb6b5a2b8, local_signal_index=4, argv=0xbfeb8f40) at kernel/qobject.cpp:3547
#18 0xb6a65395 in QAbstractItemModel::rowsAboutToBeInserted (this=0x9035c28, _t1=..., _t2=3, _t3=3) at .moc/release-shared/moc_qabstractitemmodel.cpp:190
#19 0xb69f621c in QAbstractItemModel::beginInsertRows (this=0x9035c28, parent=..., first=3, last=3) at kernel/qabstractitemmodel.cpp:2416
#20 0xb75ba73f in KBookmarkModel::beginInsert (this=0x9035c28, group=..., first=3, last=3) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:404
#21 0xb75b5054 in CreateCommand::redo (this=0x9344e88) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:113
#22 0xb75b673f in MoveCommand::redo (this=0x943bd58) at ../../../keditbookmarks/kbookmarkmodel/commands.cpp:374
#23 0xb6583003 in QUndoCommand::redo (this=0x944b5a0) at util/qundostack.cpp:208
#24 0xb6584af5 in QUndoStack::push (this=0x901c26c, cmd=0x944b5a0) at util/qundostack.cpp:583
#25 0xb75b48a8 in CommandHistory::addCommand (this=0x901c208, cmd=0x944b5a0) at ../../../keditbookmarks/kbookmarkmodel/commandhistory.cpp:107
#26 0xb75bb1ef in KBookmarkModel::dropMimeData (this=0x9035c28, data=0x90fb800, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../../keditbookmarks/kbookmarkmodel/model.cpp:380
#27 0xb77b636b in BookmarkFolderViewFilterModel::dropMimeData (this=0x90a9ea0, data=0x90fb800, action=Qt::MoveAction, row=-1, column=-1, parent=...) at ../../keditbookmarks/bookmarklistview.cpp:187
#28 0xb64179a6 in QAbstractItemView::dropEvent (this=0x90a7a40, event=0xbfeb9bac) at itemviews/qabstractitemview.cpp:2006
#29 0xb5ec294f in QWidget::event (this=0x90a7a40, event=0xbfeb9bac) at kernel/qwidget.cpp:8552
#30 0xb62dfe55 in QFrame::event (this=0x90a7a40, e=0xbfeb9bac) at widgets/qframe.cpp:557
#31 0xb6372ab1 in QAbstractScrollArea::viewportEvent (this=0x90a7a40, e=0xbfeb9bac) at widgets/qabstractscrollarea.cpp:1043
#32 0xb6418acc in QAbstractItemView::viewportEvent (this=0x90a7a40, event=0xbfeb9bac) at itemviews/qabstractitemview.cpp:1644
#33 0xb6466b66 in QTreeView::viewportEvent (this=0x90a7a40, event=0xbfeb9bac) at itemviews/qtreeview.cpp:1257
#34 0xb63751d6 in viewportEvent (this=<optimized out>, event=0xbfeb9bac) at widgets/qabstractscrollarea_p.h:100
#35 eventFilter (e=0xbfeb9bac, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#36 QAbstractScrollAreaFilter::eventFilter (this=0x90a87a0, o=0x90a7ed8, e=0xbfeb9bac) at widgets/qabstractscrollarea_p.h:115
#37 0xb69fcb16 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8e8a708, receiver=0x90a7ed8, event=0xbfeb9bac) at kernel/qcoreapplication.cpp:986
#38 0xb5e67ea2 in notify_helper (e=0xbfeb9bac, receiver=0x90a7ed8, this=0x8e8a708) at kernel/qapplication.cpp:4555
#39 QApplicationPrivate::notify_helper (this=0x8e8a708, receiver=0x90a7ed8, e=0xbfeb9bac) at kernel/qapplication.cpp:4531
#40 0xb5e6dc6f in QApplication::notify (this=0x8e8a708, receiver=0x90a7ed8, e=0xbfeb9bac) at kernel/qapplication.cpp:4345
#41 0xb701be01 in KApplication::notify (this=0xbfebbc44, receiver=0x90a7ed8, event=0xbfeb9bac) at ../../kdeui/kernel/kapplication.cpp:311
#42 0xb69fc97e in QCoreApplication::notifyInternal (this=0xbfebbc44, receiver=0x90a7ed8, event=0xbfeb9bac) at kernel/qcoreapplication.cpp:876
#43 0xb5f00531 in sendEvent (event=0xbfeb9bac, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#44 QX11Data::xdndHandleDrop (this=0x8e8dc00, xe=0xbfeb9c8c, passive=false) at kernel/qdnd_x11.cpp:1185
#45 0xb5f017f4 in QDragManager::drop (this=0x9324560) at kernel/qdnd_x11.cpp:1750
#46 0xb5f04802 in QDragManager::eventFilter (this=0x9324560, o=0x9580a88, e=0xbfeba194) at kernel/qdnd_x11.cpp:1314
#47 0xb69fca4b in QCoreApplicationPrivate::sendThroughApplicationEventFilters (this=0x8e8a708, receiver=0x9580a88, event=0xbfeba194) at kernel/qcoreapplication.cpp:967
#48 0xb5e67e4a in QApplicationPrivate::notify_helper (this=0x8e8a708, receiver=0x9580a88, e=0xbfeba194) at kernel/qapplication.cpp:4534
#49 0xb5e6e024 in QApplication::notify (this=0x8e8a708, receiver=0x9580a88, e=0xbfeba194) at kernel/qapplication.cpp:4102
#50 0xb701be01 in KApplication::notify (this=0xbfebbc44, receiver=0x9580a88, event=0xbfeba194) at ../../kdeui/kernel/kapplication.cpp:311
#51 0xb69fc97e in QCoreApplication::notifyInternal (this=0xbfebbc44, receiver=0x9580a88, event=0xbfeba194) at kernel/qcoreapplication.cpp:876
#52 0xb5e68e95 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#53 QApplicationPrivate::sendMouseEvent (receiver=0x9580a88, event=0xbfeba194, alienWidget=0x0, nativeWidget=0x9580a88, buttonDown=0xb67fccf4, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#54 0xb5ef5074 in QETWidget::translateMouseEvent (this=0x9580a88, event=0xbfeba64c) at kernel/qapplication_x11.cpp:4617
#55 0xb5ef3c0d in QApplication::x11ProcessEvent (this=0xbfebbc44, event=0xbfeba64c) at kernel/qapplication_x11.cpp:3732
#56 0xb5f20eac in x11EventSourceDispatch (s=0x8e8a430, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#57 0xb541dd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#58 0xb541e125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#59 0xb541e201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#60 0xb6a2f887 in QEventDispatcherGlib::processEvents (this=0x8e89ad8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#61 0xb5f20aaa in QGuiEventDispatcherGlib::processEvents (this=0x8e89ad8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#62 0xb69fb50d in QEventLoop::processEvents (this=0x92475b8, flags=...) at kernel/qeventloop.cpp:149
#63 0xb69fb7a9 in QEventLoop::exec (this=0x92475b8, flags=...) at kernel/qeventloop.cpp:204
#64 0xb5f044cc in QDragManager::drag (this=0x9324560, o=0x9246f90) at kernel/qdnd_x11.cpp:2017
#65 0xb5e7b981 in QDrag::exec (this=0x9246f90, supportedActions=..., defaultDropAction=Qt::MoveAction) at kernel/qdrag.cpp:284
#66 0xb64253dc in QAbstractItemView::startDrag (this=0x908c358, supportedActions=...) at itemviews/qabstractitemview.cpp:3540
#67 0xb642382d in QAbstractItemView::mouseMoveEvent (this=0x908c358, event=0xbfebab20) at itemviews/qabstractitemview.cpp:1725
#68 0xb64669fc in QTreeView::mouseMoveEvent (this=0x908c358, event=0xbfebb3f4) at itemviews/qtreeview.cpp:1939
#69 0xb5ec21e8 in QWidget::event (this=0x908c358, event=0xbfebb3f4) at kernel/qwidget.cpp:8347
#70 0xb62dfe55 in QFrame::event (this=0x908c358, e=0xbfebb3f4) at widgets/qframe.cpp:557
#71 0xb6372ab1 in QAbstractScrollArea::viewportEvent (this=0x908c358, e=0xbfebb3f4) at widgets/qabstractscrollarea.cpp:1043
#72 0xb6418acc in QAbstractItemView::viewportEvent (this=0x908c358, event=0xbfebb3f4) at itemviews/qabstractitemview.cpp:1644
#73 0xb6466b66 in QTreeView::viewportEvent (this=0x908c358, event=0xbfebb3f4) at itemviews/qtreeview.cpp:1257
#74 0xb63751d6 in viewportEvent (this=<optimized out>, event=0xbfebb3f4) at widgets/qabstractscrollarea_p.h:100
#75 eventFilter (e=0xbfebb3f4, this=<optimized out>, o=<optimized out>) at widgets/qabstractscrollarea_p.h:116
#76 QAbstractScrollAreaFilter::eventFilter (this=0x9030990, o=0x908c2d0, e=0xbfebb3f4) at widgets/qabstractscrollarea_p.h:115
#77 0xb69fcb16 in QCoreApplicationPrivate::sendThroughObjectEventFilters (this=0x8e8a708, receiver=0x908c2d0, event=0xbfebb3f4) at kernel/qcoreapplication.cpp:986
#78 0xb5e67ea2 in notify_helper (e=0xbfebb3f4, receiver=0x908c2d0, this=0x8e8a708) at kernel/qapplication.cpp:4555
#79 QApplicationPrivate::notify_helper (this=0x8e8a708, receiver=0x908c2d0, e=0xbfebb3f4) at kernel/qapplication.cpp:4531
#80 0xb5e6e024 in QApplication::notify (this=0x8e8a708, receiver=0x908c2d0, e=0xbfebb3f4) at kernel/qapplication.cpp:4102
#81 0xb701be01 in KApplication::notify (this=0xbfebbc44, receiver=0x908c2d0, event=0xbfebb3f4) at ../../kdeui/kernel/kapplication.cpp:311
#82 0xb69fc97e in QCoreApplication::notifyInternal (this=0xbfebbc44, receiver=0x908c2d0, event=0xbfebb3f4) at kernel/qcoreapplication.cpp:876
#83 0xb5e68e95 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#84 QApplicationPrivate::sendMouseEvent (receiver=0x908c2d0, event=0xbfebb3f4, alienWidget=0x908c2d0, nativeWidget=0x901db30, buttonDown=0xb67fccf4, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3170
#85 0xb5ef5074 in QETWidget::translateMouseEvent (this=0x901db30, event=0xbfebb8ac) at kernel/qapplication_x11.cpp:4617
#86 0xb5ef3c0d in QApplication::x11ProcessEvent (this=0xbfebbc44, event=0xbfebb8ac) at kernel/qapplication_x11.cpp:3732
#87 0xb5f20eac in x11EventSourceDispatch (s=0x8e8a430, callback=0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#88 0xb541dd86 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#89 0xb541e125 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#90 0xb541e201 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#91 0xb6a2f887 in QEventDispatcherGlib::processEvents (this=0x8e89ad8, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#92 0xb5f20aaa in QGuiEventDispatcherGlib::processEvents (this=0x8e89ad8, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#93 0xb69fb50d in QEventLoop::processEvents (this=0xbfebbba4, flags=...) at kernel/qeventloop.cpp:149
#94 0xb69fb7a9 in QEventLoop::exec (this=0xbfebbba4, flags=...) at kernel/qeventloop.cpp:204
#95 0xb6a00eba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1148
#96 0xb5e65a74 in QApplication::exec () at kernel/qapplication.cpp:3820
#97 0xb779b5e3 in kdemain (argc=5, argv=0xbfebbf04) at ../../keditbookmarks/main.cpp:212
#98 0x0804850b in main (argc=5, argv=0xbfebbf04) at keditbookmarks_dummy.cpp:3

Possible duplicates by query: bug 287038.

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-01-23 10:16:14 UTC

*** This bug has been marked as a duplicate of bug 287038 ***