Bug 313577 - Crashes when pressing the "send to" button
Summary: Crashes when pressing the "send to" button
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Portability-Runtime (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-20 16:46 UTC by swarfega
Modified: 2018-02-04 11:15 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description swarfega 2013-01-20 16:46:16 UTC
Application: ksnapshot (0.8.2)
KDE Platform Version: 4.9.98
Qt Version: 4.8.3
Operating System: Linux 3.5.0-22-generic x86_64
Distribution: Ubuntu 12.10

-- Information about the crash:
I changed the snapshot area to window under the cursor and then pressed send to button afterwards. Its when pressing this button that I get this crash every time.

Kubuntu 12.10. Ksnapshot:  0.8.2. KDE: 4.9.98.

The crash can be reproduced every time.

-- Backtrace:
Application: KSnapshot (ksnapshot), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbf44d43780 (LWP 22769))]

Thread 2 (Thread 0x7fbf32d23700 (LWP 22770)):
#0  0x00007fbf3ecaaf69 in __pthread_mutex_lock (mutex=0x7fbf2c000a60) at pthread_mutex_lock.c:92
#1  0x00007fbf3e816e21 in g_mutex_lock () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fbf3e7d9623 in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fbf3e7d9cab in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fbf3e7d9ea4 in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fbf42003c16 in QEventDispatcherGlib::processEvents (this=0x7fbf2c0008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0x00007fbf41fd42bf in QEventLoop::processEvents (this=this@entry=0x7fbf32d22dd0, flags=...) at kernel/qeventloop.cpp:149
#7  0x00007fbf41fd4548 in QEventLoop::exec (this=0x7fbf32d22dd0, flags=...) at kernel/qeventloop.cpp:204
#8  0x00007fbf41ed5b10 in QThread::exec (this=<optimized out>) at thread/qthread.cpp:501
#9  0x00007fbf41fb49af in QInotifyFileSystemWatcherEngine::run (this=0x14022d0) at io/qfilesystemwatcher_inotify.cpp:248
#10 0x00007fbf41ed8aec in QThreadPrivate::start (arg=0x14022d0) at thread/qthread_unix.cpp:338
#11 0x00007fbf3eca8e9a in start_thread (arg=0x7fbf32d23700) at pthread_create.c:308
#12 0x00007fbf41592cbd in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:112
#13 0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7fbf44d43780 (LWP 22769)):
[KCrash Handler]
#6  QString::operator= (this=0x75006c00700089, other=...) at tools/qstring.cpp:1411
#7  0x00007fbf31e86d89 in KIPI::Plugin::setUiBaseName (this=0x1510cb0, name=<optimized out>) at ../../libkipi/plugin.cpp:309
#8  0x00007fbf323035b3 in KIPIFacebookPlugin::Plugin_Facebook::Plugin_Facebook (this=0x1510cb0, parent=0x130f9f0) at /build/buildd/digikam-3.0.0~beta3/extra/kipi-plugins/facebook/plugin_facebook.cpp:72
#9  0x00007fbf323040f7 in KPluginFactory::createInstance<KIPIFacebookPlugin::Plugin_Facebook, QObject> (parentWidget=<optimized out>, parent=<optimized out>, args=...) at /usr/include/kpluginfactory.h:477
#10 0x00007fbf427acd55 in KPluginFactory::create (this=0x14f9ee0, iface=0x7fbf43d730c0 "KIPI::Plugin", parentWidget=0x0, parent=0x130f9f0, args=..., keyword=...) at ../../kdecore/util/kpluginfactory.cpp:203
#11 0x00007fbf43d67586 in KIPI::PluginLoader::Info::plugin() const () from /usr/lib/libkipi.so.9
#12 0x0000000000417758 in _start ()

Reported using DrKonqi
Comment 1 Jekyll Wu 2013-01-20 20:57:48 UTC
Please use more descriptive summary when you report bugs, instead of a bare "ksnapshot"
Comment 2 caulier.gilles 2013-01-21 06:57:40 UTC

*** This bug has been marked as a duplicate of bug 307775 ***
Comment 3 caulier.gilles 2018-02-04 11:15:26 UTC
Problem fixed in 6.0.0 where all tools are now in digiKam core