Bug 313523 - while move images from one folder to other there is an error report and the image is delete
Summary: while move images from one folder to other there is an error report and the i...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Files (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR critical (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords: reproducible
Depends on:
Blocks:
 
Reported: 2013-01-19 22:04 UTC by luigi
Modified: 2017-07-26 07:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description luigi 2013-01-19 22:04:25 UTC
I've imported old db storage from previous version of digikam 32 bit version to version 2.8 ubuntu package 64 bit. The program import correctly the old labels and album but when I try to move some image from one album to another the program say 'is not possible to rename file 'filename'' and after that the image is delete! Some image are trasformed in folder with the same name, this is a serious bug because the image are lost!! I hope this is resolvable problem because I like very well this progam and how it automatically import and organize the photos.  

Reproducible: Always

Steps to Reproduce:
1.Import previous sqlite image data 32bit digikam version in 64bit digikam version nder ubuntu 12.10 whit gnome interfaceand no kde intalled  
2.Try to move some image from one album to another and it abort whit message that the name of image can't change, but for some image it work right.
3.try to edit preview into digikam and you can note that it can't do it and the size is 0byte, try to navigate with some file manager and you can note that the image are deleted or are trasformed in folder with same name, it's incomprehensible and an irreversible damage.
Comment 1 caulier.gilles 2013-11-25 12:08:46 UTC
This problem is reproducible with 3.5.0 release ?

Gilles Caulier
Comment 2 luigi 2013-12-08 20:15:30 UTC
Hi, 

I haven't 3.5.0 relase, I've 2.8.0 relase from ubuntu 12.10 repository, the 
scheme is that I've in internal hd ubunt and on external hd the photos imported 
with digikam, I don't know if the problem is that external hd has ntfs file 
system and writing from ubuntu/digikam is not safe.

After several recovery program I find the about 5000 photos and I copied them 
in internal hd, after a safe copy I reimported these photos in digikam to 
discover if in local linux filesystem there is the same problem, but I have to 
work hard to restore all categories.. so I don't know if is this the problem.





>----Messaggio originale----
>Da: caulier.gilles@gmail.com
>Data: 25/11/2013 13.08
>A: <luigi_159@libero.it>
>Ogg: [digikam] [Bug 313523] while move images from one folder to other there 
is an error report and the image is delete
>
>https://bugs.kde.org/show_bug.cgi?id=313523
>
>Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>                 CC|                            |caulier.gilles@gmail.com
>
>--- Comment #1 from Gilles Caulier <caulier.gilles@gmail.com> ---
>This problem is reproducible with 3.5.0 release ?
>
>Gilles Caulier
>
>-- 
>You are receiving this mail because:
>You reported the bug.
>
Comment 3 luigi 2013-12-08 20:18:58 UTC
Hi, 

I haven't 3.5.0 relase, I've 2.8.0 relase from ubuntu 12.10 repository, the 
scheme is that I've in internal hd ubunt and on external hd the photos imported 
with digikam, I don't know if the problem is that external hd has ntfs file 
system and writing from ubuntu/digikam is not safe.

After several recovery program I find the about 5000 photos and I copied them 
in internal hd, after a safe copy I reimported these photos in digikam to 
discover if in local linux filesystem there is the same problem, but I have to 
work hard to restore all categories.. so I don't know if is this the problem.





>>----Messaggio originale----
>>Da: caulier.gilles@gmail.com
>>Data: 25/11/2013 13.08
>>A: <luigi_159@libero.it>
>>Ogg: [digikam] [Bug 313523] while move images from one folder to other 
there 
>is an error report and the image is delete
>>
>>https://bugs.kde.org/show_bug.cgi?id=313523
>>
>>Gilles Caulier <caulier.gilles@gmail.com> changed:
>>
>>           What    |Removed                     |Added
>>----------------------------------------------------------------------------
>>                 CC|                            |caulier.gilles@gmail.com
>>
>>--- Comment #1 from Gilles Caulier <caulier.gilles@gmail.com> ---
>>This problem is reproducible with 3.5.0 release ?
>>
>>Gilles Caulier
>>
>>-- 
>>You are receiving this mail because:
>>You reported the bug.
>>
>
>-- 
>You are receiving this mail because:
>You reported the bug.
>
Comment 4 caulier.gilles 2014-08-22 13:42:12 UTC
Still reproducible using last digiKam 4.2.0 ?

Gilles Caulier
Comment 5 luigi 2014-08-30 13:48:27 UTC
I don't know, I've try to compile the last version of Digikam under Ubuntu 
12.10 but there was some dipendency problem  so I' ve the version 2.8.0 .

Let me expose some excellent feature and limitation of Digikam,  and try to 
understand the problem cause ( I'm a developer but with firmare on embedded 
system with c/c++ and I've no suffice knowlodge about develop on kde/qt, I'd 
like join this project  in the future because I think that it is very advanced 
but some features must be improve.)

I choose DIgikam because I think that it's perfect for my scope:

1- It let me to download only new photos from sd card automatically and 
automatically you can set-up to create date based album as first step 
organization so you don't worry about double photos and with tags you have a 
complete organization for find all photos

2- It let me to have the root album and database on external hard disk so I 
can import it on digikam from several operating system but under windows is 
very slow so I decide to uninstall it because is not utilizable, I haven't try 
on mac if is fast as is on linux. It let me to access database from another pc 
with too.

3- face detection seem very interesting but although it find the face very 
well if i tag the same people several times end try to tell Digikam to try to 
detect and tag untagged faces it don't work, I have to tag all the faces, I 
don't know this feature is under progress or more advanced in lastest versions.


About feature number "2" i Think that a possible problem was this: I have an 
exernal HD with NTFS file system. I created the root album on it for advantage 
exposed above. When I started pc with windows with HD attached the message like 
"the file system seem corrupted or with some problem do you want to check it"?  
I reply "no" but I could access on it from windows without problem and browse 
root album with file manager. Now I have another pc with new version of ubuntu 
and digikam and I have imported the old database from external HD, but after 
that I have this problem, I don't know is the problem is the write on NTFS file 
system from linux... it's possible? but why all other folders created with 
linux are unchanged? only with DIgikam the write problem has occourred, and 
only in the folder image.
But on digikam there is not alert about warning on NTFS file system. 
As soon as I upgrade the os version I try to install the last version of 
digikam.

Best regards, 

Luigi Berardi

>----Messaggio originale----
>Da: caulier.gilles@gmail.com
>Data: 22/08/2014 15.42
>A: <luigi_159@libero.it>
>Ogg: [digikam] [Bug 313523] while move images from one folder to other there 
is an error report and the image is delete
>
>https://bugs.kde.org/show_bug.cgi?id=313523
>
>--- Comment #4 from Gilles Caulier <caulier.gilles@gmail.com> ---
>Still reproducible using last digiKam 4.2.0 ?
>
>Gilles Caulier
>
>-- 
>You are receiving this mail because:
>You reported the bug.
>
Comment 6 caulier.gilles 2015-05-10 08:15:09 UTC
Luigi,

Problem still reproducible using last stable digiKam 4.9.0 ?

Gilles Caulier
Comment 7 luigi 2015-05-13 08:30:20 UTC
Hi, 
I don't know, I have to upgrade my OS to have the last version of digikam, I 
have some library configuration problem while try intalling Digikam outside 
from OS repository.

best regards, 
Luigi Berardi


>----Messaggio originale----
>Da: caulier.gilles@gmail.com
>Data: 10/05/2015 10.15
>A: <luigi_159@libero.it>
>Ogg: [digikam] [Bug 313523] while move images from one folder to other there 
is an error report and the image is delete
>
>https://bugs.kde.org/show_bug.cgi?id=313523
>
>Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>           What    |Removed                     |Added
>----------------------------------------------------------------------------
>         Resolution|---                         |WAITINGFORINFO
>             Status|UNCONFIRMED                 |RESOLVED
>
>--- Comment #6 from Gilles Caulier <caulier.gilles@gmail.com> ---
>Luigi,
>
>Problem still reproducible using last stable digiKam 4.9.0 ?
>
>Gilles Caulier
>
>-- 
>You are receiving this mail because:
>You reported the bug.
>
Comment 8 caulier.gilles 2015-06-26 13:44:01 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles Caulier
Comment 9 caulier.gilles 2015-08-21 07:04:26 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.
Comment 10 caulier.gilles 2016-07-07 05:17:46 UTC
Since digiKam drop KIO Slave support to move files with 5.0.0, this problem is not reproducible.

I close this file now. Don't hesitate to re-open if necessary.

Gilles Caulier