Bug 313507 - digiKam does not start reliable anymore.
Summary: digiKam does not start reliable anymore.
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Scan (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR grave (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-19 13:47 UTC by Axel Krebs
Modified: 2017-07-25 13:19 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.4.0


Attachments
startup-log of digiKam (178.04 KB, text/plain)
2013-01-19 13:48 UTC, Axel Krebs
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2013-01-19 13:47:17 UTC
digiKam does not atart reliable anymore. Sometimes, it takes forever. 

Reproducible: Always

Steps to Reproduce:
1. Happens five times since two days 
2. Started from comand line- error log enclosed
3. 
Actual Results:  
When starting digiKam, it takes long times (3 or 4 minutes?).

In "system monitor", I can see, that digiKam takes about 18 to 20 MB memory. Earlier days it reserved more and more memory, and, when using some 320 MB, it would appear 8open) on desktop.

Now, it takes memory up to this limit then "crashes silent" without further viseble reactions.

Maybe relatet to quicktime?

Expected Results:  
Something slows down regular use of digiKam: writing metadata,(tags), starting up or even crashing.

Digikam sould start up quicker, work quicker and much more reliable.
Comment 1 Axel Krebs 2013-01-19 13:48:46 UTC
Created attachment 76565 [details]
startup-log of digiKam
Comment 2 caulier.gilles 2013-01-21 07:10:09 UTC
From your log, not KDE KIOSlave structure is present to run digiKam KIOSlave properlly. It's not a digiKam fault, it's system fault...

Check your system, or install a new one cleanly. Can you image that we develop or use digiKam in same conditions ? I never see this error on my system, and i use digiKam everyday...

Gilles Caulier
Comment 3 caulier.gilles 2016-12-24 14:30:09 UTC
digKam KIO slaves have been removed since 5.0.0 and replaced by a multi-threaded interface.

Gilles Caulier