Bug 313506 - erasing files should be an independent process in digKam
Summary: erasing files should be an independent process in digKam
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Trash (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-19 13:29 UTC by Axel Krebs
Modified: 2017-07-26 07:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.7.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Axel Krebs 2013-01-19 13:29:41 UTC
Sometimes, there are many processes going on simultaneously. If these are kept as individual processes, they can be treate (and stopped!) as single entities. 


Reproducible: Always

Steps to Reproduce:
1. when running several processes, files erasing does not apppear as an independent processes
2. erasing does not appear at all as a process
3.
Actual Results:  
unfortunately, there is no way within digiKam to stop  running deleting process at all

Expected Results:  
Deleting should be kept carefully as an individual process. 
Only in this case (??), the process can be stopped as a single task, without "killing" digikam completely. in this case, the integrity of digiKam database could be indangered.
Comment 1 Smit Mehta 2013-01-20 18:12:11 UTC
Hi Axel

Deleting pics is a KDE's routine. digiKam just calls the API. You must have noticed, when you delete the pics, your KDE's system tray will show you a notification of a process which indicates deletion of pictures. You can stop them from there. You dont need to "kill" digikam for stopping it.

@Gilles, I am closing this bug. Reopen it if you feel something is supposed to be done here.

Smit
Comment 2 Axel Krebs 2013-01-20 19:07:49 UTC
hi Smit:

does this mean, that other processes, as given in service manager e.g.,
are digiKam internal processes?

Hmm... ?!


Thanks, Axel

, Am 20.01.2013 19:12, schrieb Smit Mehta:
> https://bugs.kde.org/show_bug.cgi?id=313506
> 
> Smit Mehta <smit.meh@gmail.com> changed:
> 
>            What    |Removed                     |Added
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>                  CC|                            |smit.meh@gmail.com
>          Resolution|---                         |INVALID
> 
> --- Comment #1 from Smit Mehta <smit.meh@gmail.com> ---
> Hi Axel
> 
> Deleting pics is a KDE's routine. digiKam just calls the API. You must have
> noticed, when you delete the pics, your KDE's system tray will show you a
> notification of a process which indicates deletion of pictures. You can stop
> them from there. You dont need to "kill" digikam for stopping it.
> 
> @Gilles, I am closing this bug. Reopen it if you feel something is supposed to
> be done here.
> 
> Smit
>
Comment 3 caulier.gilles 2013-01-21 07:24:31 UTC
Smit, closing as invalid is fine...
Comment 4 caulier.gilles 2017-07-26 07:04:44 UTC
Since digiKam 5.0.0 we have an independent database trash management with a dedicated trash album  for each collection. The low level file processing with trash is don through a multi-threaded interface.