Bug 313500 - Crash during modify of a picture
Summary: Crash during modify of a picture
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Database-Models (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-19 12:55 UTC by Ernesto
Modified: 2017-08-08 09:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ernesto 2013-01-19 12:55:39 UTC
Application: digikam (2.8.0)
KDE Platform Version: 4.9.4
Qt Version: 4.8.3
Operating System: Linux 3.5.0-21-generic i686
Distribution: Ubuntu 12.10

-- Information about the crash:
- What I was doing when the application crashed: I have adjusted a picture with "automatic correction" command . By clic on "forward", system asked me i i wanted save changes. I said yes, then system crashed !  Saluti, Ernesto

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0xaedc68c0 (LWP 2310))]

Thread 7 (Thread 0xacbffb40 (LWP 2314)):
#0  0xb3488c70 in __pthread_mutex_unlock_usercnt () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb47878a4 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb3114f10 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30d3bef in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb30d41db in g_main_loop_run () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xaf95cb7a in ?? () from /usr/lib/i386-linux-gnu/libgio-2.0.so.0
#6  0xb30f9303 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#7  0xb3485d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4779d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 6 (Thread 0xab596b40 (LWP 2315)):
#0  0xb7781424 in __kernel_vsyscall ()
#1  0xb348996b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb478764c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4a50030 in wait (time=4294967295, this=0x8e38190) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x8e380fc, mutex=0x8e380f8, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0x081f2389 in Digikam::ScanController::run() ()
#6  0xb4a4fa58 in QThreadPrivate::start (arg=0x8e36400) at thread/qthread_unix.cpp:338
#7  0xb3485d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4779d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 5 (Thread 0xaad95b40 (LWP 2316)):
#0  0xb3487dc8 in pthread_mutex_lock () from /lib/i386-linux-gnu/libpthread.so.0
#1  0xb4787864 in pthread_mutex_lock () from /lib/i386-linux-gnu/libc.so.6
#2  0xb3114ed0 in g_mutex_lock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30d37cd in g_main_context_check () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb30d3c92 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb30d3e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#6  0xb4b9499f in QEventDispatcherGlib::processEvents (this=0xac207748, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0xb4b6126c in QEventLoop::processEvents (this=this@entry=0xaad950a8, flags=...) at kernel/qeventloop.cpp:149
#8  0xb4b61561 in QEventLoop::exec (this=0xaad950a8, flags=...) at kernel/qeventloop.cpp:204
#9  0xb4a4c66c in QThread::exec (this=0x8e3ef58) at thread/qthread.cpp:501
#10 0xb4b3f7bd in QInotifyFileSystemWatcherEngine::run (this=0x8e3ef58) at io/qfilesystemwatcher_inotify.cpp:248
#11 0xb4a4fa58 in QThreadPrivate::start (arg=0x8e3ef58) at thread/qthread_unix.cpp:338
#12 0xb3485d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#13 0xb4779d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 4 (Thread 0xaa594b40 (LWP 2322)):
#0  0xb7781424 in __kernel_vsyscall ()
#1  0xb348996b in pthread_cond_wait@@GLIBC_2.3.2 () from /lib/i386-linux-gnu/libpthread.so.0
#2  0xb478764c in pthread_cond_wait () from /lib/i386-linux-gnu/libc.so.6
#3  0xb4a50030 in wait (time=4294967295, this=0x8f95fe8) at thread/qwaitcondition_unix.cpp:86
#4  QWaitCondition::wait (this=0x9193b68, mutex=0x9193b64, time=4294967295) at thread/qwaitcondition_unix.cpp:158
#5  0xb6a1bfba in Digikam::ParkingThread::run() () from /usr/lib/libdigikamcore.so.2
#6  0xb4a4fa58 in QThreadPrivate::start (arg=0x9193b58) at thread/qthread_unix.cpp:338
#7  0xb3485d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#8  0xb4779d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 3 (Thread 0xa2af7b40 (LWP 2378)):
#0  0xb4787881 in pthread_mutex_unlock () from /lib/i386-linux-gnu/libc.so.6
#1  0xb3114f10 in g_mutex_unlock () from /lib/i386-linux-gnu/libglib-2.0.so.0
#2  0xb30d369d in g_main_context_query () from /lib/i386-linux-gnu/libglib-2.0.so.0
#3  0xb30d3c5e in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#4  0xb30d3e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#5  0xb4b9499f in QEventDispatcherGlib::processEvents (this=0xa0fb1928, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#6  0xb4b6126c in QEventLoop::processEvents (this=this@entry=0xa2af70b8, flags=...) at kernel/qeventloop.cpp:149
#7  0xb4b61561 in QEventLoop::exec (this=0xa2af70b8, flags=...) at kernel/qeventloop.cpp:204
#8  0xb6a1b540 in Digikam::WorkerObjectRunnable::run() () from /usr/lib/libdigikamcore.so.2
#9  0xb4a42444 in QThreadPoolThread::run (this=0x9ec8078) at concurrent/qthreadpool.cpp:107
#10 0xb4a4fa58 in QThreadPrivate::start (arg=0x9ec8078) at thread/qthread_unix.cpp:338
#11 0xb3485d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#12 0xb4779d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 2 (Thread 0x97706b40 (LWP 2394)):
#0  0xb4e88244 in KLocalePrivate::translateRawFrom (this=0x8dfaa90, catname=0x0, msgctxt=0xa9d8effa "QSQLiteResult", msgid=0xa9d8f0f6 "Unable to fetch row", msgid_plural=0x0, n=0, language=0x977057f8, translation=0x977057f4) at ../../kdecore/localization/klocale_kde.cpp:941
#1  0xb4e80528 in KLocalePrivate::translateQt (this=0x8dfaa90, context=0xa9d8effa "QSQLiteResult", sourceText=0xa9d8f0f6 "Unable to fetch row", comment=0x0) at ../../kdecore/localization/klocale_kde.cpp:1022
#2  0xb4e7af23 in KLocale::translateQt (this=0x8d984d0, context=0xa9d8effa "QSQLiteResult", sourceText=0xa9d8f0f6 "Unable to fetch row", comment=0x0) at ../../kdecore/localization/klocale.cpp:199
#3  0x97705900 in ?? ()
#4  0x0850c204 in typeinfo for Digikam::HidingStateChanger ()
#5  0xaf2943db in ?? () from /usr/lib/i386-linux-gnu/libsqlite3.so.0
#6  0xb4b89474 in clear (d=0x97705a94) at kernel/qvariant.cpp:198
#7  0xb510be49 in clear (d=0x97705a94) at kernel/qguivariant.cpp:280
#8  0xb4b859ca in QVariant::~QVariant (this=0x9ef2db40, __in_chrg=<optimized out>) at kernel/qvariant.cpp:1412
#9  0xa9d8e162 in QSQLiteResult::exec (this=0x9fc425c0) at ../../../sql/drivers/sqlite/qsql_sqlite.cpp:448
#10 0xb7737de6 in QSqlQuery::exec (this=0x97705c38) at kernel/qsqlquery.cpp:949
#11 0xb69d1cf1 in Digikam::DatabaseCoreBackend::exec(Digikam::SqlQuery&) () from /usr/lib/libdigikamcore.so.2
#12 0xb69d07ee in Digikam::DatabaseCoreBackend::execQuery(Digikam::SqlQuery&, QVariant const&, QVariant const&, QVariant const&, QVariant const&) () from /usr/lib/libdigikamcore.so.2
#13 0xb69d03f5 in Digikam::DatabaseCoreBackend::execQuery(QString const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&) () from /usr/lib/libdigikamcore.so.2
#14 0xb69cfe56 in Digikam::DatabaseCoreBackend::execSql(QString const&, QVariant const&, QVariant const&, QVariant const&, QVariant const&, QList<QVariant>*, QVariant*) () from /usr/lib/libdigikamcore.so.2
#15 0xb69db3de in Digikam::ThumbnailDB::insertThumbnail(Digikam::DatabaseThumbnailInfo const&, QVariant*) () from /usr/lib/libdigikamcore.so.2
#16 0xb69fbaf9 in Digikam::ThumbnailCreator::storeInDatabase(Digikam::ThumbnailInfo const&, Digikam::ThumbnailImage const&) const () from /usr/lib/libdigikamcore.so.2
#17 0xb69f9270 in Digikam::ThumbnailCreator::load(QString const&, QRect const&, bool) const () from /usr/lib/libdigikamcore.so.2
#18 0xb69f8e6f in Digikam::ThumbnailCreator::load(QString const&) const () from /usr/lib/libdigikamcore.so.2
#19 0xb6a06b81 in Digikam::ThumbnailLoadingTask::execute() () from /usr/lib/libdigikamcore.so.2
#20 0xb69e5017 in Digikam::LoadSaveThread::run() () from /usr/lib/libdigikamcore.so.2
#21 0xb6a1dfd6 in Digikam::DynamicThread::DynamicThreadPriv::run() () from /usr/lib/libdigikamcore.so.2
#22 0xb4a42444 in QThreadPoolThread::run (this=0x9ec7a48) at concurrent/qthreadpool.cpp:107
#23 0xb4a4fa58 in QThreadPrivate::start (arg=0x9ec7a48) at thread/qthread_unix.cpp:338
#24 0xb3485d4c in start_thread () from /lib/i386-linux-gnu/libpthread.so.0
#25 0xb4779d3e in clone () from /lib/i386-linux-gnu/libc.so.6

Thread 1 (Thread 0xaedc68c0 (LWP 2310)):
[KCrash Handler]
#7  QSortFilterProxyModelPrivate::proxy_to_source (this=0xa1d33e8, proxy_index=...) at itemviews/qsortfilterproxymodel.cpp:369
#8  0xb56f8283 in QSortFilterProxyModel::mapToSource (this=0xa1d2b38, proxyIndex=...) at itemviews/qsortfilterproxymodel.cpp:2503
#9  0x080b6460 in Digikam::ModelIndexBasedComboBox::hidePopup ()
#10 0xb660f292 in Digikam::ImageSortFilterModel::mapToSourceImageModel(QModelIndex const&) const () from /usr/lib/libdigikamdatabase.so.2
#11 0xb660f65c in Digikam::ImageSortFilterModel::imageInfo(QModelIndex const&) const () from /usr/lib/libdigikamdatabase.so.2
#12 0x080be364 in Digikam::ImageWindow::loadIndex(QModelIndex const&) ()
#13 0x080be406 in Digikam::ImageWindow::slotForward() ()
#14 0x080bae74 in Digikam::ImageWindow::qt_static_metacall(QObject*, QMetaObject::Call, int, void**) ()
#15 0xb4b7aed6 in QMetaObject::activate (sender=0xa1e1858, m=0x850d950 <QAction::staticMetaObject>, local_signal_index=1, argv=0xbf977728) at kernel/qobject.cpp:3547
#16 0xb50c810d in QAction::triggered (this=this@entry=0xa1e1858, _t1=false) at .moc/release-shared/moc_qaction.cpp:277
#17 0xb50c83ac in QAction::activate (this=0xa1e1858, event=QAction::Trigger) at kernel/qaction.cpp:1257
#18 0xb55c42d0 in trigger (this=<optimized out>) at ../../include/QtGui/../../src/gui/kernel/qaction.h:218
#19 QToolButton::nextCheckState (this=0xa25dc70) at widgets/qtoolbutton.cpp:1144
#20 0xb54eeee7 in QAbstractButtonPrivate::click (this=this@entry=0xa25dee0) at widgets/qabstractbutton.cpp:530
#21 0xb54ef1e6 in QAbstractButton::mouseReleaseEvent (this=0xa25dc70, e=0xbf977e74) at widgets/qabstractbutton.cpp:1123
#22 0xb55c436d in QToolButton::mouseReleaseEvent (this=0xa25dc70, e=0xbf977e74) at widgets/qtoolbutton.cpp:718
#23 0xb51286df in QWidget::event (this=0xa25dc70, event=0xbf977e74) at kernel/qwidget.cpp:8371
#24 0xb54ee5a2 in QAbstractButton::event (this=0xa25dc70, e=0xbf977e74) at widgets/qabstractbutton.cpp:1082
#25 0xb55c5a4d in QToolButton::event (this=0xa25dc70, event=0xbf977e74) at widgets/qtoolbutton.cpp:1160
#26 0xb50cf39c in QApplicationPrivate::notify_helper (this=0x8c40500, receiver=0xa25dc70, e=0xbf977e74) at kernel/qapplication.cpp:4562
#27 0xb50d4892 in QApplication::notify (this=0x8c40500, receiver=0xa25dc70, e=0xbf977e74) at kernel/qapplication.cpp:4105
#28 0xb5c42e91 in KApplication::notify (this=0xbf978788, receiver=0xa25dc70, event=0xbf977e74) at ../../kdeui/kernel/kapplication.cpp:311
#29 0xb4b6278e in QCoreApplication::notifyInternal (this=0xbf978788, receiver=0xa25dc70, event=0xbf977e74) at kernel/qcoreapplication.cpp:915
#30 0xb50d0206 in sendEvent (event=<optimized out>, receiver=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#31 QApplicationPrivate::sendMouseEvent (receiver=0xa25dc70, event=0xbf977e74, alienWidget=0xa25dc70, nativeWidget=0xa260b00, buttonDown=0xb5a60d14 <qt_button_down>, lastMouseReceiver=..., spontaneous=true) at kernel/qapplication.cpp:3173
#32 0xb515ba75 in QETWidget::translateMouseEvent (this=0xa260b00, event=0xbf97829c) at kernel/qapplication_x11.cpp:4622
#33 0xb515a705 in QApplication::x11ProcessEvent (this=0xbf978788, event=0xbf97829c) at kernel/qapplication_x11.cpp:3737
#34 0xb5185dc4 in x11EventSourceDispatch (s=0x8c406b0, callback=0x0, user_data=0x0) at kernel/qguieventdispatcher_glib.cpp:146
#35 0xb30d39e3 in g_main_context_dispatch () from /lib/i386-linux-gnu/libglib-2.0.so.0
#36 0xb30d3d80 in ?? () from /lib/i386-linux-gnu/libglib-2.0.so.0
#37 0xb30d3e61 in g_main_context_iteration () from /lib/i386-linux-gnu/libglib-2.0.so.0
#38 0xb4b94981 in QEventDispatcherGlib::processEvents (this=0x8bf5018, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#39 0xb51859aa in QGuiEventDispatcherGlib::processEvents (this=0x8bf5018, flags=...) at kernel/qguieventdispatcher_glib.cpp:204
#40 0xb4b6126c in QEventLoop::processEvents (this=this@entry=0xbf978598, flags=...) at kernel/qeventloop.cpp:149
#41 0xb4b61561 in QEventLoop::exec (this=0xbf978598, flags=...) at kernel/qeventloop.cpp:204
#42 0xb4b66cba in QCoreApplication::exec () at kernel/qcoreapplication.cpp:1187
#43 0xb50ccfc4 in QApplication::exec () at kernel/qapplication.cpp:3823
#44 0x082b77bf in main ()

Reported using DrKonqi
Comment 1 caulier.gilles 2013-01-21 07:20:14 UTC
I remember a similar report which have been fixed in 2.9.0.

In all case with next 3.0.0, i cannot reproduce here.

Please update to 2.9.0 and try again...

Gilles Caulier
Comment 2 Ernesto 2013-01-24 07:19:56 UTC
Hi Gilles,

thank you very much for your answer.

How can I download the V 2.9.0 ? If I search it on Ubuntu SW center, it only
appears the version 2.8.0, the version I use now.

Saluti

ernesto

2013/1/21 Gilles Caulier <caulier.gilles@gmail.com>

> https://bugs.kde.org/show_bug.cgi?id=313500
>
> Gilles Caulier <caulier.gilles@gmail.com> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>              Status|UNCONFIRMED                 |RESOLVED
>                  CC|                            |caulier.gilles@gmail.com
>          Resolution|---                         |WAITINGFORINFO
>
> --- Comment #1 from Gilles Caulier <caulier.gilles@gmail.com> ---
> I remember a similar report which have been fixed in 2.9.0.
>
> In all case with next 3.0.0, i cannot reproduce here.
>
> Please update to 2.9.0 and try again...
>
> Gilles Caulier
>
> --
> You are receiving this mail because:
> You reported the bug.
>
Comment 3 caulier.gilles 2015-06-27 13:42:12 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?

Gilles caulier
Comment 4 caulier.gilles 2015-08-21 07:06:52 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.
Comment 5 caulier.gilles 2016-07-09 12:13:28 UTC
This problem is not reproducible with last 5.0.0.
I close this file now. Don't hesitate to re-open it if necessary.
Gilles Caulier