Bug 313426 - Make it possible to skip the introduction page(the first page) in the reporting assistant.
Summary: Make it possible to skip the introduction page(the first page) in the report...
Status: RESOLVED FIXED
Alias: None
Product: drkonqi
Classification: Unclassified
Component: general (show other bugs)
Version: 2.1.5
Platform: Gentoo Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-17 22:16 UTC by Jekyll Wu
Modified: 2013-01-18 20:00 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jekyll Wu 2013-01-17 22:16:45 UTC
The introduct page is reallly need to be shown to new users, especially to inform that they need to agree to be contacted by devolpers. But for users who have already used DrKonqi for enough time , showing that introduction each time seems to be useless and just a waste of time.

I get this idea after I need to frequently invoke drkonqi and its report assistant for testing various hacking/tweaking.  Showing that introduction page each time is just waste of time for me, although it can be quickly skipped by pressing the "Alt+N" accelerator. But it still needs (unnecessary) extra operation.

I have prepared a patch which adds a hidden option for skipping that introduction page. No GUI involved so far, because I'm not sure about the best way of exposing that option in the GUI.




Reproducible: Always
Comment 1 Jekyll Wu 2013-01-17 22:42:10 UTC
https://git.reviewboard.kde.org/r/108454/
Comment 2 Jekyll Wu 2013-01-18 20:00:17 UTC
Git commit 0bf10cac3763a9d3c5811068e709c33967c264e2 by Jekyll Wu.
Committed on 18/01/2013 at 20:55.
Pushed by jekyllwu into branch 'master'.

Add a hidden option for skipping the introduction in reporting assistant

That introduction page is not really useful/needed for users and
developers who have used drkonqi for enough times.

No GUI change involved, so it is now a hidden option in drkonqirc:

    [ReportAssistant]
    SkipIntroduction=true
REVIEW: 108454

FIXED-IN: 4.11.0

M  +13   -7    drkonqi/reportassistantdialog.cpp

http://commits.kde.org/kde-runtime/0bf10cac3763a9d3c5811068e709c33967c264e2