Bug 313420 - mail filtering does not always work
Summary: mail filtering does not always work
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Unclassified
Component: Mail Filter Agent (show other bugs)
Version: 4.10
Platform: openSUSE RPMs Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-17 21:36 UTC by Martin Koller
Modified: 2013-02-28 08:34 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.1


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Koller 2013-01-17 21:36:53 UTC
I have configured about 40 filters and I only use 3 POP accounts.
When I fetch new mails, I see the mails coming into my inbox and - most of them - are immediately removed again from the inbox message list as they are moved to different (mailing list) folders. But some of them stay in the inbox which should also be moved.
When I then afterwards select these mails manually and press CTRL+J to manually apply the filters again, they are then moved to the correct destination folder.

Reproducible: Always



Expected Results:  
- mails should always be moved to the defined destination folders
- mails should not appear in the inbox for a fraction of a second and then moved to the destination afterwards (this is just a graphical glitch, not a functional one)
Comment 1 András Manţia 2013-02-28 08:27:33 UTC
Fixed in KDE 4.10.1 and later by Wolfgang Rohdewald.
http://commits.kde.org/kdepim/185c572e079ef40bee2225e582c11dbdbb35840f