Bug 313390 - RAW images cannot be decoded if selected from within the image editor
Summary: RAW images cannot be decoded if selected from within the image editor
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: ImageEditor-RawImport (show other bugs)
Version: 3.1.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-17 07:13 UTC by S. Burmeister
Modified: 2017-08-06 12:02 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description S. Burmeister 2013-01-17 07:13:54 UTC
With yesterday's git checkout the image editor fails to decode RAW images if one opens them from within it. Opening them from the album view works.

Reproducible: Always

Steps to Reproduce:
1. Select some RAW image in the album view and press F4
2. The editor opens, the image is decoded
3. From the editor's thumbnail bar select another RAW image
Actual Results:  
Digikam claims that it cannot decode the RAW image.
Comment 1 Rishubh Jain 2013-01-17 14:26:37 UTC
This Bug has been confirmed Using reproducing steps provided by the Bug reporter..

Product version:3.0.0
Distribution:Kubuntu-12.10
KDE-4.9.2
Comment 2 Smit Mehta 2013-01-20 17:32:41 UTC
Hi

I also use Kubuntu 12.10 and digikam 3.0.0rc. I am not able to reproduce it here. Can you send a screenshot and the debug trace as well?

Smit
Comment 3 caulier.gilles 2013-01-21 07:12:29 UTC
I second Smit here. I cannot reproduce the problem with 3.0.0.

Which important step we forget exacty ? Please details in-deep. Give also all settings used in your workflow...

Gilles Caulier
Comment 4 S. Burmeister 2013-01-21 17:16:54 UTC
I compile against the KDE SC 4.10 libs. Probably those who cannot reproduce use the private libs. We will see what happens if 3.0 is released.
Comment 5 S. Burmeister 2013-01-26 09:33:29 UTC
For those to follow and to make it easier to find via google:

It still happens with current git, i.e. yesterday's checkout.

The debug output shows:

P1030795.RW2: data corrupted at 6599680
P1030795.RW2: data corrupted at 603136

which is a bug since it worked before with the same image and does even now if opened directly from the album view or if one clicks on "import" within the demosaicing tool.
Comment 6 caulier.gilles 2013-01-26 09:44:07 UTC
Corrupted data???

Can you share your RW2 files to test here ?

Gilles Caulier
Comment 7 S. Burmeister 2013-01-26 10:34:18 UTC
There are some test RW2 I sent to digikam some time ago. There was a folder with test images within the digikam project, I do not remember exactly. They should work.

I'm not sure this is related to RW2.

Rishubh: what RAW format do you use?
Comment 8 cfab 2013-03-20 05:03:28 UTC
Kubuntu 13.04a2 with KDE 4.10 and Digikam 3.1 leads to the same problem.
Comment 9 caulier.gilles 2015-06-30 08:05:49 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?
Comment 10 caulier.gilles 2015-08-20 06:49:59 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.

Gilles Caulier
Comment 11 cfab 2015-08-20 07:14:37 UTC
Hi,

the problem is solved with this version (and the previous one indeed).

Thanks !
Comment 12 caulier.gilles 2016-07-15 13:16:12 UTC
With digiKam 5.0.0, this problem is not reproducible.
I close this file now. Don't hesitate to re-open if necessary.
Gilles Caulier