Bug 313319 - The icon of a newly created Search & Run activity flickers
Summary: The icon of a newly created Search & Run activity flickers
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: activities (show other bugs)
Version: unspecified
Platform: Archlinux Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 315475 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-15 18:42 UTC by Romário Rios
Modified: 2013-03-16 19:40 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.10.2


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Romário Rios 2013-01-15 18:42:23 UTC
This is a bit hard to describe. When I tried to create a new Search & Run activity, its icon kept flcikering between the random icon generated for every activity and the binoculars. When I tried to change the icon, supposing it was just a glitch, the icon then started to flicker between the three icons. That also made impossible to change the name of the activity.

Present in 4.10 RC2 and in master.


Reproducible: Always

Steps to Reproduce:
1. Create a new Search & Launch activity
2. Open the activity manager
Actual Results:  
The new activity shows a weird flickering behavior in the activity manager

Expected Results:  
Nothing unusual in the new activity
Comment 1 franz.bergesund 2013-01-22 16:48:05 UTC
I see the same behavior for "Desktop Icons", "Photo activity" and "Search & Launch" on kubuntu 12.10,  KDE 4.9.98 (4.10 RC2) insalled from ppa:kubuntu-ppa/beta

They seems to work fine on kubuntu 12.04 with KDE 4.9.5
Comment 2 Simeon Bird 2013-03-11 01:57:54 UTC
This appears to be because plasma-desktop is constantly resetting the icon: 

for "Desktop Icons" it goes "user-desktop"->""->"user-desktop".
Comment 3 Aaron J. Seigo 2013-03-12 18:32:14 UTC
Git commit 3031f1c216e9e58a7cfdfea47daf5ebd9ab2c551 by Aaron Seigo.
Committed on 12/03/2013 at 19:26.
Pushed by aseigo into branch 'KDE/4.10'.

prevent looping calls to setIcon/setName

Activity no longer sets the activity name, icon, etc. that is the job of kactivitymanagerd,
perhaps via the activities DataEngine.

on activity creation, it was possible to have the icon set by Activity .. which would then call
setIcon on the KAMD activity .. which would then update Activity. which would then call .. etc.

tested creation of new activities, changing icons, etc. and all is well

bug reporters: please confirm

M  +0    -17   plasma/desktop/shell/activity.cpp
M  +0    -1    plasma/desktop/shell/activity.h

http://commits.kde.org/kde-workspace/3031f1c216e9e58a7cfdfea47daf5ebd9ab2c551
Comment 4 Aaron J. Seigo 2013-03-12 18:32:32 UTC
Git commit 27dd3c23640c10fb19803da488588dc7d6186f87 by Aaron Seigo.
Committed on 12/03/2013 at 19:26.
Pushed by aseigo into branch 'master'.

prevent looping calls to setIcon/setName

Activity no longer sets the activity name, icon, etc. that is the job of kactivitymanagerd,
perhaps via the activities DataEngine.

on activity creation, it was possible to have the icon set by Activity .. which would then call
setIcon on the KAMD activity .. which would then update Activity. which would then call .. etc.

tested creation of new activities, changing icons, etc. and all is well

bug reporters: please confirm

M  +0    -17   plasma/desktop/shell/activity.cpp
M  +0    -1    plasma/desktop/shell/activity.h

http://commits.kde.org/kde-workspace/27dd3c23640c10fb19803da488588dc7d6186f87
Comment 5 manutortosa@gmail.com 2013-03-16 19:39:38 UTC
*** Bug 315475 has been marked as a duplicate of this bug. ***
Comment 6 manutortosa@gmail.com 2013-03-16 19:40:12 UTC
The patch works perfect, the issue is gone here.