Bug 313255 - slide effect goes wrong way with wrap-around desktops
Summary: slide effect goes wrong way with wrap-around desktops
Status: RESOLVED DUPLICATE of bug 185710
Alias: None
Product: kwin
Classification: Unclassified
Component: effects-window-management (show other bugs)
Version: 4.9.5
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-14 16:55 UTC by Aaron Wolf
Modified: 2013-01-15 06:19 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Aaron Wolf 2013-01-14 16:55:25 UTC
With wrap-around on for virtual desktops, the slide effect goes the wrong way when wrapping around. For example, with just two desktops in vertical alignment, move from upper to lower and the windows slide up as expected. Move back up and the windows slide down as expected. But move up from the upper to then wrap around and the slide effect still goes up. The slide should work in a loop so that any time the cursor goes off the top of the screen, the slide effect should be downward. Same issue with left and right.

Reproducible: Always

Steps to Reproduce:
1. Have multiple desktops
2. Enable wrap around and slide effect for switching
3. move through the desktops in a single direction wrapping around and notice that slide isn't in a consistent direction even though cursor movement is consistent
Comment 1 Martin Flöser 2013-01-15 06:19:37 UTC

*** This bug has been marked as a duplicate of bug 185710 ***