Bug 313245 - Support for Share-Like-Connect
Summary: Support for Share-Like-Connect
Status: RESOLVED FIXED
Alias: None
Product: plasma-mediacenter
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Sinny Kumari
URL:
Keywords:
: 313453 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-14 14:58 UTC by Shantanu Tushar
Modified: 2013-02-27 19:12 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Shantanu Tushar 2013-01-14 14:58:19 UTC
On Plasma Active, PMC doesn't support SLC yet. We need to have this so the user can use this very important PA feature.

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
N/A

Expected Results:  
PMC should support SLC
Comment 1 Marco Martin 2013-01-18 15:40:02 UTC
*** Bug 313453 has been marked as a duplicate of this bug. ***
Comment 2 Marco Martin 2013-02-27 19:12:39 UTC
Git commit 3154e9eb8eb8b8534c06a94cffbf773fbc30a23f by Marco Martin.
Committed on 27/02/2013 at 20:10.
Pushed by mart into branch 'master'.

basic support for SLC

export to SLC with a PlasmaExtraComponents.ResourceInstance{}
following logic:
if the image viewer is visible, has a source and is not covered by a media browser, the image will be the SLC exported url, otherwise export the url of the mediaplayer

M  +5    -0    shells/newshell/package/contents/ui/mediacenter.qml

http://commits.kde.org/plasma-mediacenter/3154e9eb8eb8b8534c06a94cffbf773fbc30a23f