Bug 313173 - drag and drop DELETES files from library (MOVES)
Summary: drag and drop DELETES files from library (MOVES)
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-Drag&Drop (show other bugs)
Version: 2.8.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-13 12:02 UTC by dns
Modified: 2019-08-14 19:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 6.3.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dns 2013-01-13 12:02:07 UTC
Hi I just noticed, that when draging and dropping files out of digiKam, the default behaviour is to MOVE files out (like in the Nauilus)... I don't think it's a good usability decision, as I just have removed from my library hundreds of pictures tagged with the same tag... and have no mena to put them back into right folders/events... 

I think digiKam shall ALWASY do COPY... and MOVE be possible only in a very intentional way.

Reproducible: Always

Steps to Reproduce:
1. select pictures
2. drag and drop them to desktop
3. will be removed from original locations
Comment 1 caulier.gilles 2013-01-13 14:52:53 UTC
This topic have been already discuted in-deep in bug 219908...

Gilles Caulier

*** This bug has been marked as a duplicate of bug 219908 ***
Comment 2 caulier.gilles 2019-08-14 19:02:10 UTC
Fixed with bug #219908