Bug 313167 - Pop-under dialog after failed login
Summary: Pop-under dialog after failed login
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: UI (show other bugs)
Version: 4.9.5
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-13 10:05 UTC by Graeme Hewson
Modified: 2013-01-13 17:12 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Graeme Hewson 2013-01-13 10:05:34 UTC
If login fails for an account with interval mail checking enabled, a popup message appears:

"Please enter the username and password for account '<account>'. You are asked here because the previous login was not successful."

However, it's actually a pop-under message, which is easy to overlook. This also happens with a manual check.

Reproducible: always
Expected result: message pops up on top of other windows.

My focus policy is Focus Follows Mouse, if that's relevant.
Comment 1 Graeme Hewson 2013-01-13 10:13:44 UTC
OK, focus policy is relevant. With Click to Focus and Focus Follows Mouse, dialog pops under, as described. With Focus Under Mouse and Focus Strictly Under Mouse, dialog pops up over other windows.

I would still expect the dialog to pop up with all focus policies.
Comment 2 Allen Winter 2013-01-13 17:12:55 UTC
Git commit 56a1872ae8e63ca6878e362904e10829b46691b8 by Allen Winter.
Committed on 13/01/2013 at 18:11.
Pushed by winterz into branch 'KDE/4.10'.

make parentless KPasswordDialogs modal, with the hope the user
will be less likely to miss them now.
FIXED-IN: 4.10

M  +1    -0    resources/imap/settings.cpp
M  +1    -0    resources/pop3/pop3resource.cpp

http://commits.kde.org/kdepim-runtime/56a1872ae8e63ca6878e362904e10829b46691b8