Bug 313130 - Plugins/ImageInfo.cpp:187:1: error: expected ',' or ';' before '{' token
Summary: Plugins/ImageInfo.cpp:187:1: error: expected ',' or ';' before '{' token
Status: RESOLVED DUPLICATE of bug 307148
Alias: None
Product: kphotoalbum
Classification: Unclassified
Component: general (show other bugs)
Version: 4.3
Platform: openSUSE RPMs Linux
: NOR major (vote)
Target Milestone: ---
Assignee: KPhotoAlbum Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-12 12:09 UTC by Matthias Mailänder
Modified: 2013-01-12 14:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
I attached the whole build log. (498.00 KB, text/x-log)
2013-01-12 12:09 UTC, Matthias Mailänder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Mailänder 2013-01-12 12:09:12 UTC
Created attachment 76415 [details]
I attached the whole build log.

KPhotoAlbum fails to build on openSUSE Factory since version 4.2:

/usr/include/marble/global.h:2:2: warning: #warning global.h is deprecated. Please #include <marble/MarbleGlobal.h> instead (no further changes needed). [-Wcpp]
In file included from /home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/Interface.cpp:25:0:
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.h:53:35: error: 'KIPI::TimeSpec' has not been declared
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.h:54:56: error: 'KIPI::TimeSpec' has not been declared
In file included from /home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.cpp:21:0:
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.h:53:35: error: 'KIPI::TimeSpec' has not been declared
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.h:54:56: error: 'KIPI::TimeSpec' has not been declared
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.cpp:186:43: error: 'QDateTime Plugins::ImageInfo::time' is not a static member of 'class Plugins::ImageInfo'
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.cpp:186:37: error: 'TimeSpec' is not a member of 'KIPI'
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.cpp:186:37: note: suggested alternative:
In file included from /usr/include/QtCore/qbytearray.h:46:0,
                 from /usr/include/QtCore/qstring.h:46,
                 from /usr/include/QtCore/QString:1,
                 from /usr/include/libkipi/imageinfoshared.h:39,
                 from /home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.h:23,
                 from /home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.cpp:21:
/usr/include/QtCore/qnamespace.h:1404:10: note:   'Qt::TimeSpec'
/home/abuild/rpmbuild/BUILD/kphotoalbum-4.3/Plugins/ImageInfo.cpp:187:1: error: expected ',' or ';' before '{' token

via https://build.opensuse.org/request/show/148132
Comment 1 Miika Turkia 2013-01-12 14:09:48 UTC

*** This bug has been marked as a duplicate of bug 307148 ***