Bug 313056 - Cell references become wrong after deleting rows or columns
Summary: Cell references become wrong after deleting rows or columns
Status: RESOLVED FIXED
Alias: None
Product: calligrasheets
Classification: Unclassified
Component: general (show other bugs)
Version: Git
Platform: Other Linux
: NOR major (vote)
Target Milestone: ---
Assignee: Calligra Sheets (KSpread) Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-11 06:23 UTC by Camilla Boemann
Modified: 2013-01-14 03:30 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
file showing the problem (3.83 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-01-11 06:39 UTC, Camilla Boemann
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Camilla Boemann 2013-01-11 06:23:28 UTC
I have  a cell D5 that refer to a cell in A1

if I delete row 3+4, or column B+C then the cell reference becomes A-1 which is clearly wrong

in fact: libreoffice and excel don't change the cell reference in this case. They always keep an absolute reference.  And it is not because it's the topmost or leftmost row/column.





Reproducible: Always

Steps to Reproduce:
1.enter a value in A1, say 5
2.enter a formula =A1 in cell D5
3. delete row 3 and 4

Actual Results:  
the cell with the formula says =A-1
and the value shown is -1

Expected Results:  
The formula stays A1
and the shown value stays correctly at 5
Comment 1 Camilla Boemann 2013-01-11 06:39:31 UTC
Created attachment 76379 [details]
file showing the problem
Comment 2 Camilla Boemann 2013-01-11 06:40:19 UTC
instead load attached document

delete rows 5-30

notice the bug

In some other variations when trying to reproduce this bug Sheets automatically detects that it goes wrong and replaces the reference with #DEPENDENCY

this would be the correct response in this case too
Comment 3 Cyrille Berger 2013-01-11 08:26:47 UTC
I can reproduce the bug in 2.4.3
Comment 4 Marijn Kruisselbrink 2013-01-12 01:17:54 UTC
Git commit 5115de4f64697a39009db7ff802d49ae94a23aee by Marijn Kruisselbrink.
Committed on 12/01/2013 at 02:15.
Pushed by mkruisselbrink into branch 'master'.

Fix an issue where a reference to a deleted row (or column) was not detected properly.

Also adds a test-case for the other problem reported in this bug, but I can't reproduce the bug in that situation.

M  +2    -2    sheets/Sheet.cpp
M  +31   -18   sheets/tests/TestSheet.cpp

http://commits.kde.org/calligra/5115de4f64697a39009db7ff802d49ae94a23aee
Comment 5 Camilla Boemann 2013-01-12 05:41:47 UTC
Git commit ae1d3ff4bd0a0669c3ca9853003d7af3b4dc188b by C. Boemann, on behalf of Marijn Kruisselbrink.
Committed on 12/01/2013 at 02:15.
Pushed by boemann into branch 'calligra/2.6'.

Fix an issue where a reference to a deleted row (or column) was not detected properly.

Also adds a test-case for the other problem reported in this bug, but I can't reproduce the bug in that situation.

M  +2    -2    sheets/Sheet.cpp
M  +31   -18   sheets/tests/TestSheet.cpp

http://commits.kde.org/calligra/ae1d3ff4bd0a0669c3ca9853003d7af3b4dc188b
Comment 6 Camilla Boemann 2013-01-13 04:55:45 UTC
Git commit 368305a82cd4754e30b402e0f784b249526c79b4 by C. Boemann, on behalf of Marijn Kruisselbrink.
Committed on 12/01/2013 at 02:15.
Pushed by boemann into branch 'calligra/2.4'.

Fix an issue where a reference to a deleted row (or column) was not detected properly.

Also adds a test-case for the other problem reported in this bug, but I can't reproduce the bug in that situation.

M  +2    -2    sheets/Sheet.cpp
M  +31   -18   sheets/tests/TestSheet.cpp

http://commits.kde.org/calligra/368305a82cd4754e30b402e0f784b249526c79b4
Comment 7 Camilla Boemann 2013-01-13 04:56:24 UTC
Git commit e59122078fe53683c7abbd203758170e9504726c by C. Boemann, on behalf of Marijn Kruisselbrink.
Committed on 12/01/2013 at 02:15.
Pushed by boemann into branch 'calligra/2.5'.

Fix an issue where a reference to a deleted row (or column) was not detected properly.

Also adds a test-case for the other problem reported in this bug, but I can't reproduce the bug in that situation.

M  +2    -2    sheets/Sheet.cpp
M  +31   -18   sheets/tests/TestSheet.cpp

http://commits.kde.org/calligra/e59122078fe53683c7abbd203758170e9504726c
Comment 8 Inge Wallin 2013-01-14 03:30:58 UTC
Git commit ebae782379d6451f530f4371cf3a8d0be929fec3 by Inge Wallin, on behalf of Marijn Kruisselbrink.
Committed on 12/01/2013 at 02:15.
Pushed by ingwa into branch 'text-annotations-ingwa'.

Fix an issue where a reference to a deleted row (or column) was not detected properly.

Also adds a test-case for the other problem reported in this bug, but I can't reproduce the bug in that situation.

M  +2    -2    sheets/Sheet.cpp
M  +31   -18   sheets/tests/TestSheet.cpp

http://commits.kde.org/calligra/ebae782379d6451f530f4371cf3a8d0be929fec3