Bug 313020 - [regression] password window obscures lock screen screensaver
Summary: [regression] password window obscures lock screen screensaver
Status: RESOLVED DUPLICATE of bug 311116
Alias: None
Product: kscreensaver
Classification: Miscellaneous
Component: locker-qml (show other bugs)
Version: 4.9.97 RC2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-10 15:13 UTC by Will Stephenson
Modified: 2013-01-14 19:44 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Subsidiary dark grey background (673 bytes, patch)
2013-01-11 15:50 UTC, Thomas Lübking
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Will Stephenson 2013-01-10 15:13:54 UTC
With the old password dialog, the window was opened on top of the screensaver window.  Now a fullscreen white QML view is opened with the password dialog elements in the middle, hiding the screensaver completely.

Reproducible: Always

Steps to Reproduce:
1. Set a screensaver as the screen locker type
2. Lock the screen. Observe screensaver
3. Attempt to unlock the screen
Actual Results:  
White window with QML unlock UI in middle

Expected Results:  
unlock UI on top of screensaver.
Comment 1 Martin Sandsmark 2013-01-10 18:21:24 UTC
this is pretty jarring, especially early in the morning when it is dark in the room.
Comment 2 Marco Martin 2013-01-11 09:29:38 UTC
screensaver and lockscreen are expected to be mutually exclusive, but in theory the lockscreen should show the default wallpaper, not a white window
Comment 3 Thomas Lübking 2013-01-11 15:50:31 UTC
Created attachment 76389 [details]
Subsidiary dark grey background

BG Image is taken from the theme. If the theme has no wallpaper, you get a plain background which is white by default.

Since "white" is not necessarily the ideal transition from a (likely former turned off, thus) black screen, attached is a patch which alters places a dark grey rect below the image.
Comment 4 Thomas Lübking 2013-01-11 15:52:41 UTC
Also see bug #312828.
The just attached patch does not "fix" the fullscreen locker "issue" claimed in OP, but which i believe is wontfix due to the altered architecture anyway.
Comment 5 Aaron J. Seigo 2013-01-12 18:14:23 UTC
the UI should probably do 2 things:

* hide after a delay or if the user presses Esc
* return when there is user activity

as such, i really see this as a dupe of #311116

*** This bug has been marked as a duplicate of bug 311116 ***
Comment 6 Thomas Lübking 2013-01-13 11:26:07 UTC
For the dark background see https://git.reviewboard.kde.org/r/108377/
Comment 7 Thomas Lübking 2013-01-14 19:43:36 UTC
Git commit 5997f324c8cef97b7f4e1a705b4f560d132ecc90 by Thomas Lübking.
Committed on 13/01/2013 at 12:13.
Pushed by luebking into branch 'KDE/4.10'.

sublay the theme wallpaper with a dark background

REVIEW: 108377

M  +7    -0    ksmserver/screenlocker/greeter/themes/org.kde.passworddialog/contents/ui/main.qml

http://commits.kde.org/kde-workspace/5997f324c8cef97b7f4e1a705b4f560d132ecc90
Comment 8 Thomas Lübking 2013-01-14 19:44:12 UTC
Git commit c74cc6e9df97c0acbcfe8f8a3b213109db4f6604 by Thomas Lübking.
Committed on 13/01/2013 at 12:13.
Pushed by luebking into branch 'master'.

sublay the theme wallpaper with a dark background

REVIEW: 108377

M  +7    -0    ksmserver/screenlocker/greeter/themes/org.kde.passworddialog/contents/ui/main.qml

http://commits.kde.org/kde-workspace/c74cc6e9df97c0acbcfe8f8a3b213109db4f6604