Bug 312928 - Show URL in address line while trying to open an external link (i.e. in an e-mail) even if there's a server error.
Summary: Show URL in address line while trying to open an external link (i.e. in an e-...
Status: RESOLVED FIXED
Alias: None
Product: rekonq
Classification: Unclassified
Component: general (show other bugs)
Version: latest git snapshot
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Andrea Diamantini
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-09 09:55 UTC by Kristian Rink
Modified: 2013-06-19 13:52 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kristian Rink 2013-01-09 09:55:42 UTC
Situation: We internally use redmine for ticket tracking, with the tracker sending out status messages (with links to the tickets). These links are https which don't work with rekonq so far so the "workaround" is to manually change "https" to "http". 

rekonq, in such situations, by now just ends wit an "Oops! Cannot load...". However, in here I also can't manually change https -> http because, in such situations, the URL bar remains empty, so I manually need to copy-paste the full URL.

It would be helpful, in situations like that, if the browser would display the actual URL it tries to open in the address bar no matter whether or not loading the page was successful.

Reproducible: Always
Comment 1 Martin 2013-04-19 13:14:48 UTC
I can confirm this. Whenever rekonq shows an error page the URL bar is cleared.
Comment 2 Andrea Diamantini 2013-06-06 23:11:38 UTC
Git commit 8767b92a1027283562d33de783f9601f66f3d32f by Andrea Diamantini.
Committed on 07/06/2013 at 01:10.
Pushed by adjam into branch 'master'.

Fix behavior on unloaded sites

- show url
- reload with f5
Related: bug 319924

M  +6    -0    src/urlbar/urlbar.cpp
M  +14   -0    src/webtab/webview.cpp
M  +8    -5    src/webtab/webview.h

http://commits.kde.org/rekonq/8767b92a1027283562d33de783f9601f66f3d32f
Comment 3 Andrea Diamantini 2013-06-19 13:52:03 UTC
Git commit 7fd44b92554588240a5dd953ce1734891b147271 by Andrea Diamantini.
Committed on 19/06/2013 at 11:09.
Pushed by adjam into branch 'master'.

Let fixed behavior when site is NOT loaded
work also when you don't have connection from the beginning.
Related: bug 319924

M  +5    -0    src/webtab/webpage.cpp
M  +2    -1    src/webtab/webpage.h
M  +2    -0    src/webtab/webtab.cpp

http://commits.kde.org/rekonq/7fd44b92554588240a5dd953ce1734891b147271