Bug 312920 - Neverending spinner when filetransfers and jobs are disabled
Summary: Neverending spinner when filetransfers and jobs are disabled
Status: RESOLVED FIXED
Alias: None
Product: plasma4
Classification: Unclassified
Component: notifications (show other bugs)
Version: 4.9.97 RC2
Platform: Chakra Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Marco Martin
URL:
Keywords: reproducible
: 324583 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-09 00:45 UTC by Martin Bednar
Modified: 2013-09-06 15:12 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 4.11.1


Attachments
This is a patch which removes the bug (700 bytes, patch)
2013-08-19 10:54 UTC, Błażej Szczygieł
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Bednar 2013-01-09 00:45:41 UTC
When I disable "Show filetransfers and jobs" in the notification configuration, upon plasma start there is a spinner that never ends in the notification widget.

Reproducible: Always

Steps to Reproduce:
1.disable filetransfers and jobs in the notifiaction widget configuration
2.kquitapp plasma-desktop
3.plasma-desktop
Actual Results:  
Never ending spinner with no notification

Expected Results:  
Nothing (except filetransfers not being shown)

enabling and disabling filetransfers and jobs in the widget configuration stops the spinner.

Might be relevant : in the console output, this appears while changing the configuration : 
"file:///usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/Jobs.qml:28:15: Unable to assign undefined value
file:///usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/Jobs.qml:29:16: Unable to assign undefined value
file:///usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/NotificationIcon.qml:47: TypeError: Result of expression 'jobs' [null] is not an object.
file:///usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/NotificationIcon.qml:66: TypeError: Result of expression 'jobs' [null] is not an object.
file:///usr/share/apps/plasma/plasmoids/org.kde.notifications/contents/ui/Notifications.qml:160: Unable to assign null to bool
"
Comment 1 Błażej Szczygieł 2013-03-16 14:53:00 UTC
Happens in 4.10.1...
Comment 2 Błażej Szczygieł 2013-06-08 11:25:48 UTC
Still happens in 4.10.4...
Comment 3 Christoph Feck 2013-07-20 15:03:54 UTC
I tried to debug this, but was not successful, needs someone understanding QML.

The following patch disables the animation, so that it does not consume CPU cycles. Now it is no longer required to change the settings on each start.

diff --git a/plasma/generic/applets/notifications/contents/ui/NotificationIcon.qml b/plasma/generic/applets/notifications/contents/ui/NotificationIcon.qml
index 819d39d..93e70da 100644
--- a/plasma/generic/applets/notifications/contents/ui/NotificationIcon.qml
+++ b/plasma/generic/applets/notifications/contents/ui/NotificationIcon.qml
@@ -64,7 +64,7 @@ Item {
         PlasmaComponents.BusyIndicator {
             anchors.fill: parent
             visible: jobs.count > 0
-            running: visible
+            running: false
         }
 
         Column {
Comment 4 Błażej Szczygieł 2013-08-19 10:54:07 UTC
Created attachment 81780 [details]
This is a patch which removes the bug
Comment 5 Christoph Feck 2013-08-25 10:34:30 UTC
Patch from comment #4 works good, no regressions seen. Could you please commit it to 4.11 branch? If you do not want to commit, please state your full name, and I will do it.

Could you also look at related bug 315847?
Comment 6 Błażej Szczygieł 2013-08-26 19:03:38 UTC
Where can I commit this patch?
Comment 7 Christoph Feck 2013-08-26 22:02:03 UTC
Błażej, you need a developer account to get commit access to the KDE repositories. Please see http://techbase.kde.org/Contribute/Get_a_Contributor_Account
Comment 8 Błażej Szczygieł 2013-08-27 10:49:16 UTC
OK, thanks Christoph. But you can commit the patch to 4.11 branch.
Comment 9 Christoph Feck 2013-08-27 12:15:01 UTC
Git commit ed7c2e824303e0c971100c2e2a9c6362129bf409 by Christoph Feck, on behalf of Błażej Szczygieł.
Committed on 27/08/2013 at 12:13.
Pushed by cfeck into branch 'KDE/4.11'.

Fix neverending spinner when jobs are disabled
FIXED-IN: 4.11.1
Reviewed by Christoph Feck

M  +1    -1    plasma/generic/applets/notifications/contents/ui/NotificationIcon.qml

http://commits.kde.org/kde-workspace/ed7c2e824303e0c971100c2e2a9c6362129bf409
Comment 10 Christoph Feck 2013-09-06 15:12:38 UTC
*** Bug 324583 has been marked as a duplicate of this bug. ***