Bug 312839 - crash when start
Summary: crash when start
Status: RESOLVED DUPLICATE of bug 311681
Alias: None
Product: marble
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: marble-bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-07 19:24 UTC by karsten.strobach
Modified: 2018-08-28 09:27 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description karsten.strobach 2013-01-07 19:24:20 UTC
Application: digikam (2.9.0)
KDE Platform Version: 4.9.5 "release 3" (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.1.10-1.16-desktop x86_64
Distribution: "openSUSE 12.1 (x86_64)"

-- Information about the crash:
digikam 2.9.0 crashes when starting in command line mode with 
QSqlDatabasePrivate::removeDatabase: connection 'ConnectionTest' is still in use, all queries will cease to work.
Map theme file does not exist: ""

The crash can be reproduced every time.

-- Backtrace:
Application: digiKam (digikam), signal: Segmentation fault
[Current thread is 1 (Thread 0x7f68623e1800 (LWP 9481))]

Thread 5 (Thread 0x7f68440ce700 (LWP 9483)):
#0  0x00007f685980de6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f685d4cbd4b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00000000005dfb70 in Digikam::ScanController::run (this=0xe2bdd0) at /usr/src/debug/digikam-2.9.0/core/digikam/database/scancontroller.cpp:698
#3  0x00007f685d4cb7dc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f685102f56c in ?? () from /usr/lib64/libGL.so.1
#5  0x00007f6859809f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f685bac410d in clone () from /lib64/libc.so.6

Thread 4 (Thread 0x7f68438cd700 (LWP 9484)):
#0  0x00007f685babaff3 in poll () from /lib64/libc.so.6
#1  0x00007f6853c86ae8 in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6853c86fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f685d5faa36 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f685d5ca252 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f685d5ca4a7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f685d4c8777 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f685d5a9cff in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f685d4cb7dc in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f685102f56c in ?? () from /usr/lib64/libGL.so.1
#10 0x00007f6859809f05 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f685bac410d in clone () from /lib64/libc.so.6

Thread 3 (Thread 0x7f68430cc700 (LWP 9492)):
#0  0x00007f685980de6c in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f685d4cbd4b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x00007f685fc6fda1 in Digikam::ParkingThread::run (this=0xe71330) at /usr/src/debug/digikam-2.9.0/core/libs/threads/threadmanager.cpp:119
#3  0x00007f685d4cb7dc in ?? () from /usr/lib64/libQtCore.so.4
#4  0x00007f685102f56c in ?? () from /usr/lib64/libGL.so.1
#5  0x00007f6859809f05 in start_thread () from /lib64/libpthread.so.0
#6  0x00007f685bac410d in clone () from /lib64/libc.so.6

Thread 2 (Thread 0x7f681b09e700 (LWP 9516)):
#0  0x00007f6853c85ea4 in g_main_context_query () from /usr/lib64/libglib-2.0.so.0
#1  0x00007f6853c869ea in ?? () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f6853c86fa9 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f685d5faa36 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#4  0x00007f685d5ca252 in QEventLoop::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#5  0x00007f685d5ca4a7 in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib64/libQtCore.so.4
#6  0x00007f685d4c8777 in QThread::exec() () from /usr/lib64/libQtCore.so.4
#7  0x00007f685d5a9cff in ?? () from /usr/lib64/libQtCore.so.4
#8  0x00007f685d4cb7dc in ?? () from /usr/lib64/libQtCore.so.4
#9  0x00007f685102f56c in ?? () from /usr/lib64/libGL.so.1
#10 0x00007f6859809f05 in start_thread () from /lib64/libpthread.so.0
#11 0x00007f685bac410d in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f68623e1800 (LWP 9481)):
[KCrash Handler]
#6  0x00007f6858295185 in setCheckState (acheckState=<optimized out>, this=0x4dc4e48) at /usr/include/QtGui/qstandarditemmodel.h:290
#7  Marble::RenderPlugin::setEnabled (this=0x4dd1700, enabled=false) at /usr/src/debug/marble-4.9.5/src/lib/RenderPlugin.cpp:137
#8  0x00007f681a68073f in ?? () from /usr/lib64/kde4/plugins/marble/AprsPlugin.so
#9  0x00007f681a68084d in qt_plugin_instance () from /usr/lib64/kde4/plugins/marble/AprsPlugin.so
#10 0x00007f685d5af41f in QPluginLoader::instance() () from /usr/lib64/libQtCore.so.4
#11 0x00007f685823272e in Marble::PluginManagerPrivate::loadPlugins (this=0x4db7ed0) at /usr/src/debug/marble-4.9.5/src/lib/PluginManager.cpp:177
#12 0x00007f6858233bb6 in loadPlugins (this=<optimized out>) at /usr/src/debug/marble-4.9.5/src/lib/PluginManager.cpp:151
#13 Marble::PluginManager::renderPlugins (this=0x4db7ad8) at /usr/src/debug/marble-4.9.5/src/lib/PluginManager.cpp:75
#14 0x00007f6858231b5f in Marble::LayerManager::LayerManager (this=0x4dc1590, model=0x4db7728, parent=<optimized out>) at /usr/src/debug/marble-4.9.5/src/lib/LayerManager.cpp:82
#15 0x00007f68581d999e in Marble::MarbleMapPrivate::MarbleMapPrivate (this=0x4dc14a0, parent=0x4db7740, model=0x4db7728) at /usr/src/debug/marble-4.9.5/src/lib/MarbleMap.cpp:151
#16 0x00007f68581da62e in Marble::MarbleMap::MarbleMap (this=0x4db7740, model=0x4db7728) at /usr/src/debug/marble-4.9.5/src/lib/MarbleMap.cpp:243
#17 0x00007f68581d055c in MarbleWidgetPrivate (parent=0x4db77d0, this=0x4db7720) at /usr/src/debug/marble-4.9.5/src/lib/MarbleWidget.cpp:102
#18 Marble::MarbleWidget::MarbleWidget (this=0x4db77d0, parent=<optimized out>) at /usr/src/debug/marble-4.9.5/src/lib/MarbleWidget.cpp:163
#19 0x00007f6860858987 in KGeoMap::BackendMarble::mapWidget (this=0x4ab3410) at /usr/src/debug/digikam-2.9.0/extra/libkgeomap/libkgeomap/backend_map_marble.cpp:220
#20 0x00007f686084711e in setBackend (backendName=..., this=0x4aa5eb0) at /usr/src/debug/digikam-2.9.0/extra/libkgeomap/libkgeomap/kgeomap_widget.cpp:481
#21 KGeoMap::KGeoMapWidget::setBackend (this=0x4aa5eb0, backendName=...) at /usr/src/debug/digikam-2.9.0/extra/libkgeomap/libkgeomap/kgeomap_widget.cpp:398
#22 0x00007f686084754b in KGeoMap::KGeoMapWidget::readSettingsFromGroup (this=0x4aa5eb0, group=0x7fff887923e0) at /usr/src/debug/digikam-2.9.0/extra/libkgeomap/libkgeomap/kgeomap_widget.cpp:633
#23 0x00007f685fd16100 in Digikam::ImagePropertiesGPSTab::readSettings (this=0x4aa29d0, group=...) at /usr/src/debug/digikam-2.9.0/core/libs/imageproperties/imagepropertiesgpstab.cpp:218
#24 0x00007f685fd01be1 in Digikam::ImagePropertiesSideBar::doLoadState (this=0x48be210) at /usr/src/debug/digikam-2.9.0/core/libs/imageproperties/imagepropertiessidebar.cpp:331
#25 0x00000000004aa722 in Digikam::ImagePropertiesSideBarDB::doLoadState (this=0x48be210) at /usr/src/debug/digikam-2.9.0/core/libs/imageproperties/imagepropertiessidebardb.cpp:629
#26 0x00007f685fc9851a in Digikam::StateSavingObject::loadState (this=0x48be240) at /usr/src/debug/digikam-2.9.0/core/libs/widgets/common/statesavingobject.cpp:183
#27 0x000000000049ebd4 in Digikam::ImageWindow::ImageWindow (this=0x4833f30, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-2.9.0/core/utilities/imageeditor/editor/imagewindow.cpp:344
#28 0x000000000049edd5 in Digikam::ImageWindow::imageWindow () at /usr/src/debug/digikam-2.9.0/core/utilities/imageeditor/editor/imagewindow.cpp:276
#29 0x000000000058a511 in Digikam::DigikamApp::preloadWindows (this=0xe6f070) at /usr/src/debug/digikam-2.9.0/core/digikam/main/digikamapp.cpp:2558
#30 0x00000000005a0f61 in Digikam::DigikamApp::DigikamApp (this=0xe6f070, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /usr/src/debug/digikam-2.9.0/core/digikam/main/digikamapp.cpp:290
#31 0x0000000000498384 in main (argc=1, argv=<optimized out>) at /usr/src/debug/digikam-2.9.0/core/digikam/main/main.cpp:188

Reported using DrKonqi
Comment 1 Bernhard Beschow 2014-04-27 11:07:20 UTC

*** This bug has been marked as a duplicate of bug 311681 ***