Bug 312801 - Crash dialog comes up upon login into KDE
Summary: Crash dialog comes up upon login into KDE
Status: RESOLVED FIXED
Alias: None
Product: ktouchpadenabler
Classification: Miscellaneous
Component: General (show other bugs)
Version: unspecified
Platform: Gentoo Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Albert Astals Cid
URL: http://paste.kde.org/639344/
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-07 09:41 UTC by Stefan Radermacher
Modified: 2013-01-07 18:53 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan Radermacher 2013-01-07 09:41:42 UTC
See backtrace.

Reproducible: Always

Steps to Reproduce:
1. Login to KDE

Actual Results:  
Crash handler dialog displayed

Expected Results:  
No crash!
Comment 1 Albert Astals Cid 2013-01-07 10:04:18 UTC
Git commit 3e41f5ff7a0f46fa49d23cc8a0290281b2b5e741 by Albert Astals Cid.
Committed on 07/01/2013 at 11:03.
Pushed by aacid into branch 'KDE/4.10'.

XIFreeDeviceInfo of NULL crashes, don't do it

M  +3    -1    ktouchpadenabler/ktouchpadenabler_daemon.cpp

http://commits.kde.org/kde-workspace/3e41f5ff7a0f46fa49d23cc8a0290281b2b5e741
Comment 2 Stefan Radermacher 2013-01-07 10:35:45 UTC
Thanks fof fixing this so fast!
Comment 3 Albert Astals Cid 2013-01-07 18:18:16 UTC
Just wondering, which kind of computer do you have? It seems as if you did not have any mouse?
Comment 4 Stefan Radermacher 2013-01-07 18:47:34 UTC
It's a normal desktop computer, and I do have a mouse, an Evoluent VerticalMouse 3 to be exact.
Comment 5 Albert Astals Cid 2013-01-07 18:53:37 UTC
Weird, it should not happen, but it doesn't matter anyway since you don't have a touchpad.

Thanks for the bug report :-)