Bug 312794 - Error while trying to open database
Summary: Error while trying to open database
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Setup-Database (show other bugs)
Version: 2.5.0
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-01-07 06:05 UTC by Chris
Modified: 2017-07-25 18:50 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Chris 2013-01-07 06:05:46 UTC
Every time I try to open digikam it gives me this error. I've let it try to reconnect to the database, sitting here for 30+minutes and still unable to open my photo album. I tried unenstalling and reinstalling in hopes that digikam would have me go through the setup process again  but it didn't. Instead it tried connectiing to the database of the old install. This is the first time I've had any problems with digikam and I haven't moved my photoalbum to any other device, ever. So file permissions are the same. Though I had the external drive it is on while I booted up into windows 7 on my new system and windows ran a chkdisk scan recently. 

Reproducible: Always

Steps to Reproduce:
1.try to laun digikam
2.error occurs
3.unable to connect to database, rendering digikam useless
Actual Results:  
already mentioned

Expected Results:  
connect to album database and launch digikam
Comment 1 caulier.gilles 2013-01-07 06:14:01 UTC
Try to use a newer version as last 2.9.0 to see if error is reproducible.

Also please give us the digiKam console trace to investiguate.

Gilles Caulier
Comment 2 caulier.gilles 2015-06-30 08:08:00 UTC
New digiKam 4.11.0 is available :

https://www.digikam.org/node/740

Can you reproduce the problem with this release ?
Comment 3 caulier.gilles 2015-08-22 06:38:08 UTC
digiKam 4.12.0 is out :

https://www.digikam.org/node/741

We need a fresh feedback using this release please...
Thanks in advance.
Comment 4 swatilodha27 2016-07-02 16:14:35 UTC
It's possible to connect with the database now. Try 5.0.0 version.

Please reopen the file if you still face the issue.