Bug 312568 - Pressing 'Ctrl+F' should focus the search box
Summary: Pressing 'Ctrl+F' should focus the search box
Status: RESOLVED FIXED
Alias: None
Product: muon
Classification: Unclassified
Component: muon (show other bugs)
Version: 1.4.1
Platform: Ubuntu Packages Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Jonathan Thomas
URL:
Keywords: reproducible, usability
Depends on:
Blocks:
 
Reported: 2013-01-03 22:01 UTC by Konstantinos Smanis
Modified: 2016-01-11 13:55 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:
konstantinos.smanis: Usability+


Attachments
Add search shortcut in muon-package manager and muon-discover (2.70 KB, patch)
2015-08-29 21:50 UTC, Carlo Vanini
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Konstantinos Smanis 2013-01-03 22:01:52 UTC
I was surprised to find out that pressing 'Ctrl+F' in Muon Package Manager didn't move the focus to the search bar. I also couldn't find any related configurable action so that I could assign the proper shortcut myself.

It's not really a big deal, just a tiny usability incoherence, since this is considered to be standard & expected behaviour.

PS: Personally, I would go for moving the focus to the search bar + select all of its contents when pressing 'Ctrl+F', not just moving the focus there.
Comment 1 Carlo Vanini 2015-08-29 21:50:41 UTC
Created attachment 94279 [details]
Add search shortcut in muon-package manager and muon-discover

Ctrl+F gives focus to the search box and selects its content.

In Muon Package Center the shortcut appears in "Configure shortcuts" and can be changed, in muon-discover it does not.
Comment 2 Aleix Pol 2016-01-11 13:55:51 UTC
Git commit 8f21836cff78f9834f9052e301363f106d5d1ded by Aleix Pol, on behalf of Carlo Vanini.
Committed on 11/01/2016 at 13:49.
Pushed by apol into branch 'master'.

add keyboard shortcut to focus search box

Add keyboard shortcut to move focus to the search box, and give it focus at startup.

If the box is hidden, e.g. by changes preview, the focus is not changed. Otherwise you could change the content of the search box without seeing it.

(if accepted, please push it for me)

REVIEW: 126709
Related: bug 299763, bug 325536

M  +10   -0    src/MainWindow.cpp
M  +1    -0    src/MainWindow.h
M  +7    -0    src/PackageModel/PackageWidget.cpp
M  +1    -0    src/PackageModel/PackageWidget.h

http://commits.kde.org/muon/8f21836cff78f9834f9052e301363f106d5d1ded