I've doscovered, that ktp-call-ui (both 0.5.1 and git head) fails to compile if gstreamer-1.0 (at least 1.0.3) is installed in the system (even parallely to gstreamer-0.10).
Created attachment 76123 [details]
The bug summary is incorrect, please fix it. The reason is telepathy-farstream-0.6.0 (which depends on gstreamer-1.0), not gstreamer-1.0 itself. ktp-call-ui will still build fine if you have telepathy-farstream-0.4.0, regardless whether you have gstreamer-1.0 installed or not.
(In reply to comment #2)
> ktp-call-ui will still build fine if you have
> telepathy-farstream-0.4.0, regardless whether you have gstreamer-1.0
> installed or not.
Summary is ok, since, I guess, both variants is right:
ktp-call-ui builds fine with telepathy-farstream-0.6.0, for example, if I temporarily move /usr/include/gstreamer-1.0 somewhere (since it is bug in buildsystem, which cause it add -L for both gstreamer versions, and, since 1.0 has bigger priority -> compilation fails due to incompatibility between ktp-call-ui and gstreamer-1.0 (sic!).
(In reply to comment #3)
so, I asking to change it back...
We all know what it means and that's what's important.
AFAIK we can't fix this until we fix QGstreamer to work with gstreamer1.0 anyway...and there's a whole trail of things that need updating.
There is a patch out there to co-install telepathy-farstream 0.4 and 0.6, at which point this all works, so arguably this is "more correct" as that then implicitly checks gsteamer.
It may be worth us doing an immediate fix to check the telepathy-farstream version when compiling.
Here's my current collection of modifications/patches to make telepathy-farstream-0.4 co-installable and to telepathy-qt(4)/ktp-call-ui to use it:
*** Bug 313836 has been marked as a duplicate of this bug. ***
Just adding ebuilds for kde overlay in Gentoo :)
Also, ktp-call-ui-0.7 fails to compile even with telepathy-farstream 0.2.2 .
(In reply to comment #9)
> Also, ktp-call-ui-0.7 fails to compile even with telepathy-farstream 0.2.2 .
Please ensure that you do not mix up farstream and telepathy-farstream. (telepathy-farstream-0.2.2 would be ancient, but farstream-0.2.2 is rather current.) This bug is about telepathy-farstream, not farstream. ktp-call-ui-0.7.1 builds fine against telepathy-farstream-0.4.0.
thanks for correcting me . did not notice, that I was using latter version of farstream which was causing the error!
the git version ktp-call-ui is now regularly compiling against qt-gstreamer 1.0 and telepathy-farstream-0.6-dev.
Can we close this?
Probably so, closing.
ideally, new releases (including these fixes) will be made soon too? :)