Bug 312450 - ktp-call-ui fails to compile with telepathy-farstream-0.6
Summary: ktp-call-ui fails to compile with telepathy-farstream-0.6
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: call-ui (show other bugs)
Version: git-latest
Platform: Gentoo Packages Linux
: NOR normal
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
: 313836 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-01-01 11:53 UTC by Vadim A. Misbakh-Soloviov (mva)
Modified: 2014-09-11 11:34 UTC (History)
30 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
build log (16.03 KB, text/plain)
2013-01-01 15:35 UTC, Vadim A. Misbakh-Soloviov (mva)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vadim A. Misbakh-Soloviov (mva) 2013-01-01 11:53:54 UTC
Hi!
I've doscovered, that ktp-call-ui (both 0.5.1 and git head) fails to compile if gstreamer-1.0 (at least 1.0.3) is installed in the system (even parallely to gstreamer-0.10).

Reproducible: Always
Comment 1 Vadim A. Misbakh-Soloviov (mva) 2013-01-01 15:35:31 UTC
Created attachment 76123 [details]
build log
Comment 2 Bartosz Brachaczek 2013-01-06 20:24:20 UTC
The bug summary is incorrect, please fix it. The reason is telepathy-farstream-0.6.0 (which depends on gstreamer-1.0), not gstreamer-1.0 itself. ktp-call-ui will still build fine if you have telepathy-farstream-0.4.0, regardless whether you have gstreamer-1.0 installed or not.
Comment 3 Vadim A. Misbakh-Soloviov (mva) 2013-01-06 21:24:37 UTC
(In reply to comment #2)
> ktp-call-ui will still build fine if you have
> telepathy-farstream-0.4.0, regardless whether you have gstreamer-1.0
> installed or not.

Summary is ok, since, I guess, both variants is right:
ktp-call-ui builds fine with telepathy-farstream-0.6.0, for example, if I temporarily move /usr/include/gstreamer-1.0 somewhere (since it is bug in buildsystem, which cause it add -L for both gstreamer versions, and, since 1.0 has bigger priority -> compilation fails due to incompatibility between ktp-call-ui and gstreamer-1.0 (sic!).
Comment 4 Vadim A. Misbakh-Soloviov (mva) 2013-01-06 21:25:52 UTC
(In reply to comment #3)
so, I asking to change it back...
Comment 5 David Edmundson 2013-01-06 21:34:20 UTC
We all know what it means and that's what's important.

AFAIK we can't fix this until we fix QGstreamer to work with gstreamer1.0  anyway...and there's a whole trail of things that need updating.

There is a patch out there to co-install telepathy-farstream 0.4 and 0.6, at which point this all works, so arguably this is "more correct" as that then implicitly checks gsteamer.

It may be worth us doing an immediate fix to check the telepathy-farstream version when compiling.
Comment 6 Rex Dieter 2013-01-07 16:25:44 UTC
Here's my current collection of modifications/patches to make telepathy-farstream-0.4 co-installable and to telepathy-qt(4)/ktp-call-ui to use it:
http://rdieter.fedorapeople.org/rpms/ktp/
Comment 7 David Edmundson 2013-01-24 17:17:36 UTC
*** Bug 313836 has been marked as a duplicate of this bug. ***
Comment 8 David Heidelberg 2014-02-12 18:38:32 UTC
http://ghic.org/~diane/qtgstreamer-1.0-proposed.html

Just adding ebuilds for kde overlay in Gentoo :)
Comment 9 mayank 2014-02-23 08:06:45 UTC
Also, ktp-call-ui-0.7 fails to compile even with telepathy-farstream 0.2.2 .
Comment 10 Dennis Schridde 2014-02-23 08:21:14 UTC
(In reply to comment #9)
> Also, ktp-call-ui-0.7 fails to compile even with telepathy-farstream 0.2.2 .

Please ensure that you do not mix up farstream and telepathy-farstream. (telepathy-farstream-0.2.2 would be ancient, but farstream-0.2.2 is rather current.) This bug is about telepathy-farstream, not farstream. ktp-call-ui-0.7.1 builds fine against telepathy-farstream-0.4.0.
Comment 11 mayank 2014-02-23 09:17:43 UTC
thanks for correcting me . did not notice, that I was using latter version of farstream which was causing the error!
Comment 12 Diane Trout 2014-09-08 17:55:17 UTC
the git version ktp-call-ui is now regularly compiling against qt-gstreamer 1.0 and telepathy-farstream-0.6-dev.

Can we close this?
Comment 13 Rex Dieter 2014-09-08 17:57:55 UTC
Probably so, closing.

ideally, new releases (including these fixes) will be made soon too?  :)
Comment 14 Martin Klapetek 2014-09-11 11:34:38 UTC
Yes. ...ish.