Bug 312419 - Internationalization: digiKam in English only
Summary: Internationalization: digiKam in English only
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Usability-i18n (show other bugs)
Version: 2.6.0
Platform: Ubuntu Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-31 05:38 UTC by antoine messiah
Modified: 2017-08-04 17:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 3.0.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description antoine messiah 2012-12-31 05:38:44 UTC
I installed digiKam on a computer with Ubuntu 10.04 in French. All my other application are in French, except when there is no translation.

It was impossible to switch digiKam from English to French, until I came across a CLOSED bug (that is, a bug invisible with default search option) reported for Ubuntu 11.x and digiKam in German (https://bugs.kde.org/show_bug.cgi?id=278329). I was able to switch to French after installing "language-pack-kde-fr-base".

I would recommend that this closed bug stays visible with default search options, and/or goes to the main documentation since it explains how to solve the issue. The FAQ "Is Digikam available in my language ?" (http://www.digikam.org/node/167) does not help at all, since it does not explain how to solve the "language pack" problem.

I think that a dependence with "language-pack-kde-<language_initials>-base" should be checked or created when one want to install digiKam, and/or a message should pops-up when one tries to change language (help menu) but has no choice other choice than English.




Reproducible: Always

Steps to Reproduce:
1. N/A 
2.
3.
Actual Results:  
N/A

Expected Results:  
N/A
Comment 1 caulier.gilles 2012-12-31 09:50:36 UTC
All translations are managed outside digiKam, by your distro team...

Gilles Caulier
Comment 2 Smit Mehta 2012-12-31 11:11:52 UTC
Hi Gilles

But I still think that a couple of lines should be added in the FAQs of digikam's site. What do you think?
Comment 3 caulier.gilles 2012-12-31 13:39:31 UTC
Why not. Do yo u have an account to do it in digikam.org ?

Gilles
Comment 4 Smit Mehta 2013-01-03 07:39:28 UTC
Hi Gilles

No I dont. Its a very small job. You add it when free. No need to make an account for it. Kindly replace the text in "distribution package" by this text:

If you installed digikam using your distribution package, language files should be included with it and you can run digikam in any supported language. 
You can change the default language by using KDE Control Center (kcontrol) : 
Go to "Regional & Accessibility" and then in "Country/Region & Language" to use your default language. 
If you dont find the required language in it, you can add a language by installing that particular language pack. For example, in debian based distros, if you want to add "french" language, you can do it by following:

sudo apt-get install language-pack-kde-fr-base
sudo apt-get install language-pack-kde-fr

Note, that will affects all your KDE applications. 
You can also change the language used in digikam with the $LANG environment variable. Eg :

export LANG=fr.UTF-8 ; digikam

Smit
Comment 5 caulier.gilles 2013-01-05 11:14:49 UTC
Done in this page :

http://www.digikam.org/download/binary

Gilles Caulier