Bug 312356 - Crop tool does not remember advanced settings checkbox state
Summary: Crop tool does not remember advanced settings checkbox state
Status: RESOLVED FIXED
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.4
Platform: Archlinux Packages Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-29 21:49 UTC by Jan Hambrecht
Modified: 2013-04-10 16:54 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Hambrecht 2012-12-29 21:49:29 UTC
I was preparing multiple images to be printed at a local photo printing service. Part of that was to crop images to a specific aspect ratio (which works great by the way). However it was a little bit annoying that I always had to check the advanced settings check box in the crop tool settings for each image. It would be great if the tool could remember that setting for the current session so preparing lots of images gets a little smoother.

Reproducible: Always

Steps to Reproduce:
1. Enable crop tool.
2. Check advanced settings checkbox.
3. Crop the image.
4. Select another image.
5. Enable the crop tool.
6. The advanced settings check box is unchecked again.


Expected Results:  
The advanced settings checkbox state should be remembered for the current session.
Comment 1 Jan Hambrecht 2012-12-29 21:53:12 UTC
I already looked at the code but there seems to be currently no way for a tool to save state between different instantiations. An easy but probably not the most elegant way would be to add a function local static variable to save the checkbox state. If you think that would be an ok solution i could prepare a patch implementing that.
Comment 2 Benni Hill 2012-12-30 16:17:30 UTC
I think that remembering the checkbox state is a good idea. But you should talk directly to Aurélien Gâteau (agateau at kde. org) about the implementation.
Comment 3 Jan Hambrecht 2013-02-13 20:04:27 UTC
Git commit 300bc3ad431f8abd6f6507a1d16ea8170d1a46ad by Jan Hambrecht.
Committed on 13/02/2013 at 21:00.
Pushed by jaham into branch 'master'.

Make advanced settings visibility of crop tool persistent.
REVIEW:108885

M  +3    -0    lib/crop/croptool.cpp
M  +10   -0    lib/crop/cropwidget.cpp
M  +3    -0    lib/crop/cropwidget.h
M  +6    -0    lib/gwenviewconfig.kcfg

http://commits.kde.org/gwenview/300bc3ad431f8abd6f6507a1d16ea8170d1a46ad