Bug 312339 - USABILITY: Make tab switching able to cycle tabs.
Summary: USABILITY: Make tab switching able to cycle tabs.
Status: RESOLVED FIXED
Alias: None
Product: telepathy
Classification: Unclassified
Component: text-ui (show other bugs)
Version: 0.5.2
Platform: Compiled Sources Linux
: NOR minor
Target Milestone: Future
Assignee: Telepathy Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-29 14:50 UTC by sombragris
Modified: 2012-12-30 20:08 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In: 0.5.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sombragris 2012-12-29 14:50:07 UTC
In Text-UI, when one has multiple chats, one can switch back and forth between chats thanks to the Previous Tab and Next Tab shortcuts, which are configurable. They work fine and I'm grateful for them, because they're a real time saver.

Now what I'm asking is this:
* When one is at the *last* tab, pressing the "Next Tab" shortcut should cause text-ui to cycle, i.e., to show the *first* tab.

* When one is at the *first* tab, pressing the "Previous Tab" shortcut should cause text-ui to go to the *last* chat.

This would be really appreciated. Also, it would be consistent with the behavior of other tabbed applications in KDE. Thanks!

Reproducible: Always

Steps to Reproduce:
1. In Text-ui, go to the last conversation tab in a window with multiple tabs.
2. Press the Next-Tab shortcut
3. Nothing happens;
Actual Results:  
Nothing. And that's the problem.

Expected Results:  
It should cycle tabs.
Comment 1 David Edmundson 2012-12-30 16:32:10 UTC
Git commit 72a2a40b97a4879fdf8080a4d1d2de6c48f16978 by David Edmundson.
Committed on 29/12/2012 at 16:38.
Pushed by davidedmundson into branch 'kde-telepathy-0.5'.

Cycle through tabs with next/prev tabs
FIXED-IN: 0.5.3
Reviewed-by: Martin Klapetek

M  +13   -1    app/chat-window.cpp

http://commits.kde.org/telepathy-text-ui/72a2a40b97a4879fdf8080a4d1d2de6c48f16978
Comment 2 sombragris 2012-12-30 20:08:31 UTC
Thank you :)