Bug 312305 - Configuration screen lacks option for IPv6 privacy
Summary: Configuration screen lacks option for IPv6 privacy
Status: RESOLVED FIXED
Alias: None
Product: Network Management
Classification: Unclassified
Component: Control Module (show other bugs)
Version: 0.9
Platform: Other Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: Lamarque V. Souza
URL: https://git.reviewboard.kde.org/r/108...
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-28 14:00 UTC by Ralf Jung
Modified: 2013-01-07 18:18 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralf Jung 2012-12-28 14:00:30 UTC
Network Manager for some versions now supports a configuration "ip6-privacy" to configure whether the IPv6 privacy extensions are enabled or not. However, the configuration screen currently has no GUI for this option.

Reproducible: Always

Steps to Reproduce:
1. Open any connection config screen
2. Switch to IPv6 tab
Actual Results:  
No option for privacy extensions exists.

Expected Results:  
There should be a checkbox/drop-down menu to configure IPv6 privacy extensions.
Comment 1 Ralf Jung 2013-01-02 15:07:22 UTC
I wrote a patch for this and submitted it for review at https://git.reviewboard.kde.org/r/108064/
Comment 2 Jan Grulich 2013-01-02 15:18:57 UTC
Knm::*setting classes will be replaced with classes from libnm-qt in future. I'm working on implementation of these classes and IPv6Setting is already implemented. But it will take some time to finish it so I think your patch could be applied for now. But this decision is up on lamarque.
Comment 3 Ralf Jung 2013-01-02 15:24:30 UTC
I assume that's part of the work going on in master, porting the applet to lib{mm,nm}-qt? I don't know what the state of that port is, i.e. how far away from a stable release (replacing the nm09 branch) it is. I based my work on the nm09 branch because I hope to use it soon, so I'd like to see it end up in a released version.
Comment 4 Ralf Jung 2013-01-07 11:11:40 UTC
Git commit b1bed1ebdc3ded10370cc084bb01a28a7e3432ef by Ralf Jung.
Committed on 07/01/2013 at 12:09.
Pushed by ralfjung into branch 'nm09'.

Add option to configure IPv6 Privacy Extension

REVIEW: 108064

M  +5    -0    backends/NetworkManager/settings/ipv6dbus.cpp
M  +3    -1    libs/internals/settings/ipv6.cpp
M  +26   -0    libs/internals/settings/ipv6.h
M  +33   -7    libs/ui/ipv6.ui
M  +11   -0    libs/ui/ipv6widget.cpp

http://commits.kde.org/networkmanagement/b1bed1ebdc3ded10370cc084bb01a28a7e3432ef
Comment 5 Lamarque V. Souza 2013-01-07 18:18:51 UTC
Git commit 402ad6f360aec052c5f48dfe68f40a1fc0ae9f17 by Lamarque V. Souza, on behalf of Ralf Jung.
Committed on 07/01/2013 at 12:09.
Pushed by lvsouza into branch 'master'.

Add option to configure IPv6 Privacy Extension

REVIEW: 108064
(cherry picked from commit b1bed1ebdc3ded10370cc084bb01a28a7e3432ef)

M  +5    -0    backends/NetworkManager/settings/ipv6dbus.cpp
M  +3    -1    libs/internals/settings/ipv6.cpp
M  +26   -0    libs/internals/settings/ipv6.h
M  +27   -1    libs/ui/ipv6.ui
M  +11   -0    libs/ui/ipv6widget.cpp
M  +1    -1    plasma_nm_version.h

http://commits.kde.org/networkmanagement/402ad6f360aec052c5f48dfe68f40a1fc0ae9f17