Bug 312279 - Can't switch between tracks without noticeable delay
Summary: Can't switch between tracks without noticeable delay
Status: RESOLVED DUPLICATE of bug 256734
Alias: None
Product: amarok
Classification: Applications
Component: Playback (show other bugs)
Version: 2.6.0
Platform: Archlinux Linux
: NOR normal (vote)
Target Milestone: 2.7
Assignee: Amarok Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-27 21:18 UTC by Alexander
Modified: 2012-12-27 22:08 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander 2012-12-27 21:18:30 UTC
Hi, so if you have a single few hours long track which has been split to small parts amarok hung for a second or so when switching between them. This makes listening very unpleasant and uncomfortable. This bug persists in amarok as long as I can remember.

Sometimes, before to start the next track from the playlist it plays first second from the previous track and only then switch to the next one.

This is reproducible for all file types.

Reproducible: Always



Expected Results:  
Tracks should switch without any delays so user should not be able to notice when a track has been changed.

Using VLC backend.
Comment 1 Myriam Schweingruber 2012-12-27 22:08:47 UTC
Where are your tracks located? I can't reproduce this with local tracks at all.

Just to make this clear: the gap-less playback does only work with the phonon-backend-gstreamer 4.6.2 AFAIK, and it will not work for mp3 tracks at all in its current state. You will also need the latest upstream gstreamer version, see also bug 256734

*** This bug has been marked as a duplicate of bug 256734 ***