By default, in the main toolbar, there are back & forward buttons (and the two items is also in the view menu). They can be used to navigate to the previous or next document when you open multiple files in kate. But the text "Back" and "Forward" is ambiguous because the two buttons are frequently used in browser or file manager.
When kate has been localized, the problem becomes more obvious. I am using KDE in Chinese environment, the translated text means go to the next/previous place, which has nothing to do with navigating to other files. It may make users think the button is used to go to the previous/next edit place.
I am using the kate 3.9.4 in KDE 4.9.4.
Diving into the source code, I find the two line of code in kate/plugins/filetree/katefiletreeplugin.cpp,
actionCollection()->addAction( KStandardAction::Back, "filetree_prev_document", m_fileTree, SLOT(slotDocumentPrev()) );
actionCollection()->addAction( KStandardAction::Forward, "filetree_next_document", m_fileTree, SLOT(slotDocumentNext()) );
The use of KStandardAction::Back & KStandardAction::Forward cause the problem.
And the problem is still in the git tree.
You mean ambiguous in the sense of bad naming? Do you have better suggestions?
(In reply to comment #1)
> You mean ambiguous in the sense of bad naming? Do you have better
IMO, Previous/Next is better. (The tooltip can be 'switch to previous file/next file')
This describe what exactly will happen. And can be translated without changing the back/forward text in konqueror, dolphin, etc.
Git commit 410f74b4458b74663fa03e8a86fa6787897cebb9 by Dominik Haumann.
Committed on 20/02/2013 at 13:22.
Pushed by dhaumann into branch 'master'.
Better naming to navigate documents
Forward -> Next Document (menu: View > Forward)
Back -> Previous Document (menu: View > Back)
@T.C.: If this is in the Kate docbook, it needs to be adapted to reflect
the new naming in KDE 4.11.
M +2 -2 kate/plugins/filetree/katefiletreeplugin.cpp
Git commit 2a1a97a2914bb818ffe238b06c6ab8120a444d3f by Burkhard Lück.
Committed on 17/04/2013 at 12:16.
Pushed by lueck into branch 'master'.
document changed menu strings for filetreeplugin
M +3 -3 doc/kate/index.docbook
M +8 -3 doc/kate/mdi.docbook
M +2 -2 doc/kate/menus.docbook