Bug 312226 - useless error message when trying to copy file with forbidden characters in a FAT Partition
Summary: useless error message when trying to copy file with forbidden characters in a...
Status: RESOLVED DUPLICATE of bug 322837
Alias: None
Product: kfile
Classification: Applications
Component: general (show other bugs)
Version: 4.9.1
Platform: Archlinux Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-26 15:46 UTC by ariasuni
Modified: 2018-04-13 17:42 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ariasuni 2012-12-26 15:46:50 UTC
When I want to copy a file with ":" for example to a FAT32 partition, Dolphin display an useless error message.

Reproducible: Always

Steps to Reproduce:
1. Pick a file with ":" in his name for example
2. Try to copy the file on a FAT or FAT32 partition
3. See the error message
Actual Results:  
Dolphin display this error message:
"Could not write to /path/to/filewithforbiddencharacters"

Expected Results:  
Dolphin could display an error message like this:
"Could not write to /path/to/filewithforbiddencharacters because it contains one or more of the forbidden characters: / \ : * ? " < > |."
or
"Could not write to /path/to/filewithforbiddencharacters because it contains the followings forbidden characters: ":"."
Comment 1 Christoph Feck 2012-12-27 03:27:39 UTC
Do filesystems announce which characters they support in filenames?
Comment 2 ariasuni 2012-12-27 09:49:09 UTC
When I modify directly the filename when the file is on the FAT32 or ext4 partition with forbidden characters, Dolphin just tells me that it is impossible to rename the file. Note that the file is effectively renamed at the screen, like if it works, and I must refresh the view to see that the name is not changed (but I think I must open a separate bug report if not already done by someone else).
Comment 3 Nate Graham 2018-04-13 17:42:51 UTC

*** This bug has been marked as a duplicate of bug 322837 ***