Bug 312196 - Gwenview will not start
Summary: Gwenview will not start
Status: RESOLVED WORKSFORME
Alias: None
Product: gwenview
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.4
Platform: Compiled Sources Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Gwenview Bugs
URL:
Keywords: triaged
: 314786 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-25 17:49 UTC by deathpyre.tarrant
Modified: 2018-10-28 03:26 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description deathpyre.tarrant 2012-12-25 17:49:29 UTC
Application: gwenview (2.9.4)
KDE Platform Version: 4.9.4 (Compiled from sources)
Qt Version: 4.8.4
Operating System: Linux 3.6.8-gentoo x86_64
Distribution: "Gentoo Base System release 2.2"

-- Information about the crash:
- Tried to start Gwenview, Soprano disabled; get the following when run in console:

"/usr/bin/gwenview(15273)" Soprano: "Could not connect to server at /tmp/ksocket-soushi/nepomuk-socket (No such file or directory)"
"/usr/bin/gwenview(15273)" Soprano: "Could not connect to server at /tmp/ksocket-soushi/nepomuk-socket (No such file or directory)"
"/usr/bin/gwenview(15273)" Soprano: "Could not connect to server at /tmp/ksocket-soushi/nepomuk-socket (No such file or directory)"
"/usr/bin/gwenview(15273)" Soprano: "Could not connect to server at /tmp/ksocket-soushi/nepomuk-socket (No such file or directory)"
"/usr/bin/gwenview(15273)" Soprano: "Could not connect to server at /tmp/ksocket-soushi/nepomuk-socket (No such file or directory)"
"/usr/bin/gwenview(15273)" Soprano: "Could not connect to server at /tmp/ksocket-soushi/nepomuk-socket (No such file or directory)"
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 1 (X_CreateWindow)
  Resource id:  0x16b
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 12 (X_ConfigureWindow)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 55 (X_CreateGC)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    137 (Uknown extension)
  Minor opcode: 3 (Unknown request)
  Resource id:  0x3e0004c
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Extension:    137 (Uknown extension)
  Minor opcode: 5 (Unknown request)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 18 (X_ChangeProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 10 (X_UnmapWindow)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 7 (X_ReparentWindow)
  Resource id:  0x3e0004c
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 1 (X_CreateWindow)
  Resource id:  0x3e00053
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e00061
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e00061
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e00061
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e00061
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 2 (X_ChangeWindowAttributes)
  Resource id:  0x3e00061
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x3e0004c
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 4 (X_DestroyWindow)
  Resource id:  0x3e0004c
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode: 1 (X_CreateWindow)
  Resource id:  0x3e00053
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 3 (X_GetWindowAttributes)
  Resource id:  0x3e00062
KCrash: Application 'gwenview' crashing...

The crash can be reproduced every time.

-- Backtrace:
Application: Gwenview (gwenview), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fbb59cef780 (LWP 15234))]

Thread 3 (Thread 0x7fbb48e40700 (LWP 15235)):
#0  0x00007fbb54d5226f in __pthread_mutex_unlock_usercnt (mutex=0x7fbb44000a60, decr=0) at pthread_mutex_unlock.c:52
#1  0x00007fbb52f75871 in g_mutex_unlock (mutex=<optimized out>) at gthread-posix.c:227
#2  0x00007fbb52f3969a in g_main_context_prepare (context=0x7fbb440009a0, priority=0x7fbb48e3fc88) at gmain.c:2834
#3  0x00007fbb52f39dfb in g_main_context_iterate (dispatch=1, block=1, context=0x7fbb440009a0, self=<optimized out>) at gmain.c:3126
#4  g_main_context_iterate (context=0x7fbb440009a0, block=1, dispatch=1, self=<optimized out>) at gmain.c:3083
#5  0x00007fbb52f39fec in g_main_context_iteration (context=0x7fbb440009a0, may_block=1) at gmain.c:3207
#6  0x00007fbb58afb58e in QEventDispatcherGlib::processEvents (this=0x7fbb440008c0, flags=...) at kernel/qeventdispatcher_glib.cpp:426
#7  0x00007fbb58acac12 in QEventLoop::processEvents (this=<optimized out>, flags=...) at kernel/qeventloop.cpp:149
#8  0x00007fbb58acae97 in QEventLoop::exec (this=0x7fbb48e3fdb0, flags=...) at kernel/qeventloop.cpp:204
#9  0x00007fbb589c8c9f in QThread::exec (this=<optimized out>) at thread/qthread.cpp:542
#10 0x00007fbb58aaa4ff in QInotifyFileSystemWatcherEngine::run (this=0x1aed930) at io/qfilesystemwatcher_inotify.cpp:256
#11 0x00007fbb589cbd1c in QThreadPrivate::start (arg=0x1aed930) at thread/qthread_unix.cpp:338
#12 0x00007fbb54d4f006 in start_thread (arg=0x7fbb48e40700) at pthread_create.c:305
#13 0x00007fbb565efbad in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 2 (Thread 0x7fbb42a3d700 (LWP 15236)):
#0  pthread_cond_wait () at ../nptl/sysdeps/unix/sysv/linux/x86_64/pthread_cond_wait.S:162
#1  0x00007fbb42cc0bcb in pipe_semaphore_wait (sema=0x1d026b8) at ../../../../../src/gallium/auxiliary/os/os_thread.h:433
#2  radeon_drm_cs_emit_ioctl (param=0x1ce1b30) at radeon_drm_cs.c:416
#3  0x00007fbb54d4f006 in start_thread (arg=0x7fbb42a3d700) at pthread_create.c:305
#4  0x00007fbb565efbad in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Thread 1 (Thread 0x7fbb59cef780 (LWP 15234)):
[KCrash Handler]
#6  0x00007fbb541d9780 in XVisualIDFromVisual () from /usr/lib64/libX11.so.6
#7  0x00007fbb5732700b in qt_x11_getX11InfoForWindow (xinfo=0x1b6dfc0, att=...) at kernel/qwidget_x11.cpp:3115
#8  0x00007fbb573270b0 in qt_x11_getX11InfoForWindow (xinfo=<optimized out>, a=...) at kernel/qwidget_x11.cpp:438
#9  0x00007fbb5732ab3a in QWidgetPrivate::create_sys (this=0x1b6dde0, window=56623202, initializeWindow=true, destroyOldWindow=true) at kernel/qwidget_x11.cpp:599
#10 0x00007fbb572dc12f in QWidget::create (this=0x1b6ddb0, window=56623202, initializeWindow=true, destroyOldWindow=true) at kernel/qwidget.cpp:1515
#11 0x00007fbb57909423 in QEgl::createSurface (device=0x1b6ddc0, config=0x1b11ac0, properties=0x0) at egl/qegl_x11.cpp:410
#12 0x00007fbb55267c10 in QGLWidgetPrivate::recreateEglSurface (this=0x1b6dde0) at qgl_x11egl.cpp:376
#13 0x00007fbb551f0778 in QGLWidget::event (this=0x1b6ddb0, e=0x7fffcfeceff0) at qgl.cpp:4332
#14 0x00007fbb572920f4 in notify_helper (e=0x7fffcfeceff0, receiver=0x1b6ddb0, this=0x185c290) at kernel/qapplication.cpp:4562
#15 QApplicationPrivate::notify_helper (this=0x185c290, receiver=0x1b6ddb0, e=0x7fffcfeceff0) at kernel/qapplication.cpp:4534
#16 0x00007fbb57296e53 in QApplication::notify (this=0x7fffcfecf6f0, receiver=0x1b6ddb0, e=0x7fffcfeceff0) at kernel/qapplication.cpp:4423
#17 0x00007fbb57ffb948 in KApplication::notify (this=0x7fffcfecf6f0, receiver=0x1b6ddb0, event=0x7fffcfeceff0) at /var/tmp/portage/kde-base/kdelibs-4.9.4-r1/work/kdelibs-4.9.4/kdeui/kernel/kapplication.cpp:311
#18 0x00007fbb58acc16b in QCoreApplication::notifyInternal (this=0x7fffcfecf6f0, receiver=0x1b6ddb0, event=0x7fffcfeceff0) at kernel/qcoreapplication.cpp:946
#19 0x00007fbb572e66ee in sendEvent (event=0x7fffcfeceff0, receiver=0x1b6ddb0) at ../../include/QtCore/../../src/corelib/kernel/qcoreapplication.h:231
#20 QWidget::setParent (this=0x1b6ddb0, parent=0x1bd3770, f=...) at kernel/qwidget.cpp:10306
#21 0x00007fbb572e6ca2 in QWidget::setParent (this=<optimized out>, parent=<optimized out>) at kernel/qwidget.cpp:10157
#22 0x00007fbb5770a12a in QAbstractScrollArea::setViewport (this=0x1bd3770, widget=0x1b6ddb0) at widgets/qabstractscrollarea.cpp:547
#23 0x00007fbb595e151e in Gwenview::DocumentViewContainer::DocumentViewContainer (this=0x1bd3770, parent=<optimized out>) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/lib/documentview/documentviewcontainer.cpp:92
#24 0x0000000000434bd7 in setupAdapterContainer (this=0x1bd1220) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/viewmainpage.cpp:220
#25 Gwenview::ViewMainPage::ViewMainPage (this=0x1bd0a80, parent=<optimized out>, slideShow=<optimized out>, actionCollection=0x1a4c990) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/viewmainpage.cpp:380
#26 0x000000000045662b in setupViewMainPage (parent=0x1a64600, this=0x19cee70) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/mainwindow.cpp:318
#27 Gwenview::MainWindow::Private::setupWidgets (this=0x19cee70) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/mainwindow.cpp:260
#28 0x000000000045122a in Gwenview::MainWindow::MainWindow (this=0x1a13aa0, __in_chrg=<optimized out>, __vtt_parm=<optimized out>) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/mainwindow.cpp:845
#29 0x000000000044b39e in StartHelper::createMainWindow (this=0x7fffcfecf6c0) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/main.cpp:82
#30 0x000000000042a2fd in main (argc=5, argv=0x7fffcfecfa18) at /var/tmp/portage/kde-base/gwenview-4.9.4/work/gwenview-4.9.4/app/main.cpp:140

Possible duplicates by query: bug 244017.

Reported using DrKonqi
Comment 1 heena 2012-12-25 18:02:22 UTC
Perhaps Sapranocmd (executable file) is incorrectly placed, is deleted .After checking it ,try to open it again,if that does not help you need to compile it again I guess .
Comment 2 deathpyre.tarrant 2012-12-25 20:22:32 UTC
$ sopranocmd 
sopranocmd 2.8.0
   Copyright (C) 2007-2010 Sebastian Trueg <trueg@kde.org>
   This program is free software; you can redistribute it and/or modify
   it under the terms of the GNU General Public License as published by
   the Free Software Foundation; either version 2 of the License, or
   (at your option) any later version.

Using Virtuoso Version: "6.1.6.3127-pthreads"

Re-emerged (compiled), with no change.
Comment 3 Benni Hill 2013-01-06 01:29:40 UTC
You could try the following workaround:
Open gwenviewrc (ususally in ~/.kde/share/config) and change the key "AnimationMethod" (within "[ImageView]") to "DocumentView::NoAnimation". Or create it when it's not there.

[ImageView]
<other stuff>
AnimationMethod=DocumentView::NoAnimation
Comment 4 Benni Hill 2013-01-06 02:02:12 UTC
Could you also try my patch I posted on reviewboard?
https://git.reviewboard.kde.org/r/108219/
Comment 5 deathpyre.tarrant 2013-01-06 23:54:56 UTC
The workaround worked fine, so did software animation.

I will try the patch when I have more time to clone the git.
Comment 6 Benni Hill 2013-01-10 17:41:26 UTC
Git commit 6f17587683b801c09c137f063ee3c89fb11f291d by Benjamin Löwe.
Committed on 06/01/2013 at 02:43.
Pushed by bennihill into branch 'KDE/4.10'.

Check if QGLWidget has been initialised successfully before using it.

REVIEW: 108219

M  +7    -1    lib/documentview/documentviewcontainer.cpp

http://commits.kde.org/gwenview/6f17587683b801c09c137f063ee3c89fb11f291d
Comment 7 Benni Hill 2013-02-09 19:45:51 UTC
*** Bug 314786 has been marked as a duplicate of this bug. ***
Comment 8 Benni Hill 2013-02-09 19:48:03 UTC
Patch doesn't seem to fix this. See duplicate bug 314786 (KDE 4.10.0).
Comment 9 Nate Graham 2017-09-09 04:47:07 UTC
The duplicates are circular! Is this reproducible with KF5 versions of Gwenview?
Comment 10 Andrew Crouthamel 2018-09-28 02:42:58 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 15 days. Please provide the requested information as soon as possible and set the bug status as REPORTED. Due to regular bug tracker maintenance, if the bug is still in NEEDSINFO status with no change in 30 days, the bug will be closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please set the bug status as REPORTED so that the KDE team knows that the bug is ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 11 Andrew Crouthamel 2018-10-28 03:26:25 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least 30 days. The bug is now closed as RESOLVED > WORKSFORME due to lack of needed information.

For more information about our bug triaging procedures please read the wiki located here: https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!