Bug 312053 - Freeze when selecting text
Summary: Freeze when selecting text
Status: RESOLVED DUPLICATE of bug 306338
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 2.9.2
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-21 19:50 UTC by Gabriel Poesia
Modified: 2012-12-30 14:45 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
A screenshot with the debug messages (185.75 KB, image/png)
2012-12-21 20:04 UTC, Gabriel Poesia
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gabriel Poesia 2012-12-21 19:50:20 UTC
If I try to select any text in any konsole window (containing only simple ASCII characters), Konsole stops responding to input. 

I will attach a screenshot that shows the debug messages. The exact same crash and debug messages happen inside Yakuake (only substituting "konsole" by "yakuake").

Reproducible: Always

Steps to Reproduce:
1. Open Konsole
2. Select some text with the mouse

Actual Results:  
Konsole freezes

Expected Results:  
The selected text would be highlighted and I would be able to copy it
Comment 1 Gabriel Poesia 2012-12-21 20:04:36 UTC
Created attachment 75963 [details]
A screenshot with the debug messages

I ran Konsole from another Konsole instance to show the debug messages.

The Konsole in which the messages are shown is still responsive. Only the other window, in which I tried to select some text, freezed. When trying to close it, I get the "window not responding" dialog.
Comment 2 Christoph Feck 2012-12-21 21:20:30 UTC

*** This bug has been marked as a duplicate of bug 306338 ***
Comment 3 Gabriel Poesia 2012-12-30 14:45:50 UTC
I tested this with Konsole 2.9.3 and it worked as expected (same in Yakuake. It uses KPart, I guess?). Thanks!
The bug this one was marked as a duplicate of is still "Confirmed", though.