Bug 311994 - IMAP quota isn't displayed in some cases
Summary: IMAP quota isn't displayed in some cases
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Unclassified
Component: folders (show other bugs)
Version: 4.9.4
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-20 16:25 UTC by Pal Körössy
Modified: 2012-12-31 12:57 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 4.10


Attachments
screenshot:folder is almost empty (21.98 KB, image/png)
2012-12-20 17:14 UTC, Pal Körössy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pal Körössy 2012-12-20 16:25:11 UTC
IMAP quota in the "Folder properties" dialog on Qouta tab isn't displayed in the following cases:
- if account is over quota (over 100%)
- account is empty or close to 0%. 


Reproducible: Always



Expected Results:  
0% should be displayed if account is empty.
100% should be displayes if account is full and the display-bar should be fully filled.
Comment 1 Laurent Montel 2012-12-20 16:48:16 UTC
could you paste screenshot when 100% and 0% (for quota tab please)
Comment 2 Laurent Montel 2012-12-20 16:54:50 UTC
" if account is over quota (over 100%)" how you can be over quota ?
Comment 3 Pal Körössy 2012-12-20 17:11:10 UTC
(In reply to comment #2)
> " if account is over quota (over 100%)" how you can be over quota ?

You're right, it shouldn't happen. 
I made this situation by changing dovecot's quota config below the real size of the folder. But the display should show 100% and now it shows nothing.
Comment 4 Pal Körössy 2012-12-20 17:14:45 UTC
Created attachment 75941 [details]
screenshot:folder is almost empty

If the folder is full, the screenshot is the same.
Comment 5 Laurent Montel 2012-12-20 17:29:22 UTC
"0% should be displayed if account is empty." what is empty ?
for me when current value = 0 it shows 0%

so what is you quota max from your account and what is your current quota ? 

I tried to make 0 as current value and it works fine.

I can reproduce for over quota I have a fix for it. will commit for 4.10
Comment 6 Laurent Montel 2012-12-20 18:06:17 UTC
Git commit 90c85c58473b39fe6f0cad260ee1644ab487ed07 by Montel Laurent.
Committed on 20/12/2012 at 19:05.
Pushed by mlaurent into branch 'KDE/4.10'.

Start to fix Bug 311994 - IMAP quota isn't displayed in some cases

Fix when it's overquota

M  +2    -1    kmail/collectionquotapage.cpp

http://commits.kde.org/kdepim/90c85c58473b39fe6f0cad260ee1644ab487ed07
Comment 7 Pal Körössy 2012-12-21 09:06:21 UTC
(In reply to comment #5)
> "0% should be displayed if account is empty." what is empty ?
> for me when current value = 0 it shows 0%
> so what is you quota max from your account and what is your current quota ? 
> I tried to make 0 as current value and it works fine.

Now it works for me too (shows 0%) with dovecot on my local server, but experiences the problem (missing 0%) with my gmail account.
I don't know how to retrieve current quota manually from gmail.
Comment 8 Laurent Montel 2012-12-21 09:53:52 UTC
if it works for others account perhaps it's specific to google no ?
Do you use google resource ?
Comment 9 Pal Körössy 2012-12-21 10:11:14 UTC
(In reply to comment #8)
> if it works for others account perhaps it's specific to google no ?

The same happened yesterday with my local IMAP account on a local dovecot server as I wrote it but now I cannot reproduce it. So the problem seems not to be gmail-related.

> Do you use google resource ?

Only Kolab resources are configured in Akonadi but it has never worked for me on my gmail account either.
Comment 10 Pal Körössy 2012-12-28 13:40:26 UTC
In KDE3 "No quota is set for this folder" is displayed for my googlemail-account.
Comment 11 Laurent Montel 2012-12-28 14:02:34 UTC
Ok so it's a bug in imap when we get quota infos.
Will look at it soon
Comment 12 Laurent Montel 2012-12-28 15:38:24 UTC
ok found and reproduce it
value returned from gmail account it too big.
Will fix it soon.
Comment 13 Laurent Montel 2012-12-28 16:55:59 UTC
Git commit 58f13aa8ba737721e731f8e21764071a2fc30131 by Montel Laurent.
Committed on 28/12/2012 at 17:55.
Pushed by mlaurent into branch 'KDE/4.10'.

Fix Bug 311994 - IMAP quota isn't displayed in some cases

FIXED-IN: 4.10

M  +3    -2    kmail/collectionquotapage.cpp

http://commits.kde.org/kdepim/58f13aa8ba737721e731f8e21764071a2fc30131
Comment 14 Laurent Montel 2012-12-31 12:57:02 UTC
Git commit 7261c7b670ddc7644e42c602bee3049d284dea3a by Montel Laurent.
Committed on 28/12/2012 at 17:55.
Pushed by mlaurent into branch 'akregator_port'.

Fix Bug 311994 - IMAP quota isn't displayed in some cases

FIXED-IN: 4.10

M  +3    -2    kmail/collectionquotapage.cpp

http://commits.kde.org/kdepim/7261c7b670ddc7644e42c602bee3049d284dea3a