Bug 311974 - When I set the panel to auto-hide, the mouse does not reveal it
Summary: When I set the panel to auto-hide, the mouse does not reveal it
Status: RESOLVED UNMAINTAINED
Alias: None
Product: plasma4
Classification: Plasma
Component: containment-panel (show other bugs)
Version: 4.11.0
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-20 10:02 UTC by Marco Parillo
Modified: 2020-12-29 10:09 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Parillo 2012-12-20 10:02:11 UTC
I am running a Daily Kubuntu 13.04 build in VMWare Player. I normally set the panel to autohide and mouse to the bottom to reveal it. On 4.9.9, only Alt F1 reveals it.
Comment 1 Marco Parillo 2012-12-24 01:58:47 UTC
Perhaps KDE SC now uses the Xorg Xfixes' pointer barrier feature instead of the mouse pointer position? See  https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/971018/comments/11 in this bug report: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/971018
Comment 2 Christoph Feck 2012-12-28 20:12:47 UTC
Are you using a multiple-monitor configuration? Does it happen with a freshly created user account?
Comment 3 Marco Parillo 2012-12-29 11:01:29 UTC
> Are you using a multiple-monitor configuration?

No, a single VMware Player guest window on a laptop. Same behaviour regardless of whether I am in full screen, or window mode.

> Does it happen with a freshly created user account?

It was the regular user account created by default when I installed the Kubuntu daily build (Platform Version 4.9.95).
Comment 4 Marco Parillo 2013-01-05 21:40:01 UTC
Unchanged Using KDE Development Platform 4.9.97
Comment 5 Marco Parillo 2013-02-15 18:31:15 UTC
Changed to version 4.10 to indicate it is still a problem. Additional info: SOMETIMES, before I remove the windows frame from my VMWare Player window, I can get the panel to rise by mousing to the bottom, but never once I remove the Windows Frame to make my VMWare window 'full screen' (without scroll bars, etc.)
Comment 6 Marco Parillo 2013-03-28 09:22:31 UTC
I just installed openSUSE 12.3 into VMware Player, and installed VMware tools, and the same thing happens. That is, once the Panel is set to auto hide, moving my mouse to the bottom does not reveal it, but alt-F1 does.
Comment 7 Marco Parillo 2013-04-27 02:11:03 UTC
This appears to be only when the Panel is at the bottom.
When I read this, 
http://irclogs.ubuntu.com/2013/04/26/%23kubuntu.html#t10:34
I changed the screen edge to left, top, and right. 
In all cases, I could use the mouse to reveal the Panel, except for when the Panel is at the bottom.
Comment 8 Marco Parillo 2013-04-27 20:16:08 UTC
Changed to version 4.10.2 to indicate it is still a problem.
Comment 9 Marco Parillo 2013-04-28 10:59:22 UTC
Changed to kwin based on this thread:
http://forum.kde.org/viewtopic.php?f=111&t=109963&p=258859&hilit=wobbly+windows#p258859

After following the recommendations, the fancy Alt Tab switching has returned, but not my panel.
Funny thing: I am getting used to using Alt F1 instead of my mouse to unhide the panel.
Comment 10 Thomas Lübking 2013-04-28 13:07:18 UTC
sorry, i don't get it.
why do you think the compositor selection has anything to do with autohiding panels (xrender can only rotate around the z-axis, that's why opengl is required for cover switch or flipswitch) or why this would be a kwin issue?

my guess is that the input window to trigger the panel is placed too far at the bottom, but that's an issue of that containment.
Comment 11 Marco Parillo 2013-04-28 16:07:35 UTC
Thank you for your comment, Thomas.

I had originally opened this in Plasma > Containment-Panel.
Was that the best place for this, or can you suggest a better Product > Component?
Comment 12 Thomas Lübking 2013-04-28 16:15:09 UTC
Unless you've a better reason, that actually was the proper component - the WM does neither place nor interpret those windows, nor unhide the panel.
So if you don't actually have strong indication the WM is responsible here (very simple cross test: install and run eg "openbox --replace&", ie. check whether things change w/ a replacement WM) you should move the bug back there.

I suggest to run "xwininfo", move the cursor (now a cross and it will not trigger anything at this moment, that's ok) to where you'd expect a crossing event should show the autohiding panel and click.
Then post the output here.
Comment 13 Marco Parillo 2013-04-28 16:37:34 UTC
xwininfo: Window id: 0x280031e (has no name)

  Absolute upper-left X:  0
  Absolute upper-left Y:  1049
  Relative upper-left X:  0
  Relative upper-left Y:  1049
  Width: 1680
  Height: 1
  Depth: 0
  Visual: 0x21
  Visual Class: TrueColor
  Border width: 0
  Class: InputOnly
  Colormap: 0x0 (not installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: yes
  Corners:  +0+1049  -0+1049  -0-0  +0-0
  -geometry 1680x1+0-0
Comment 14 Thomas Lübking 2013-04-28 16:42:37 UTC
Ok, that's either the thing that should trigger the panel or an electric border from kwin, do you have an edge action configured for the bottom in "kcmshell4 kwinscreenedges"?
Comment 15 Marco Parillo 2013-04-28 22:38:31 UTC
Right, when I mouse to the bottom, I expect the panel that I set to auto-hide to appear. It used to work on 4.9; and it works on the top, left, and right.

How  do I check the edge action for kcmshell4 kwinscreenedges ?
Comment 16 Thomas Lübking 2013-04-28 22:44:27 UTC
(In reply to comment #15)
> How  do I check the edge action for kcmshell4 kwinscreenedges ?

Run the command "kcmshell4 kwinscreenedges" - it'll open a dialog.

Hover the bottom center checkbox in the screen icon - if the tooltip says sth. else than "no action", there's a conflicting action configured.

Also in the lowest area the "Switch desktop on edge" should NOT be "Always enabled" (the last value of the combobox)

If neither is set (action or VD switching on touching borders) this is the plasma panel proxy. Since it's there, the bug would be in plasma (whether the event is not received, handled or the panel is just placed out of the screen)
Comment 17 Marco Parillo 2013-04-29 01:11:06 UTC
> Hover the bottom center checkbox in the screen icon.
No Action

> Also in the lowest area the "Switch desktop on edge" should NOT be "Always enabled".
Disabled

So therefore, you recommend I point the bug back to Plasma > Containment-Panel?
Thank you for your patience.

P.S. For other newbies out there, once I launched the utility, it looked familiar. I could also get there from the Kickoff Application Launcher > System Settings > Workspace Behavior > Screen Edges
Comment 18 Martin Flöser 2013-04-29 05:49:40 UTC
back to plasma
Comment 19 Marco Parillo 2013-06-26 01:10:52 UTC
Bumping version to 4.10.3
Comment 20 Marco Parillo 2013-07-16 01:31:06 UTC
Bumping version to 4.10.5 after the upgrade on OpenSUSE.
Comment 21 Nick Hobart 2013-07-23 13:33:57 UTC
(In reply to comment #20)
> Bumping version to 4.10.5 after the upgrade on OpenSUSE.

I have the exactly same problem running 4.10.5 in LinuxMint 15. Hoping to get this resolved somehow. Thanks for the Alt-F1 trick - don't know about that.
Comment 22 Marco Parillo 2013-07-26 15:07:36 UTC
(In reply to comment #21)
> (In reply to comment #20)
> > Bumping version to 4.10.5 after the upgrade on OpenSUSE.
> 
> I have the exactly same problem running 4.10.5 in LinuxMint 15. Hoping to
> get this resolved somehow. Thanks for the Alt-F1 trick - don't know about
> that.

Another trick is to move the panel somewhere other than the bottom.
Problem for me is that I like it there?
Comment 23 Marco Parillo 2013-08-16 00:58:21 UTC
Marking as resolved. I have upgraded to the Kubuntu 13.10 daily build Using KDE Development Platform 4.11.00 and I can now auto-hide the panel and have it revealed when I mouse to the bottom.
Comment 24 Spencer Linkous 2020-12-09 19:28:57 UTC
Sorry to bump a 7 year old topic, but I'd just like to say that the problem is still there, on the top screen edge this time.

~ >>> latte-dock -v                                                                                                                                      
lattedock 0.9.86
~ >>>      

~ >>> neofetch                                                                                                
██████████████████  ████████   slinkous@manjarobook 
██████████████████  ████████   -------------------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: MacBookAir7,2 1.0 
████████            ████████   Kernel: 5.8.18-1-MANJARO 
████████  ████████  ████████   Uptime: 16 hours, 11 mins 
████████  ████████  ████████   Packages: 1796 (pacman), 20 (flatpak), 7 (snap) 
████████  ████████  ████████   Shell: bash 5.0.18 
████████  ████████  ████████   Resolution: 1440x900, 1920x1080 
████████  ████████  ████████   DE: Plasma 5.20.4 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   WM Theme: Ocean 
████████  ████████  ████████   Theme: Ocean [Plasma], Juno-ocean [GTK2/3] 
████████  ████████  ████████   Icons: Infinity-Dark-Icons [Plasma], Infinity-Dark-Icons [GTK2/3] 
                               Terminal: konsole 
                               Terminal Font: Noto Mono 10 
                               CPU: Intel i7-5650U (4) @ 3.200GHz 
                               GPU: Intel HD Graphics 6000 
                               Memory: 4961MiB / 7864MiB 

                                                       
                                                       


~ >>>
Comment 25 Christoph Feck 2020-12-29 10:09:06 UTC
Please do not reopen old Plasma 4 tickets. This could be a duplicate of bug 370964, otherwise please file a new ticket with exact steps to reproduce when starting with a freshly created user account.