Bug 311862 - No easy way to send windows to another activity
Summary: No easy way to send windows to another activity
Status: RESOLVED DUPLICATE of bug 283309
Alias: None
Product: kwin
Classification: Unclassified
Component: activities (show other bugs)
Version: unspecified
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-18 02:14 UTC by sparhawk
Modified: 2013-04-30 06:48 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sparhawk 2012-12-18 02:14:48 UTC
There seems to be no quick way to send windows to another activity. At the moment, the only way is to right-click the menubar (or press Alt-F3), select the "Activities" submenu, then select within there. This is checkbox, not radio-button–based, so you have to do this twice to send the window to a specific activity. That is, you have to select the destination activity, then deselect the original activity. This makes a sum total of six actions.

In comparison, you can send windows to another desktop in one action, by using a keyboard shortcut (System Settings > Global Keyboard Shortcuts > KWin > Window to Desktop 1). e.g. send the current window to desktop 1 by pressing Meta+Shift+1. 

Reproducible: Always

Steps to Reproduce:
1. Attempt to send the current window to another activity.
Actual Results:  
This requires six actions.

Expected Results:  
A single action, preferably a single keyboard shortcut.
Comment 1 Thiago Jung Bauermann 2013-01-15 16:10:02 UTC
One idea I had is that if you drag the window titlebar using the middle mouse button (or right mouse button, even?), one drop target for each activity would appear near the mouse pointer, and the window would be moved to the activity where the window is dropped.

It would be a bit obscure in that it is not immediately discoverable, but once the user knows about it, it would be very practical and ergonomic.
Comment 2 sparhawk 2013-01-15 23:22:35 UTC
My personal preference is to use keyboard shortcuts generally, so I favour that method. However, I think it's definitely a good idea to have multiple ways of doing the same thing (e.g. as per virtual desktops at the moment).

I think your suggestion is not a bad idea, but in my case, I have titlebars hidden, so it wouldn't even work… Another possibility is to drag and drop windows to the activities switcher widget in the panel. Also, I also think that if either idea is implemented for activities, it should also be implemented for virtual desktops too.
Comment 3 Thomas Lübking 2013-01-21 20:45:47 UTC

*** This bug has been marked as a duplicate of bug 283309 ***
Comment 4 sparhawk 2013-04-30 06:48:21 UTC
There is already a bug report to add keyboard shortcuts to send window to activity at bug 271686.