Bug 311831 - Repeating last action doesn't include completion
Summary: Repeating last action doesn't include completion
Status: RESOLVED FIXED
Alias: None
Product: kate
Classification: Applications
Component: Vi Input Mode (show other bugs)
Version: 4.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-17 14:42 UTC by Martin Sandsmark
Modified: 2013-06-04 16:11 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Sandsmark 2012-12-17 14:42:17 UTC
When pressing "." to repeat the last action it doesn't include what got completed, only what you typed (so if you type asd and hit ctrl+space, select asdf, hit enter, esc and press . you only get "asd" inserted).

Reproducible: Always
Comment 1 Simon St James 2013-03-01 21:31:01 UTC
Can you double-check this? Here, manually invoking completion via ctrl+space always ensures that the completion is included when you press "."; however, if completion is automatically invoked (because e.g. you've typed more than three characters, or whatever the limit is), then it is not.
Comment 2 Simon St James 2013-03-30 10:54:55 UTC
Git commit 72ffa4988c1927dbb919cd161c8cc6b87c4f62f4 by Simon St James.
Committed on 21/03/2013 at 21:18.
Pushed by sstjames into branch 'master'.

Add some Vim auto-completion tests, and fix a couple of bugs - one especially annoying one is when completion is invoked automatically and we attempt to repeat it via '.' - only the leading portion that we had typed of the completion would be repeated, not the whole thing.

Also, begin work on making the completion list wrap-around: this currently fails as https://git.reviewboard.kde.org/r/109647/ has not yet been committed.

M  +142  -0    part/tests/vimode_test.cpp
M  +3    -0    part/tests/vimode_test.h
M  +15   -0    part/vimode/kateviinsertmode.cpp
M  +5    -0    part/vimode/katevinormalmode.cpp

http://commits.kde.org/kate/72ffa4988c1927dbb919cd161c8cc6b87c4f62f4
Comment 3 Simon St James 2013-06-04 16:11:12 UTC
I'm going to assume that that last commit fixed this for you; if not, let me know :)