Bug 311751 - QML system tray crashes plasma-desktop on startup
Summary: QML system tray crashes plasma-desktop on startup
Status: RESOLVED UPSTREAM
Alias: None
Product: plasma4
Classification: Plasma
Component: widget-systemtray (show other bugs)
Version: 4.9.90 Beta2
Platform: Compiled Sources Linux
: HI crash
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
: 310647 313951 314610 314802 315427 316988 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-12-15 21:58 UTC by Michael Pyne
Modified: 2013-03-21 19:45 UTC (History)
41 users (show)

See Also:
Latest Commit:
Version Fixed In:
Sentry Crash Report:


Attachments
New crash information added by DrKonqi (7.59 KB, text/plain)
2013-01-05 16:42 UTC, Detlev Casanova
Details
New crash information added by DrKonqi (7.44 KB, text/plain)
2013-01-05 17:44 UTC, Martin Bednar
Details
New crash information added by DrKonqi (5.51 KB, text/plain)
2013-01-08 11:40 UTC, josan_pansa
Details
Qt patch to avoid calling VME meta object with unexpected data (830 bytes, text/plain)
2013-01-12 19:52 UTC, Michael Pyne
Details
New crash information added by DrKonqi (8.12 KB, text/plain)
2013-02-09 09:30 UTC, uwe.haider
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Pyne 2012-12-15 21:58:57 UTC
Loading the QML system tray causes plasma-desktop to immediately crash, in "QDeclarativeVMEMetaObject::metaCall" (see backtrace below).

All software from Qt 4.8 and up are as compiled from kdesrc-build, on a 64-bit AMD x86 machine using Gentoo as the underlying OS.

Versions (as from git-describe):
qt: v4.8.4-49-gc3fae0e (4.8 branch)
kdelibs: v4.9.90-39-g8d1d02a (KDE/4.10 branch)
kde-runtime: v4.9.90-44-g7c606bb (master)
kde-workspace: v4.9.90-72-g9c60e60 (master)
kdeplasma-addons: v4.9.90-14-g37b0925 (master)

By going to kde-workspace/plasma/generic/applets/systemtray and checking out git commit 131d7dc in *only* that directory I'm able to load plasma-desktop with a system tray, without crashing. I have not git-bisected further yet. (kde-workspace would probably work fine if it were all at 131d7dc, but I did not test that).

I chose 131d7dc because it is the master-side parent of the merge converting system tray to use QML.

For those who frequent #plasma on IRC, this is the cause of the crash I was having the other week, figured I'd make a bug for it as it's still crashing. I suspect it's a Qt issue (which seems to have been a problem elsewhere judging by the commit logs for plasma ;) but as it stands now Plasma is unusable here.

Here's the backtrace:

Application: Plasma Desktop Shell (kdeinit4), signal: Segmentation fault
Using host libthread_db library "/lib64/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f26f38fc780 (LWP 4188))]

Thread 2 (Thread 0x7f263bbef700 (LWP 4261)):
#0  0x00007f26f037314d in poll () from /lib64/libc.so.6
#1  0x00007f26ecaa80de in g_main_context_iterate.isra.23 () from /usr/lib64/libglib-2.0.so.0
#2  0x00007f26ecaa81f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#3  0x00007f26f2277fae in QEventDispatcherGlib::processEvents (this=0x7f26300008c0, flags=...) at /kdesvn/src/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:426
#4  0x00007f26f2243bd2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at /kdesvn/src/qt/src/corelib/kernel/qeventloop.cpp:149
#5  0x00007f26f2243e3f in QEventLoop::exec (this=0x7f263bbeeda0, flags=...) at /kdesvn/src/qt/src/corelib/kernel/qeventloop.cpp:204
#6  0x00007f26f212a730 in QThread::exec (this=<optimized out>) at /kdesvn/src/qt/src/corelib/thread/qthread.cpp:550
#7  0x00007f26f2221353 in QInotifyFileSystemWatcherEngine::run (this=0x34e4c90) at /kdesvn/src/qt/src/corelib/io/qfilesystemwatcher_inotify.cpp:256
#8  0x00007f26f212d5f2 in QThreadPrivate::start (arg=0x34e4c90) at /kdesvn/src/qt/src/corelib/thread/qthread_unix.cpp:338
#9  0x00007f26f1e91e37 in start_thread () from /lib64/libpthread.so.0
#10 0x00007f26f037bbbd in clone () from /lib64/libc.so.6

Thread 1 (Thread 0x7f26f38fc780 (LWP 4188)):
[KCrash Handler]
#6  QDeclarativeVMEMetaObject::metaCall (this=0x3d521f0, c=QMetaObject::WriteProperty, _id=32, a=0x7fff0318fe68) at /kdesvn/src/qt/src/declarative/qml/qdeclarativevmemetaobject.cpp:429
#7  0x00007f26f21148c9 in QPropertyAnimationPrivate::updateProperty (this=0x3d51a40, newValue=...) at /kdesvn/src/qt/src/corelib/animation/qpropertyanimation.cpp:139
#8  0x00007f26f2111d68 in QVariantAnimationPrivate::setCurrentValueForProgress (this=0x3d51a40, progress=<optimized out>) at /kdesvn/src/qt/src/corelib/animation/qvariantanimation.cpp:294
#9  0x00007f26f2112021 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x3d51a40, force=<optimized out>) at /kdesvn/src/qt/src/corelib/animation/qvariantanimation.cpp:279
#10 0x00007f26f21150b3 in QPropertyAnimation::updateState (this=0x3d580d0, newState=<optimized out>, oldState=QAbstractAnimation::Stopped) at /kdesvn/src/qt/src/corelib/animation/qpropertyanimation.cpp:285
#11 0x00007f26f210fb28 in QAbstractAnimationPrivate::setState (this=0x3d51a40, newState=QAbstractAnimation::Running) at /kdesvn/src/qt/src/corelib/animation/qabstractanimation.cpp:569
#12 0x00007f26e71b37d3 in Plasma::ItemBackground::itemChange (this=0x3d55010, change=<optimized out>, value=...) at /kdesvn/src/kde/kdelibs/plasma/widgets/itembackground.cpp:255
#13 0x00007f26f190594c in QGraphicsItemPrivate::setVisibleHelper (this=0x3d54580, newVisible=false, explicitly=<optimized out>, update=false) at /kdesvn/src/qt/src/gui/graphicsview/qgraphicsitem.cpp:2288
#14 0x00007f26f1905e4d in QGraphicsItemPrivate::setVisibleHelper (this=0x3d4b1b0, newVisible=false, explicitly=<optimized out>, update=<optimized out>) at /kdesvn/src/qt/src/gui/graphicsview/qgraphicsitem.cpp:2355
#15 0x00007f26f1907984 in QGraphicsItemPrivate::setParentItemHelper (this=0x3d4b1b0, newParent=0x3d49490, newParentVariant=0x7fff03190390, thisPointerVariant=<optimized out>) at /kdesvn/src/qt/src/gui/graphicsview/qgraphicsitem.cpp:1236
#16 0x00007f26f1907d04 in QGraphicsItem::setParentItem (this=0x3d4b100, newParent=0x3d49490) at /kdesvn/src/qt/src/gui/graphicsview/qgraphicsitem.cpp:1724
#17 0x00007f2653e2ae49 in syncMainItem (this=0x3d49480) at /kdesvn/src/kde/kde-runtime/plasma/declarativeimports/core/dialog.cpp:167
#18 DialogProxy::syncMainItem (this=0x3d49480) at /kdesvn/src/kde/kde-runtime/plasma/declarativeimports/core/dialog.cpp:135
#19 0x00007f26f2260f3e in QObject::event (this=0x3d49480, e=<optimized out>) at /kdesvn/src/qt/src/corelib/kernel/qobject.cpp:1194
#20 0x00007f26f128f87e in notify_helper (e=0x3d4bb50, receiver=0x3d49480, this=0x1cda050) at /kdesvn/src/qt/src/gui/kernel/qapplication.cpp:4562
#21 QApplicationPrivate::notify_helper (this=0x1cda050, receiver=0x3d49480, e=0x3d4bb50) at /kdesvn/src/qt/src/gui/kernel/qapplication.cpp:4534
#22 0x00007f26f12951a9 in QApplication::notify (this=0x1cd95f0, receiver=0x3d49480, e=0x3d4bb50) at /kdesvn/src/qt/src/gui/kernel/qapplication.cpp:4423
#23 0x00007f26f32ea0e8 in KApplication::notify (this=0x1cd95f0, receiver=0x3d49480, event=0x3d4bb50) at /kdesvn/src/kde/kdelibs/kdeui/kernel/kapplication.cpp:311
#24 0x00007f26f224594b in QCoreApplication::notifyInternal (this=0x1cd95f0, receiver=0x3d49480, event=0x3d4bb50) at /kdesvn/src/qt/src/corelib/kernel/qcoreapplication.cpp:946
#25 0x00007f26f22491ec in sendEvent (event=0x3d4bb50, receiver=0x3d49480) at ../../include/QtCore/../../../../src/qt/src/corelib/kernel/qcoreapplication.h:231
#26 QCoreApplicationPrivate::sendPostedEvents (receiver=0x0, event_type=0, data=0x1ba82b0) at /kdesvn/src/qt/src/corelib/kernel/qcoreapplication.cpp:1570
#27 0x00007f26f2277b13 in sendPostedEvents () at ../../include/QtCore/../../../../src/qt/src/corelib/kernel/qcoreapplication.h:236
#28 postEventSourceDispatch (s=0x1ccc930) at /kdesvn/src/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:279
#29 0x00007f26ecaa7e0a in g_main_context_dispatch () from /usr/lib64/libglib-2.0.so.0
#30 0x00007f26ecaa8145 in g_main_context_iterate.isra.23 () from /usr/lib64/libglib-2.0.so.0
#31 0x00007f26ecaa81f4 in g_main_context_iteration () from /usr/lib64/libglib-2.0.so.0
#32 0x00007f26f2277f56 in QEventDispatcherGlib::processEvents (this=0x1caf100, flags=...) at /kdesvn/src/qt/src/corelib/kernel/qeventdispatcher_glib.cpp:424
#33 0x00007f26f1341986 in QGuiEventDispatcherGlib::processEvents (this=<optimized out>, flags=...) at /kdesvn/src/qt/src/gui/kernel/qguieventdispatcher_glib.cpp:204
#34 0x00007f26f2243bd2 in QEventLoop::processEvents (this=<optimized out>, flags=...) at /kdesvn/src/qt/src/corelib/kernel/qeventloop.cpp:149
#35 0x00007f26f2243e3f in QEventLoop::exec (this=0x7fff03190d70, flags=...) at /kdesvn/src/qt/src/corelib/kernel/qeventloop.cpp:204
#36 0x00007f26f22495e7 in QCoreApplication::exec () at /kdesvn/src/qt/src/corelib/kernel/qcoreapplication.cpp:1218
#37 0x00007f26dfd796c5 in kdemain (argc=1, argv=0x1ba9770) at /kdesvn/src/kde/kde-workspace/plasma/desktop/shell/main.cpp:126
#38 0x0000000000408a7c in launch (argc=1, _name=0x1bfd438 "/home/kde-svn/kde-4/bin/plasma-desktop", args=<optimized out>, cwd=0x0, envc=<optimized out>, envs=<optimized out>, reset_env=false, tty=0x0, avoid_loops=false, startup_id_str=0x40b4d9 "0") at /kdesvn/src/kde/kdelibs/kinit/kinit.cpp:726
#39 0x0000000000409b36 in handle_launcher_request (sock=8, who=<optimized out>) at /kdesvn/src/kde/kdelibs/kinit/kinit.cpp:1218
#40 0x000000000040a083 in handle_requests (waitForPid=0) at /kdesvn/src/kde/kdelibs/kinit/kinit.cpp:1411
#41 0x00000000004058f6 in main (argc=4, argv=0x7fff00000001, envp=0x7fff03192260) at /kdesvn/src/kde/kdelibs/kinit/kinit.cpp:1899
Comment 1 Michael Pyne 2012-12-15 22:46:32 UTC
According to git-bisect, the first bad commit is:
commit f0763588f649953125592ff91dd9052df387cd52
Author: Marco Martin <notmart@gmail.com>
Date:   Fri Nov 23 16:31:21 2012 +0100

    use a Repeater instead of a ListView
    
    a ListView can delete the items when it wants, and being tasks reparented to them, this causes either crashes or empty entries in the menu.
    a Repeater ensures its items won't be deleted

:040000 040000 37e3d3b708b473babfffdff94e989286c02cf1f3 957e297b44d3dc6347b7edc9f4a418c9507a8380 M      plasma

I'll see if switching to master and then reverting that one commit is feasible (and if so, whether the crash is still present).
Comment 2 Michael Pyne 2012-12-15 22:50:23 UTC
Reverting f076358 (from current master here, commit 9c60e60) does indeed keep the crash from occurring. I'm not sure what to make of the warnings in the output of running plasma-desktop though, but at least it's usable.
Comment 3 Markus 2012-12-20 23:30:55 UTC
I can confirm this bug.

I built kde from scratch with kdesrc-build on OpenSuse 12.2 64-bit.

Versions (as from git-describe):
qt: v4.8.4-75-gc1565d0 (4.8 branch)
kdelibs: v4.9.90-56-gb0586b0 (KDE/4.10 branch)
kde-runtime: v4.9.90-52-g8b9b7ab (KDE/4.10 branch)
kde-workspace: v4.9.90-91-g2a685d9 (KDE/4.10 branch)
kdeplasma-addons: v4.9.90-17-gc0f7cf6 (KDE/4.10 branch)
Comment 4 David E. Narvaez 2012-12-29 16:08:29 UTC
Confirmed on AMD64 with Qt and KDE built from packages:

x11-libs/qt-declarative-4.8.4
kde-base/kdelibs-4.9.95
kde-base/plasma-workspace-4.9.95
kde-base/kdeplasma-addons-4.9.95
Comment 5 Ctibor Brančík 2013-01-05 09:10:20 UTC
I have just built 4.9.97 aka RC2 and the bug is still here.
Comment 6 Detlev Casanova 2013-01-05 16:42:18 UTC
Created attachment 76213 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.9.97 using Qt 4.8.4

- Custom settings of the application:

 * Empty kde configuration
 * Started from X using starkde
 * Compiled from remotes/origin/KDE/4.10 branch

-- Backtrace (Reduced):
#6  QDeclarativeVMEMetaObject::metaCall (this=0x24e6010, c=QMetaObject::WriteProperty, _id=32, a=0x7fff734ab008) at qml/qdeclarativevmemetaobject.cpp:429
#7  0x00007f0f7e1deec9 in QPropertyAnimationPrivate::updateProperty (this=0x24e5880, newValue=...) at animation/qpropertyanimation.cpp:139
#8  0x00007f0f7e1dc700 in QVariantAnimationPrivate::setCurrentValueForProgress (this=0x24e5880, progress=<optimized out>) at animation/qvariantanimation.cpp:294
#9  0x00007f0f7e1dc972 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x24e5880, force=<optimized out>) at animation/qvariantanimation.cpp:279
#10 0x00007f0f7e1df876 in QPropertyAnimation::updateState (this=0x2656440, newState=<optimized out>, oldState=<optimized out>) at animation/qpropertyanimation.cpp:285
Comment 7 Martin Bednar 2013-01-05 17:44:46 UTC
Created attachment 76214 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.9.97 using Qt 4.8.4

Clean KDE config, just add a system tray and see plasma from RC2 (4.9.97) crash...

-- Backtrace (Reduced):
#6  QDeclarativeVMEMetaObject::metaCall (this=0x2d6f1c0, c=QMetaObject::WriteProperty, _id=32, a=0x7fff566706c8) at qml/qdeclarativevmemetaobject.cpp:429
#7  0x00007f1314885fe9 in QPropertyAnimationPrivate::updateProperty (this=0x2fb8ef0, newValue=...) at animation/qpropertyanimation.cpp:139
#8  0x00007f13148836f0 in QVariantAnimationPrivate::setCurrentValueForProgress (this=0x2fb8ef0, progress=<optimized out>) at animation/qvariantanimation.cpp:294
#9  0x00007f1314883962 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x2fb8ef0, force=<optimized out>) at animation/qvariantanimation.cpp:279
#10 0x00007f1314886996 in QPropertyAnimation::updateState (this=0x2f95110, newState=<optimized out>, oldState=<optimized out>) at animation/qpropertyanimation.cpp:285
Comment 8 David E. Narvaez 2013-01-05 17:53:12 UTC
Adding Marco, since this seems to have slipped through a couple of RCs and affects a number of distros.

I should have added I'm experiencing this bug in Gentoo. Can Ctibor and Detlev add their distros to understand how many distros are affected by this? Are you both using 64 bit platforms?
Comment 9 David E. Narvaez 2013-01-05 17:58:09 UTC
Sorry, just checked Detlev's attachment, that's a 64 bit OS too. Ctbior, are you using a 64 bit paltform too?
Comment 10 Detlev Casanova 2013-01-06 00:18:11 UTC
Using Gentoo with a x86_64 environement. (Linux naboo 3.7.1-gentoo #3 SMP Sun Dec 30 21:25:54 CET 2012 x86_64 Intel(R) Core(TM) i3 CPU M 370 @ 2.40GHz GenuineIntel GNU/Linux)
Comment 11 Ctibor Brančík 2013-01-06 15:25:11 UTC
Gentoo x86_64 here.
Comment 12 Michael Pyne 2013-01-08 02:46:20 UTC
It seems like there's only Gentoo and OpenSuse bug reports at this time... I suppose the open question is whether there are people experiencing this on a 32-bit system?
Comment 13 josan_pansa 2013-01-08 11:40:24 UTC
Created attachment 76305 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.9.97 using Qt 4.8.4

- What I was doing when the application crashed:

I am in the same plasma fails to start .i have no way to initiate plasma,or konsole or alt f2, gentoo also x64

-- Backtrace (Reduced):
#6  QDeclarativeVMEMetaObject::metaCall (this=0x1dd0a60, c=QMetaObject::WriteProperty, _id=32, a=0x7fff015adea8) at qml/qdeclarativevmemetaobject.cpp:429
#7  0x0000003ddbe6aa09 in QPropertyAnimationPrivate::updateProperty (this=0x1dd03e0, newValue=...) at animation/qpropertyanimation.cpp:139
#8  0x0000003ddbe67ea8 in QVariantAnimationPrivate::setCurrentValueForProgress (this=0x1dd03e0, progress=<optimized out>) at animation/qvariantanimation.cpp:294
#9  0x0000003ddbe68161 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x1dd03e0, force=<optimized out>) at animation/qvariantanimation.cpp:279
#10 0x0000003ddbe6b1f3 in QPropertyAnimation::updateState (this=0x213f460, newState=<optimized out>, oldState=QAbstractAnimation::Stopped) at animation/qpropertyanimation.cpp:285
Comment 14 David E. Narvaez 2013-01-08 11:56:02 UTC
(In reply to comment #12)
> It seems like there's only Gentoo and OpenSuse bug reports at this time... I
> suppose the open question is whether there are people experiencing this on a
> 32-bit system?

I think another open question is if this is specific to OpenSuse and Gentoo or is it that nobody is testing this on other distros yet.
Comment 15 Jekyll Wu 2013-01-08 12:15:00 UTC
No problem on my x86(32 bit) Gentoo box.
Comment 16 Martin Bednar 2013-01-09 00:53:44 UTC
Just an FYI : I'm also running 4.10 RC2 on a 64-bit Chakra PC, it doesn't seem to be affected.
Comment 17 Ctibor Brančík 2013-01-09 16:27:14 UTC
My settings which packages were compiled with:

emerge --info plasma-workspace plasma-apps kdeplasma-addons kdelibs
Portage 2.2.0_alpha149 (default/linux/amd64/10.0/desktop/kde, gcc-4.6.3, glibc-2.15-r3, 3.6.11-pf x86_64)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.6.11-pf-x86_64-AMD_Phenom-tm-_II_X4_905e_Processor-with-gentoo-2.1
Timestamp of tree: Wed, 09 Jan 2013 02:00:01 +0000
ld GNU ld (GNU Binutils) 2.22
distcc 3.1 x86_64-pc-linux-gnu [disabled]
ccache version 3.1.8 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r2, 3.2.3
dev-util/ccache:          3.1.8
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.7.9-r2, 1.8.5-r4, 1.9.6-r3, 1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo x11 rion dagger gamerlay systemd wavilen kde sunrise multimedia flow brancik-overlay crossdev
Installed sets: @fonts, @kde-misc, @kde-packages, @qt-user-4.8, @system                                                                                    
ACCEPT_KEYWORDS="amd64"                                                                                                                                    
ACCEPT_LICENSE="* -@EULA dlj-1.1 SMLABS-EULA AdobeFlash-10.1 skype-eula Oracle-BCLA-JavaSE"                                                                
CBUILD="x86_64-pc-linux-gnu"                                                                                                                               
CFLAGS="-march=amdfam10 -O2 -pipe -ggdb"                                                                                                                   
CHOST="x86_64-pc-linux-gnu"                                                                                                                                
CONFIG_PROTECT="/etc /usr/armv6j-hardfloat-linux-gnueabi/etc/portage/ /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/openvpn/easy-rsa /usr/share/themes/oxygen-gtk/gtk-2.0"                                                                                                                              
CONFIG_PROTECT_MASK="${EPREFIX}/etc/gconf /etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"           
CXXFLAGS="-march=amdfam10 -O2 -pipe -ggdb"                                                                                                                 
DISTDIR="/mnt/server/ctibor/portage//distfiles"                                                                                                            
EMERGE_DEFAULT_OPTS="--keep-going --autounmask-write --quiet-build=n --binpkg-respect-use=y --jobs 2 --load-average 4"                                     
FCFLAGS="-O2 -pipe"                                                                                                                                        
FEATURES="assume-digests binpkg-logs buildpkg clean-logs config-protect-if-modified distlocks ebuild-locks fail-clean fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"                           
FFLAGS="-O2 -pipe"                                                                                                                                         
GENTOO_MIRRORS="http://gentoo.wheel.sk/ http://gentoo.supp.name/ http://de-mirror.org/distro/gentoo/"                                                      
LDFLAGS="-Wl,-O1 -Wl,--as-needed"                                                                                                                          
MAKEOPTS="-j4"                                                                                                                                             
PKGDIR="/mnt/server/ctibor/portage//packages/thuban/"                                                                                                      
PORTAGE_COMPRESS="lzma"                                                                                                                                    
PORTAGE_CONFIGROOT="/"                                                                                                                                     
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"                                                                                                       
PORTAGE_TMPDIR="/var/tmp"                                                                                                                                  
PORTDIR="/mnt/server/ctibor/portage"                                                                                                                       
PORTDIR_OVERLAY="/var/lib/layman/x11 /var/lib/layman/rion /var/lib/layman/dagger /var/lib/layman/gamerlay /var/lib/layman/systemd /var/lib/layman/wavilen /var/lib/layman/kde /var/lib/layman/sunrise /var/lib/layman/multimedia /var/lib/layman/flow /var/lib/layman/brancik-overlay /var/lib/layman/crossdev"       
SYNC="rsync://brancik.cz/gentoo-portage"                                                                                                                   
USE="3dnow 7zip X a52 aac aalib acl acpi aiglx alsa amd64 apache2 aspell avi bash-completion berkdb blueray bluetooth bluray branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups cxx dbus declarative devicekit dga dirac djvu docbook dri dts dvb dvd dvdr dvdread emboss encode exif exiv2 fam ffmpeg firefox flac fortran gdbm gif gphoto2 gpm htmlhandbook iconv icq id3tag ieee1394 imagemagick imlib ipv6 irc jabber jack jingle jpeg jpeg2k kde kerberos kipi ladspa lash lcms libnotify lirc lzma mad midi mmx mng modules mp3 mp4 mpeg mtp mudflap multilib musicbrainz ncurses nepomuk nls npp nptl offensive ogg openal openexr opengl openmp pam pango pcmcia pcre pda pdf phonon plasma png policykit portaudio ppds pppd qt3support qt4 rdesktop readline rss samba sasl sdl semantic-desktop session smp speex spell sse sse2 sse3 ssl startup-notification svg tcpd telepathy theora threads tiff truetype type1 udev udisks unicode upnp upower usb v4l v4l2 vaapi vhosts vorbis wifi winbind wxwidgets x264 xcb xcomposite xine xinerama xml xscreensaver xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="words tables krita stage sheets" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" DRACUT_MODULES="crypt gensplah lvm mdraid syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="mouse keyboard wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="cs" LIRC_DEVICES="livedrive_midi" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="r600 radeon" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

kde-base/plasma-workspace-4.9.97 was built with the following:
USE="handbook python rss semantic-desktop (-aqua) -debug -google-gadgets -gps -qalculate"


kde-base/plasma-apps-4.9.97 was built with the following:
USE="(-aqua) -debug"


kde-base/kdeplasma-addons-4.9.97 was built with the following:
USE="exif qalculate qwt scim semantic-desktop (-aqua) -attica -debug -desktopglobe -fcitx -ibus -json -oauth"


kde-base/kdelibs-4.9.97 was built with the following:
USE="3dnow acl alsa bzip2 fam handbook jpeg2k kerberos lzma mmx nls openexr opengl (policykit) semantic-desktop spell sse sse2 ssl udev udisks upower (-altivec) (-aqua) -debug -doc -test (-udisks2) (-upnp) -zeroconf"
Comment 18 David E. Narvaez 2013-01-09 16:55:08 UTC
I posted a patch here for all affected Gentoo users

https://bugs.gentoo.org/show_bug.cgi?id=450818

which is not a fix, but a workaround for the meantime. I tested today the latest code from the 4.10 branch and this seems fixed. I'll update later when I can confirm this.
Comment 19 David E. Narvaez 2013-01-11 11:58:12 UTC
Indeed installing latest code from the 4.10 branch works for me, but I don't see any commit related to this fix so the fact that it works may just be a configuration difference.

MIchael, are you able to check out kde-workspace in its 4.10 branch and install that for your test?
Comment 20 David E. Narvaez 2013-01-11 12:36:59 UTC
Forget it, I didn't clean my revert properly before reinstalling. After cleaning it and using latest master, it's crashing again....
Comment 21 David E. Narvaez 2013-01-11 13:13:59 UTC
(In reply to comment #16)
> Just an FYI : I'm also running 4.10 RC2 on a 64-bit Chakra PC, it doesn't
> seem to be affected.

Thanks for the info, that's very important. What's Chakra's GCC version as of now?

$ gcc --version
Comment 22 Martin Bednar 2013-01-11 15:50:38 UTC
Chakra gcc version : gcc (GCC) 4.7.2
Comment 23 Egor Y. Egorov 2013-01-12 03:25:57 UTC
On my Gentoo (amd64) with gcc-4.7.2 no problem. On other system with gcc-4.5.4 same bug.
Comment 24 Michael Pyne 2013-01-12 04:05:48 UTC
I had gcc 4.6.3 (or thereabouts), I'm recompiling now with 4.7.2 (Qt and kde-workspace only at this point).
Comment 25 Michael Pyne 2013-01-12 05:22:35 UTC
Well I think I've recompiled everything between Qt and kde-workspace with gcc 4.7.2 with no success. Will try again tomorrow I suppose (maybe with valgrind if I can get it to go).
Comment 26 David E. Narvaez 2013-01-12 05:23:33 UTC
Thank you all for your cooperation. This turns out to be a Qt bug, reported at

https://bugreports.qt-project.org/browse/QTBUG-29082

I'll provide a patch for gentoo at the bug linked above. Should we leave this bug as open while the qt bug is fixed for easy reference?
Comment 27 Michael Pyne 2013-01-12 17:45:51 UTC
We can certainly use this bug for KDE tracking purposes, but if it's upstream let's go ahead and mark it as such. If/when a Qt patch is identified we can go ahead and mirror it here though so it can be tested.
Comment 28 Michael Pyne 2013-01-12 19:52:16 UTC
Created attachment 76426 [details]
Qt patch to avoid calling VME meta object with unexpected data

This patch seems to fix/workaround the crash issue by removing the "optimized" property speedup. Probably not the proper fix (someone with knowledge of the Qt internals would need to work on that) but it can at least help mitigate this issue.
Comment 29 Christoph Feck 2013-01-29 13:14:52 UTC
*** Bug 310647 has been marked as a duplicate of this bug. ***
Comment 30 Christoph Feck 2013-02-04 21:35:53 UTC
*** Bug 313951 has been marked as a duplicate of this bug. ***
Comment 31 Andreas K. Huettel 2013-02-07 22:06:28 UTC
Everyone,  since the QT situation seems to be more complex (as I gather from the codereview), do you have any ideas how to code a (temporary) workaround in plasma-desktop? If only to use it as a downstream workaround? This seems to be hitting a lot of people now. :(
Comment 32 Michael Pyne 2013-02-07 23:05:42 UTC
Andreas:

I successfully ran plasma-desktop with the reversion as from comment 2 for awhile, but I don't know if that's still safe.

It is true that the Qt code review indicates that it's not a full fix (as it can introduce crashing in multi-threaded Qt 4 QML-using apps?), but I've never experienced that issue after running a patched Qt for weeks now. I guess it's a pick-your-poison thing. :-/
Comment 33 Jekyll Wu 2013-02-08 01:43:05 UTC
*** Bug 314610 has been marked as a duplicate of this bug. ***
Comment 34 Andreas K. Huettel 2013-02-08 20:31:30 UTC
(In reply to comment #32)
> Andreas:
> 
> I successfully ran plasma-desktop with the reversion as from comment 2 for
> awhile, but I don't know if that's still safe.
> 

OK, I added that in Gentoo as workaround patch to plasma-workspace. Everything's better than a full crash. (for reference, kde-base/plasma-workspace-4.10.0-r1) We'll see.
Comment 35 Andreas K. Huettel 2013-02-08 20:34:33 UTC
(In reply to comment #34)
> (In reply to comment #32)
> > Andreas:
> > 
> > I successfully ran plasma-desktop with the reversion as from comment 2 for
> > awhile, but I don't know if that's still safe.
> > 
> 
> OK, I added that in Gentoo as workaround patch to plasma-workspace.
> Everything's better than a full crash. (for reference,
> kde-base/plasma-workspace-4.10.0-r1) We'll see.

Gentoo users report that plasma-desktop then starts hogging 100% CPU at some point. Well. Still better than a crash.
Comment 36 andre.reinke 2013-02-08 20:45:48 UTC
(In reply to comment #35)
> (In reply to comment #34)
> > (In reply to comment #32)
> > > Andreas:
> > > 
> > > I successfully ran plasma-desktop with the reversion as from comment 2 for
> > > awhile, but I don't know if that's still safe.
> > > 
> > 
> > OK, I added that in Gentoo as workaround patch to plasma-workspace.
> > Everything's better than a full crash. (for reference,
> > kde-base/plasma-workspace-4.10.0-r1) We'll see.
> 
> Gentoo users report that plasma-desktop then starts hogging 100% CPU at some
> point. Well. Still better than a crash.

Can confirm that! This has been my first choice on how to find a workaround.

This is really weird:

I compiled qt-core with CFLAGS="-Os" and now plasma-workspace is fine.

I read it here http://www.gentooforum.de/artikel/21098/nach-update-auf-kde-4-10-kein-desktop-mehr.html#post148201 and tried myself.

Dunno if it works for gentoo only.
Comment 37 andre.reinke 2013-02-08 20:55:24 UTC
The same mentioned in english: https://bugs.gentoo.org/show_bug.cgi?id=450818#c17
Comment 38 Andreas K. Huettel 2013-02-08 21:38:24 UTC
Would it be possible (or advisable) to revert plasma to 4.9 state locally in Gentoo (while keeping the rest at 4.10)?
Comment 39 David E. Narvaez 2013-02-08 21:47:32 UTC
Can we just concentrate in gathering enough influential people to make Qt fix the real bug here? This bug has been open for months now, I don't see why are we, at this point, looking for the perfect combination of compiler flags to have plasma running.
Comment 40 Andreas K. Huettel 2013-02-08 21:58:05 UTC
> Can we just concentrate in gathering enough influential people to make Qt
> fix the real bug here? This bug has been open for months now
+1

Tried to summarize the situation in a blog post, maybe it gets noticed. 
http://dilfridge.blogspot.de/2013/02/kde-4100-plasma-desktop-crashes-and-qt.html
Comment 41 Christoph Feck 2013-02-08 22:21:18 UTC
Thanks, I just feel "Qt frustrations" title is not appropriate. We have our own crashes and bugs, that are unfixed for years (bug 242648, anyone?)

Qt developers were busy getting 5.0 out, and with a test case, that reproduces the problem, I am sure they can fix it soon.

Back on topic, is a workaround, that can be applied to KDE, known? I mean, except removing all QML applets...
Comment 42 David E. Narvaez 2013-02-08 22:34:22 UTC
(In reply to comment #41)
> Qt developers were busy getting 5.0 out, and with a test case, that
> reproduces the problem, I am sure they can fix it soon.

Well, you seldom have bug reports with detailed problematic code paths and a crystal-clear explanation of what's wrong. It is definitely a hard thing to fix, but they haven't cared to comment in the bug, and they barely comment in the code review, so "Qt frustration" is a very condescendent title - at least my blog post won't be that sweet.
Comment 43 Thomas Capricelli 2013-02-08 23:06:10 UTC
I have the problem here on gentoo amd64. Recompiling qt-core with -Os works as a workaround for me, as mentionned by others.
Comment 44 Nick Shaforostoff 2013-02-08 23:23:30 UTC
1) please try running under 'valgrind --track-origins=yes' and post the output here.
2) a minimal testcase would be much appreciated. e.g i can try if this is reproducible on mac.
Comment 45 Thomas Capricelli 2013-02-08 23:45:34 UTC
(In reply to comment #44)
> 1) please try running under 'valgrind --track-origins=yes' and post the
> output here.
> 2) a minimal testcase would be much appreciated. e.g i can try if this is
> reproducible on mac.

Erm. This bug is closed, it's a known problem in Qt (and now even famous). People are (hopefully) working on it.
Comment 46 uwe.haider 2013-02-09 09:30:07 UTC
Created attachment 77047 [details]
New crash information added by DrKonqi

plasma-desktop (0.4) on KDE Platform 4.10.00 using Qt 4.8.4

- What I was doing when the application crashed:

login in KDE causes the crash every time I try it. Since Update from KDE-4.9 I can*t start kde without this crash.... anymore.

-- Backtrace (Reduced):
#6  QDeclarativeVMEMetaObject::metaCall (this=0x2dea500, c=QMetaObject::WriteProperty, _id=32, a=0x7fff17ed5718) at qml/qdeclarativevmemetaobject.cpp:429
#7  0x00007f1a0347a229 in QPropertyAnimationPrivate::updateProperty (this=0x2de9d70, newValue=...) at animation/qpropertyanimation.cpp:139
#8  0x00007f1a034777f0 in QVariantAnimationPrivate::setCurrentValueForProgress (this=0x2de9d70, progress=<optimized out>) at animation/qvariantanimation.cpp:294
#9  0x00007f1a03477a55 in QVariantAnimationPrivate::recalculateCurrentInterval (this=0x2de9d70, force=<optimized out>) at animation/qvariantanimation.cpp:279
#10 0x00007f1a0347abad in QPropertyAnimation::updateState (this=0x2e2abe0, newState=<optimized out>, oldState=<optimized out>) at animation/qpropertyanimation.cpp:285
Comment 47 Andreas K. Huettel 2013-02-09 13:59:19 UTC
Gathering from comments on my blog, this affects Gentoo, OpenSuSE, Kubuntu and Slackware so far.
Comment 48 Kari Somby 2013-02-09 14:58:09 UTC
I can confirm this bug.
I had this with Ubuntu 12.04.1 /w kde-desktop (kde version 4.10.00) installed
and now in Kubuntu 12.10 also with kde version 4.10.00
Comment 49 Kari Somby 2013-02-09 15:01:26 UTC
Additional information for my comment.
This is strange.
If I try to install system tray to task bar, it crashes, BUT when I installed it to desktop, no crash?
Comment 50 Kari Somby 2013-02-09 20:01:43 UTC
And now more strange results.
I reported previously:

-First report
"I can confirm this bug.
I had this with Ubuntu 12.04.1 /w kde-desktop (kde version 4.10.00) installed
and now in Kubuntu 12.10 also with kde version 4.10.00"

-Second report
"Additional information for my comment.
This is strange.
If I try to install system tray to task bar, it crashes, BUT when I installed it to desktop, no crash?"

And the first were done using ati/amd closed source drivers and second one were done using kubuntu/ubuntu open source (some I can't remember) driver.
Now I installed again ati/amd closed source driver and therefor now I can't install system tray to desktop (which were possible while using open source driver?).

Hope someone @ (k)ubuntu can fix this.
Comment 51 Jekyll Wu 2013-02-10 05:19:34 UTC
*** Bug 314802 has been marked as a duplicate of this bug. ***
Comment 52 liuerfire Wang 2013-02-10 11:28:16 UTC
I have the same problem on Archlinux(KDE 4.10).
Comment 53 Alexandre Bonneau 2013-02-11 10:20:25 UTC
I can confirm the plasma-desktop crash on Kubuntu 12.10 with kde 4.10 from kubuntu-ppa backports.

Here is the output of the crash :
$ plasma-desktop 
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 9: reading configurations from ~/.fonts.conf is deprecated.
QDBusObjectPath: invalid path ""
## Loading catalog liblancelot-datamodels 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
QGraphicsLinearLayout::insertItem: cannot insert null item
QGraphicsLinearLayout::insertItem: cannot insert null item
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
plasma-desktop(2985)/libplasma Plasma::isPluginVersionCompatible: unversioned plugin detected, may result in instability 
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
plasma-desktop(2985)/libplasma Plasma::PackagePrivate::isValid: Could not find required file mainscript 
QGraphicsLinearLayout::removeAt: invalid index 0
KCrash: Attempting to start /usr/bin/plasma-desktop from kdeinit
sock_file=/home/user/.kde/socket-deep/kdeinit4__0
plasma-desktop(2984): Communication problem with  "plasma-desktop" , it probably crashed. 
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" " 

KCrash: Application 'plasma-desktop' crashing...
KCrash: Attempting to start /usr/lib/kde4/libexec/drkonqi from kdeinit
sock_file=/home/user/.kde/socket-deep/kdeinit4__0
Comment 54 Nick Shaforostoff 2013-02-11 15:43:57 UTC
i'm using KDE 4.10 on kubuntu 12.04 in netbook mode (plasma-netbook instead of plasma-desktop) and everything is fine. The whole system even uses less memory now.
Comment 55 Alexandre Bonneau 2013-02-11 20:00:17 UTC
Everything worked fine when I deleted the plasma-desktop-appletsrc file.
Then I proceeded to add back my usual widget in the taskbar : quickaccess, icon-only task switcher, magic folder, qalculate, lancelot widgets, and selected some additional functions in the notification area....then plasma-desktop started to crash again at startup.

Right now I'm narrowing down the faulty widgets by editing the plasma-desktop-appletsrc configuration file, all my tests can say now is then problem is in the notification applet, not in the other widget I added.

I'll post again when I'll find the guilty one.
Comment 56 Michael Pyne 2013-02-11 23:25:58 UTC
Alexandre, if the crash isn't due to a "VME meta object" error then it may be a different bug. In my testing only the systray applet happened to expose the Qt bug.

Is it possible that some needed libraries (e.g. liblancelot) were not updated in addition to KDE Plasma?
Comment 57 Adam Porter 2013-02-14 11:29:01 UTC
I'm confused.  This bug was reported before the new year, while 4.10 was in beta.  It affects a Plasma applet that nearly every KDE user uses, therefore it will cause nearly every user to suffer crashes or runaway CPU usage.  For many users, if not most, it will make the KDE desktop completely unusable.  For many users, it will happen inexplicably, without warning, after upgrading KDE, so their system will suddenly become unusable.  Many of these users will not have alternative DEs installed, and many will not know how to search for answers using a terminal (not to mention the users whose networking won't work unless a GUI is running for NetworkManager).  Many of them won't have other computers to use to search for answers.

Despite all this, KDE 4.10 was released to the public.

Why?
Comment 58 Aaron J. Seigo 2013-02-14 11:51:28 UTC
@Adam Porter: This is perhaps the least useful place to have such a discussion. Your question is a good one, and evidently you are missing many of the salient details, perhaps not helped by an atrociously bad blog entry on planetkde.org.  Feel free to contact me on irc.freenode.net or Google+ if you want to explore this a bit more.
Comment 59 Alexandre Bonneau 2013-02-14 18:45:37 UTC
For information, I managed to recreate a planel/widget configuration where plasma-desktop doesn't crash, mostly by removing one specific plugin : "paste" (not pastebin which work well).
Comment 60 Vangelis 2013-02-18 11:47:59 UTC
(In reply to comment #58)
> @Adam Porter: This is perhaps the least useful place to have such a
> discussion. Your question is a good one, and evidently you are missing many
> of the salient details, perhaps not helped by an atrociously bad blog entry
> on planetkde.org.  Feel free to contact me on irc.freenode.net or Google+ if
> you want to explore this a bit more.

Aaron, can you please write a blog post about it exploring this a bit more? I have some of the same issues and questions, and I probably face this bug as well. KDE 4.10 is the most unusable KDE SC release for me since I ever used KDE back in 2005. I wouldn't want to bother you in Google+, IRC, Facebook etc, because if everyone does this, I guess you will have no time to answer to everyone, plus you will be very annoyed. I posted my sad story in the kde forums here: http://forum.kde.org/viewtopic.php?f=15&t=110059
Comment 61 Hrvoje Senjan 2013-02-18 19:37:41 UTC
(In reply to comment #59)
> For information, I managed to recreate a planel/widget configuration where
> plasma-desktop doesn't crash, mostly by removing one specific plugin :
> "paste" (not pastebin which work well).

Then you are hit by # 312075, not this one. Infact "only" Gentoo users provided bt here, so please verify by backtrace that you are indeed victim of this bug before posting. There is also # 311871 worth checking before applying to membership on this one.
Comment 62 Andreas K. Huettel 2013-02-18 19:44:29 UTC
(In reply to comment #61)
> (In reply to comment #59)
> > For information, I managed to recreate a planel/widget configuration where
> > plasma-desktop doesn't crash, mostly by removing one specific plugin :
> > "paste" (not pastebin which work well).
> 
> Then you are hit by # 312075, not this one. Infact "only" Gentoo users
> provided bt here, so please verify by backtrace that you are indeed victim
> of this bug before posting. There is also # 311871 worth checking before
> applying to membership on this one.

Exactly. Please veryify that you have this exact bug by checking the backtrace.
[No more from Gentoo will be coming here since we've patched.]
Comment 63 Jekyll Wu 2013-02-19 14:07:22 UTC
*** Bug 315427 has been marked as a duplicate of this bug. ***
Comment 64 David E. Narvaez 2013-03-21 19:45:38 UTC
*** Bug 316988 has been marked as a duplicate of this bug. ***