Bug 311747 - No icons in few system tray entries (sni-qt related)
Summary: No icons in few system tray entries (sni-qt related)
Status: RESOLVED DUPLICATE of bug 311555
Alias: None
Product: plasma4
Classification: Unclassified
Component: widget-systemtray (show other bugs)
Version: 4.9.90 Beta2
Platform: Ubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-12-15 20:54 UTC by Admc
Modified: 2012-12-16 03:28 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
System tray screenshot (10.54 KB, image/png)
2012-12-15 20:54 UTC, Admc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Admc 2012-12-15 20:54:02 UTC
Created attachment 75853 [details]
System tray screenshot

All apps in ubuntu must support libindicator (aka ayatana) system tray icons, because unity doesn't show legacy system tray icons. Fortunately KDE support both ayatana and legacy system tray icons. In KDE 4.10 systemtray plasmoid was rewritten which caused a regression. There's a problem which appears when sni-qt package is installed. Some qt apps are using sni-qt to provide ayatana consistent system tray entries. Those apps' system tray icons are just displaying generic "missing icon" instead of normal system tray icons (see screenshot). Temporary workaround is to uninstall sni-qt package.
Comment 1 Jekyll Wu 2012-12-16 03:28:25 UTC

*** This bug has been marked as a duplicate of bug 311555 ***